summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/quilt/ChangeLog8
-rw-r--r--dev-util/quilt/files/quilt-0.50-no-graphviz.patch47
-rw-r--r--dev-util/quilt/quilt-0.50.ebuild59
3 files changed, 113 insertions, 1 deletions
diff --git a/dev-util/quilt/ChangeLog b/dev-util/quilt/ChangeLog
index 1db37fb88fd8..48406b03a6a3 100644
--- a/dev-util/quilt/ChangeLog
+++ b/dev-util/quilt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/quilt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/ChangeLog,v 1.49 2011/01/04 01:29:30 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/ChangeLog,v 1.50 2011/12/29 23:00:52 mpagano Exp $
+
+*quilt-0.50 (29 Dec 2011)
+
+ 29 Dec 2011; Michael Pagano <mpagano@gentoo.org> +quilt-0.50.ebuild,
+ +files/quilt-0.50-no-graphviz.patch:
+ Version bump. bug #396323. Thanks to Marco Paolone.
04 Jan 2011; Michael Weber <xmw@gentoo.org> quilt-0.48.ebuild:
arm stable (bug 327625)
diff --git a/dev-util/quilt/files/quilt-0.50-no-graphviz.patch b/dev-util/quilt/files/quilt-0.50-no-graphviz.patch
new file mode 100644
index 000000000000..04e0d7d3a9a1
--- /dev/null
+++ b/dev-util/quilt/files/quilt-0.50-no-graphviz.patch
@@ -0,0 +1,47 @@
+Index: b/Makefile.in
+===================================================================
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -82,8 +82,7 @@ QUILT := $(QUILT_IN)
+ SRC += $(QUILT_SRC:%=quilt/%)
+ DIRT += $(QUILT_IN:%=quilt/%)
+
+-SCRIPTS_IN := patchfns parse-patch inspect dependency-graph edmail \
+- remove-trailing-ws
++SCRIPTS_IN := patchfns parse-patch inspect edmail remove-trailing-ws
+
+ SCRIPTS_SRC := $(SCRIPTS_IN:%=%.in)
+ SCRIPTS := $(SCRIPTS_IN)
+Index: b/bash_completion
+===================================================================
+--- a/bash_completion
++++ b/bash_completion
+@@ -95,7 +95,7 @@ _quilt_completion()
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ # quilt sub commands
+- cmds='add annotate applied delete diff edit files fold fork graph \
++ cmds='add annotate applied delete diff edit files fold fork \
+ grep header import mail new next patches pop previous push refresh \
+ remove rename revert series setup snapshot top unapplied'
+
+@@ -189,19 +189,6 @@ _quilt_completion()
+ ;;
+ esac
+ ;;
+- graph)
+- case $prev in
+- -T)
+- COMPREPLY=( $( compgen -W "ps" -- $cur ) )
+- ;;
+- --edge-labels)
+- COMPREPLY=( $( compgen -W "files" -- $cur ) )
+- ;;
+- *)
+- COMPREPLY=( $( compgen -W "-T -h --all --reduce --lines --edge-labels $(quilt applied 2>/dev/null)" -- $cur ) )
+- ;;
+- esac
+- ;;
+ grep)
+ _longopt grep
+ COMPREPLY=( ${COMPREPLY[@]:-} $( compgen -W "-h" -- $cur ) )
diff --git a/dev-util/quilt/quilt-0.50.ebuild b/dev-util/quilt/quilt-0.50.ebuild
new file mode 100644
index 000000000000..8d0c1eafa187
--- /dev/null
+++ b/dev-util/quilt/quilt-0.50.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/quilt-0.50.ebuild,v 1.1 2011/12/29 23:00:52 mpagano Exp $
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="quilt patch manager"
+HOMEPAGE="http://savannah.nongnu.org/projects/quilt"
+SRC_URI="http://savannah.nongnu.org/download/quilt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="emacs graphviz"
+
+RDEPEND="sys-apps/ed
+ dev-util/diffstat
+ graphviz? ( media-gfx/graphviz )
+ >=sys-apps/coreutils-8.5"
+
+PDEPEND="emacs? ( app-emacs/quilt-el )"
+
+pkg_setup() {
+ use graphviz && return 0
+ echo
+ elog "If you intend to use the folding functionality (graphical illustration of the"
+ elog "patch stack) then you'll need to remerge this package with USE=graphviz."
+ echo
+ epause 5
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Add support for USE=graphviz
+ use graphviz || epatch "${FILESDIR}/${P}-no-graphviz.patch"
+
+ # Some tests are somewhat broken while being run from within portage, work
+ # fine if you run them manually
+ rm "${S}"/test/delete.test "${S}"/test/mail.test
+}
+
+src_install() {
+ emake BUILD_ROOT="${D}" install || die "make install failed"
+
+ rm -rf "${D}"/usr/share/doc/${P}
+ dodoc AUTHORS TODO quilt.changes doc/README doc/README.MAIL \
+ doc/quilt.pdf
+
+ rm -rf "${D}"/etc/bash_completion.d
+ newbashcomp bash_completion ${PN}
+
+ # Remove the compat symlinks
+ rm -rf "${D}"/usr/share/quilt/compat
+
+ # Remove Emacs mode; newer version is in app-emacs/quilt-el, bug 247500
+ rm -rf "${D}"/usr/share/emacs
+}