summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/glut/ChangeLog10
-rw-r--r--dev-haskell/glut/glut-2.1.1.2.ebuild29
-rw-r--r--dev-haskell/glut/glut-2.1.1.ebuild6
3 files changed, 40 insertions, 5 deletions
diff --git a/dev-haskell/glut/ChangeLog b/dev-haskell/glut/ChangeLog
index c799cd9e3a8e..c9a7b477649b 100644
--- a/dev-haskell/glut/ChangeLog
+++ b/dev-haskell/glut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/glut
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/ChangeLog,v 1.9 2008/10/03 23:28:35 fmccor Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/ChangeLog,v 1.10 2009/04/19 11:57:43 kolmodin Exp $
+
+*glut-2.1.1.2 (19 Apr 2009)
+
+ 19 Apr 2009; Lennart Kolmodin <kolmodin@gentoo.org> glut-2.1.1.ebuild,
+ +glut-2.1.1.2.ebuild:
+ Version bump and QA.
03 Oct 2008; Ferris McCormick <fmccor@gentoo.org> glut-2.1.1.1.ebuild:
Sparc stable --- Bug #230919 and Bug #239368.
diff --git a/dev-haskell/glut/glut-2.1.1.2.ebuild b/dev-haskell/glut/glut-2.1.1.2.ebuild
new file mode 100644
index 000000000000..69daa2ba187b
--- /dev/null
+++ b/dev-haskell/glut/glut-2.1.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/glut-2.1.1.2.ebuild,v 1.1 2009/04/19 11:57:43 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+MY_PN="GLUT"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding for the OpenGL Utility Toolkit"
+HOMEPAGE="http://www.haskell.org/HOpenGL/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.6.1
+ >=dev-haskell/opengl-2.2
+ virtual/glu
+ virtual/glut"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"
+
+# TODO: Install examples when the "examples" USE flag is set
diff --git a/dev-haskell/glut/glut-2.1.1.ebuild b/dev-haskell/glut/glut-2.1.1.ebuild
index 4404614ef866..94ea0d29478a 100644
--- a/dev-haskell/glut/glut-2.1.1.ebuild
+++ b/dev-haskell/glut/glut-2.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/glut-2.1.1.ebuild,v 1.6 2007/12/16 20:34:05 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/glut-2.1.1.ebuild,v 1.7 2009/04/19 11:57:43 kolmodin Exp $
CABAL_FEATURES="haddock lib profile"
inherit haskell-cabal
@@ -27,6 +27,6 @@ DEPEND=">=dev-lang/ghc-6.6
S="${WORKDIR}/ghc-${GHC_PV}/libraries/${MY_PN}"
src_unpack() {
- unpack "${A}"
+ unpack ${A}
cabal-mksetup
}