summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/netwatch/ChangeLog10
-rw-r--r--net-analyzer/netwatch/files/netwatch-1.3.0.1-includes.patch22
-rw-r--r--net-analyzer/netwatch/netwatch-1.3.0.1-r3.ebuild49
3 files changed, 79 insertions, 2 deletions
diff --git a/net-analyzer/netwatch/ChangeLog b/net-analyzer/netwatch/ChangeLog
index 2f2eb42eb0bf..ef401d3c727b 100644
--- a/net-analyzer/netwatch/ChangeLog
+++ b/net-analyzer/netwatch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/netwatch
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwatch/ChangeLog,v 1.18 2013/12/23 02:20:08 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwatch/ChangeLog,v 1.19 2014/10/12 10:06:10 jer Exp $
+
+*netwatch-1.3.0.1-r3 (12 Oct 2014)
+
+ 12 Oct 2014; Jeroen Roovers <jer@gentoo.org> +netwatch-1.3.0.1-r3.ebuild,
+ +files/netwatch-1.3.0.1-includes.patch:
+ Fix some missing includes.
23 Dec 2013; Jeroen Roovers <jer@gentoo.org>
files/netwatch-1.3.0.1-fix-fortify.patch:
diff --git a/net-analyzer/netwatch/files/netwatch-1.3.0.1-includes.patch b/net-analyzer/netwatch/files/netwatch-1.3.0.1-includes.patch
new file mode 100644
index 000000000000..f0f0ea508a71
--- /dev/null
+++ b/net-analyzer/netwatch/files/netwatch-1.3.0.1-includes.patch
@@ -0,0 +1,22 @@
+--- a/warning.c
++++ b/warning.c
+@@ -2,6 +2,9 @@
+ #include "netwatch.h"
+ #include <syslog.h>
+ #include <stdio.h>
++#include <time.h> /* time() ctime() */
++#include <stdlib.h> /* system() */
++#include <unistd.h> /* unlink() */
+
+ static FILE *tmpfp;
+ static char tmpname[256];
+--- a/netwatch.c
++++ b/netwatch.c
+@@ -71,6 +71,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
++#include <ctype.h> /* isalnum() isspace() ispunct() */
+ /*
+ * #include <sys/socket.h>
+ */
diff --git a/net-analyzer/netwatch/netwatch-1.3.0.1-r3.ebuild b/net-analyzer/netwatch/netwatch-1.3.0.1-r3.ebuild
new file mode 100644
index 000000000000..9a51f4d5495e
--- /dev/null
+++ b/net-analyzer/netwatch/netwatch-1.3.0.1-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwatch/netwatch-1.3.0.1-r3.ebuild,v 1.1 2014/10/12 10:06:10 jer Exp $
+
+EAPI=5
+inherit autotools eutils versionator
+
+MY_PV=$(replace_version_separator 3 '-')
+
+DESCRIPTION="Ethernet/PPP IP Packet Monitor"
+HOMEPAGE="http://www.slctech.org/~mackay/netwatch.html"
+SRC_URI="http://www.slctech.org/~mackay/NETWATCH/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="
+ ${RDEPEND}
+ sys-kernel/linux-headers
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-append_ldflags.patch \
+ "${FILESDIR}"/${P}-open.patch \
+ "${FILESDIR}"/${P}-fix-fortify.patch \
+ "${FILESDIR}"/${P}-do-not-call.patch \
+ "${FILESDIR}"/${P}-includes.patch \
+ "${FILESDIR}"/${P}-tinfo.patch
+
+ eautoreconf
+}
+
+src_install() {
+ dosbin netresolv netwatch
+
+ doman netwatch.1
+ dodoc BUGS CHANGES README* TODO
+
+ if use doc; then
+ dohtml NetwatchKeyCommands.html
+ fi
+}