summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/last/ChangeLog9
-rw-r--r--sci-biology/last/last-128-r1.ebuild (renamed from sci-biology/last/last-103.ebuild)15
-rw-r--r--sci-biology/last/last-128.ebuild34
3 files changed, 14 insertions, 44 deletions
diff --git a/sci-biology/last/ChangeLog b/sci-biology/last/ChangeLog
index ff2157d428b7..5ea45c4e4961 100644
--- a/sci-biology/last/ChangeLog
+++ b/sci-biology/last/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/last
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.6 2010/07/15 15:49:58 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.7 2010/09/15 20:51:44 xarthisius Exp $
+
+*last-128-r1 (15 Sep 2010)
+
+ 15 Sep 2010; Kacper Kowalik <xarthisius@gentoo.org> -last-103.ebuild,
+ -last-128.ebuild, +last-128-r1.ebuild:
+ Respect CXX,CXXFLAGS,LDFLAGS wrt bug 337525. Thanks to Diego for the
+ report. Drop old.
*last-128 (15 Jul 2010)
diff --git a/sci-biology/last/last-103.ebuild b/sci-biology/last/last-128-r1.ebuild
index ede712fe8547..ca98f1c7eda0 100644
--- a/sci-biology/last/last-103.ebuild
+++ b/sci-biology/last/last-128-r1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-103.ebuild,v 1.1 2010/05/07 19:35:18 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-128-r1.ebuild,v 1.1 2010/09/15 20:51:44 xarthisius Exp $
EAPI="2"
+inherit toolchain-funcs
+
DESCRIPTION="Genome-scale comparison of biological sequences"
HOMEPAGE="http://last.cbrc.jp/"
SRC_URI="http://last.cbrc.jp/archive/${P}.zip"
@@ -16,19 +18,14 @@ KEYWORDS="~amd64 ~x86"
DEPEND="app-arch/unzip"
RDEPEND=""
-src_prepare() {
- sed -i -e 's/CXXFLAGS =/CXXFLAGS +=/' -e 's/CCFLAGS =/CCFLAGS = ${CFLAGS}/' \
- src/makefile || die
-}
-
src_compile() {
- emake -C src || die
+ emake -e -C src CXX="$(tc-getCXX)" \
+ STRICT="${LDFLAGS}" || die
}
src_install() {
dobin src/last{al,db} || die
exeinto /usr/share/${PN}/scripts
doexe scripts/* || die
- insinto /usr/share/doc/${PF}
- doins -r doc ChangeLog.txt README.txt
+ dodoc doc/*.txt ChangeLog.txt README.txt || die
}
diff --git a/sci-biology/last/last-128.ebuild b/sci-biology/last/last-128.ebuild
deleted file mode 100644
index 1903f79e1289..000000000000
--- a/sci-biology/last/last-128.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-128.ebuild,v 1.1 2010/07/15 15:49:58 weaver Exp $
-
-EAPI="2"
-
-DESCRIPTION="Genome-scale comparison of biological sequences"
-HOMEPAGE="http://last.cbrc.jp/"
-SRC_URI="http://last.cbrc.jp/archive/${P}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE=""
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-src_prepare() {
- sed -i -e 's/CXXFLAGS =/CXXFLAGS +=/' -e 's/CCFLAGS =/CCFLAGS = ${CFLAGS}/' \
- src/makefile || die
-}
-
-src_compile() {
- emake -C src || die
-}
-
-src_install() {
- dobin src/last{al,db} || die
- exeinto /usr/share/${PN}/scripts
- doexe scripts/* || die
- insinto /usr/share/doc/${PF}
- doins -r doc ChangeLog.txt README.txt
-}