summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/iso-codes/ChangeLog7
-rw-r--r--app-text/iso-codes/files/digest-iso-codes-1.53
-rw-r--r--app-text/iso-codes/iso-codes-1.5.ebuild39
3 files changed, 48 insertions, 1 deletions
diff --git a/app-text/iso-codes/ChangeLog b/app-text/iso-codes/ChangeLog
index 30df84fdc5d3..f7783b0f5087 100644
--- a/app-text/iso-codes/ChangeLog
+++ b/app-text/iso-codes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/iso-codes
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.33 2007/05/26 11:29:51 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.34 2007/10/13 23:55:14 eva Exp $
+
+*iso-codes-1.5 (13 Oct 2007)
+
+ 13 Oct 2007; Gilles Dartiguelongue <eva@gentoo.org> +iso-codes-1.5.ebuild:
+ bump to 1.5 (fix bug #179864)
26 May 2007; Mart Raudsepp <leio@gentoo.org>
-files/iso-codes-0.49-bsd-install.patch,
diff --git a/app-text/iso-codes/files/digest-iso-codes-1.5 b/app-text/iso-codes/files/digest-iso-codes-1.5
new file mode 100644
index 000000000000..12648c6a2d49
--- /dev/null
+++ b/app-text/iso-codes/files/digest-iso-codes-1.5
@@ -0,0 +1,3 @@
+MD5 96632aa78b23f2149e126c6b890db059 iso-codes-1.5.tar.bz2 6454911
+RMD160 78b8c332342d015a241f3e60a0fa5f538842b91b iso-codes-1.5.tar.bz2 6454911
+SHA256 73cd117de4a61de76d47f8e36bd10594b59d6758e182a9027a9078dbde969f39 iso-codes-1.5.tar.bz2 6454911
diff --git a/app-text/iso-codes/iso-codes-1.5.ebuild b/app-text/iso-codes/iso-codes-1.5.ebuild
new file mode 100644
index 000000000000..c718bdee7f65
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-1.5.ebuild,v 1.1 2007/10/13 23:55:14 eva Exp $
+
+WANT_AUTOMAKE="latest"
+inherit eutils autotools
+
+DESCRIPTION="Provides the list of country and language names"
+HOMEPAGE="http://alioth.debian.org/projects/pkg-isocodes/"
+SRC_URI="ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="sys-devel/gettext
+ >=dev-lang/python-2.3
+ >=sys-devel/automake-1.9"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix install location for multilib machines
+ sed -i -e 's:(datadir)/pkgconfig:(libdir)/pkgconfig:g' Makefile.am
+
+ eautomake
+}
+
+src_compile() {
+ econf || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc ChangeLog README TODO
+}