summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mail/mailutils/ChangeLog10
-rw-r--r--net-mail/mailutils/files/mailutils-2.1-python.patch22
-rw-r--r--net-mail/mailutils/mailutils-2.1.ebuild62
3 files changed, 92 insertions, 2 deletions
diff --git a/net-mail/mailutils/ChangeLog b/net-mail/mailutils/ChangeLog
index f9fa6e49e27e..fecda4f7c2a8 100644
--- a/net-mail/mailutils/ChangeLog
+++ b/net-mail/mailutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/mailutils
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/ChangeLog,v 1.38 2009/03/16 09:44:22 bangert Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/ChangeLog,v 1.39 2010/01/21 20:22:51 jer Exp $
+
+*mailutils-2.1 (21 Jan 2010)
+
+ 21 Jan 2010; Jeroen Roovers <jer@gentoo.org> +mailutils-2.1.ebuild,
+ +files/mailutils-2.1-python.patch:
+ Version bump thanks to Arfrever Frehtes Taifersar Arahesis (bug #252749).
16 Mar 2009; Thilo Bangert <bangert@gentoo.org> mailutils-0.6-r3.ebuild,
mailutils-1.2.ebuild:
diff --git a/net-mail/mailutils/files/mailutils-2.1-python.patch b/net-mail/mailutils/files/mailutils-2.1-python.patch
new file mode 100644
index 000000000000..221b737fa906
--- /dev/null
+++ b/net-mail/mailutils/files/mailutils-2.1-python.patch
@@ -0,0 +1,22 @@
+--- python/libmu_py/Makefile.in.org 2009-09-10 21:18:43.000000000 +0200
++++ python/libmu_py/Makefile.in 2010-01-21 19:51:58.000000000 +0100
+@@ -122,7 +122,7 @@
+ "$(DESTDIR)$(lispdir)"
+ LTLIBRARIES = $(lib_LTLIBRARIES) $(pythonexec_LTLIBRARIES)
+ am__DEPENDENCIES_1 =
+-c_api_la_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
++c_api_la_DEPENDENCIES = libmu_py.la
+ am_c_api_la_OBJECTS = c_api.lo
+ c_api_la_OBJECTS = $(am_c_api_la_OBJECTS)
+ AM_V_lt = $(am__v_lt_$(V))
+--- python/libmu_py/Makefile.in.org 2010-01-21 19:54:19.000000000 +0100
++++ python/libmu_py/Makefile.in 2010-01-21 20:29:56.000000000 +0100
+@@ -886,7 +886,7 @@
+ echo "rm -f \"$${dir}/so_locations\""; \
+ rm -f "$${dir}/so_locations"; \
+ done
+-install-pythonexecLTLIBRARIES: $(pythonexec_LTLIBRARIES)
++install-pythonexecLTLIBRARIES: $(pythonexec_LTLIBRARIES) install-libLTLIBRARIES
+ @$(NORMAL_INSTALL)
+ test -z "$(pythonexecdir)" || $(MKDIR_P) "$(DESTDIR)$(pythonexecdir)"
+ @list='$(pythonexec_LTLIBRARIES)'; test -n "$(pythonexecdir)" || list=; \
diff --git a/net-mail/mailutils/mailutils-2.1.ebuild b/net-mail/mailutils/mailutils-2.1.ebuild
new file mode 100644
index 000000000000..d62c170e8716
--- /dev/null
+++ b/net-mail/mailutils/mailutils-2.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/mailutils-2.1.ebuild,v 1.1 2010/01/21 20:22:51 jer Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic python
+
+DESCRIPTION="A useful collection of mail servers, clients, and filters."
+HOMEPAGE="http://www.gnu.org/software/mailutils/mailutils.html"
+SRC_URI="http://ftp.gnu.org/gnu/mailutils/${P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="gdbm guile mysql nls pam postgres python test"
+PROVIDE="virtual/mailx"
+
+RDEPEND="!virtual/mailx
+ !mail-client/nmh
+ !mail-filter/libsieve
+ guile? ( dev-scheme/guile )
+ gdbm? ( sys-libs/gdbm )
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )
+ nls? ( sys-devel/gettext )
+ virtual/mta"
+
+DEPEND="${RDEPEND}
+ test? ( dev-util/dejagnu )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-python.patch
+}
+
+src_configure() {
+ # TODO: Fix this breakage, starting in examples/cpp/
+ append-ldflags $(no-as-needed)
+
+ local myconf="--localstatedir=/var --sharedstatedir=/var"
+ myconf="${myconf} --enable-mh"
+
+ # We need sendmail or compiling will fail
+ myconf="${myconf} --enable-sendmail"
+
+ econf ${myconf} \
+ $(use_with gdbm) \
+ $(use_with guile) \
+ $(use_with mysql) \
+ $(use_with postgres) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_with python) \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ # mail.rc stolen from mailx, resolve bug #37302.
+ insinto /etc
+ doins "${FILESDIR}/mail.rc"
+}