summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/agda-executable/ChangeLog12
-rw-r--r--sci-mathematics/agda-executable/agda-executable-2.3.0.1.ebuild32
-rw-r--r--sci-mathematics/agda-executable/agda-executable-2.3.0.ebuild32
-rw-r--r--sci-mathematics/agda-executable/metadata.xml13
4 files changed, 89 insertions, 0 deletions
diff --git a/sci-mathematics/agda-executable/ChangeLog b/sci-mathematics/agda-executable/ChangeLog
new file mode 100644
index 000000000000..28a5668815e4
--- /dev/null
+++ b/sci-mathematics/agda-executable/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sci-mathematics/agda-executable
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-executable/ChangeLog,v 1.1 2012/03/25 14:09:18 gienah Exp $
+
+*agda-executable-2.3.0 (25 Mar 2012)
+*agda-executable-2.3.0.1 (25 Mar 2012)
+
+ 25 Mar 2012; Mark Wright <gienah@gentoo.org> +agda-executable-2.3.0.1.ebuild,
+ +agda-executable-2.3.0.ebuild, +metadata.xml:
+ Add agda-executable, Command-line program for type-checking and compiling Agda
+ programs.
+
diff --git a/sci-mathematics/agda-executable/agda-executable-2.3.0.1.ebuild b/sci-mathematics/agda-executable/agda-executable-2.3.0.1.ebuild
new file mode 100644
index 000000000000..b843dfac1904
--- /dev/null
+++ b/sci-mathematics/agda-executable/agda-executable-2.3.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-executable/agda-executable-2.3.0.1.ebuild,v 1.1 2012/03/25 14:09:18 gienah Exp $
+
+EAPI="4"
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal eutils
+
+MY_PN="Agda-executable"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command-line program for type-checking and compiling Agda programs"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ ~sci-mathematics/agda-${PV}
+ >=dev-haskell/cabal-1.8
+ >=dev-lang/ghc-6.8.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cabal-mksetup
+}
diff --git a/sci-mathematics/agda-executable/agda-executable-2.3.0.ebuild b/sci-mathematics/agda-executable/agda-executable-2.3.0.ebuild
new file mode 100644
index 000000000000..fd6101ad6f37
--- /dev/null
+++ b/sci-mathematics/agda-executable/agda-executable-2.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-executable/agda-executable-2.3.0.ebuild,v 1.1 2012/03/25 14:09:18 gienah Exp $
+
+EAPI="3"
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal eutils
+
+MY_PN="Agda-executable"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command-line program for type-checking and compiling Agda programs"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ ~sci-mathematics/agda-2.3.0
+ >=dev-haskell/cabal-1.8
+ >=dev-lang/ghc-6.8.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cabal-mksetup
+}
diff --git a/sci-mathematics/agda-executable/metadata.xml b/sci-mathematics/agda-executable/metadata.xml
new file mode 100644
index 000000000000..58fbc0e32043
--- /dev/null
+++ b/sci-mathematics/agda-executable/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package provides a command-line program for type-checking and
+ compiling Agda programs. The program can also generate hyperlinked,
+ highlighted HTML files from Agda sources.
+ </longdescription>
+</pkgmetadata>