summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/bfgminer/ChangeLog9
-rw-r--r--net-misc/bfgminer/bfgminer-3.10.0.ebuild148
-rw-r--r--net-misc/bfgminer/bfgminer-3.5.7.ebuild138
-rw-r--r--net-misc/bfgminer/metadata.xml3
4 files changed, 297 insertions, 1 deletions
diff --git a/net-misc/bfgminer/ChangeLog b/net-misc/bfgminer/ChangeLog
index 71f69955eff7..08484dd110f5 100644
--- a/net-misc/bfgminer/ChangeLog
+++ b/net-misc/bfgminer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/bfgminer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/ChangeLog,v 1.52 2014/01/01 23:46:40 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/ChangeLog,v 1.53 2014/01/18 14:05:06 blueness Exp $
+
+*bfgminer-3.5.7 (18 Jan 2014)
+*bfgminer-3.10.0 (18 Jan 2014)
+
+ 18 Jan 2014; Anthony G. Basile <blueness@gentoo.org> +bfgminer-3.10.0.ebuild,
+ +bfgminer-3.5.7.ebuild, metadata.xml:
+ Version bump
*bfgminer-3.5.4 (01 Jan 2014)
*bfgminer-3.8.1 (01 Jan 2014)
diff --git a/net-misc/bfgminer/bfgminer-3.10.0.ebuild b/net-misc/bfgminer/bfgminer-3.10.0.ebuild
new file mode 100644
index 000000000000..8d864ba94ba9
--- /dev/null
+++ b/net-misc/bfgminer/bfgminer-3.10.0.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/bfgminer-3.10.0.ebuild,v 1.1 2014/01/18 14:05:06 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Modular Bitcoin ASIC/FPGA/GPU/CPU miner in C"
+HOMEPAGE="https://bitcointalk.org/?topic=168174"
+SRC_URI="http://luke.dashjr.org/programs/bitcoin/files/${PN}/${PV}/${P}.tbz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+# Waiting for dev-libs/hidapi to be keyworded
+#KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+
+# TODO: knc (needs i2c-tools header)
+IUSE="+adl antminer avalon bifury bitforce bfsb bigpic bitfury cpumining drillbit examples hardened hashbuster hashbuster2 hashfast icarus klondike +libusb littlefury lm_sensors metabank modminer nanofury ncurses +opencl proxy proxy_getwork proxy_stratum scrypt twinfury +udev unicode x6500 ztex"
+REQUIRED_USE="
+ || ( avalon bitforce cpumining icarus modminer opencl proxy x6500 ztex )
+ adl? ( opencl )
+ bfsb? ( bitfury )
+ bigpic? ( bitfury )
+ drillbit? ( bitfury )
+ hashbuster? ( bitfury )
+ hashbuster2? ( bitfury libusb )
+ klondike? ( libusb )
+ littlefury? ( bitfury )
+ lm_sensors? ( opencl )
+ metabank? ( bitfury )
+ nanofury? ( bitfury )
+ scrypt? ( || ( cpumining opencl ) )
+ twinfury? ( bitfury )
+ unicode? ( ncurses )
+ proxy? ( || ( proxy_getwork proxy_stratum ) )
+ proxy_getwork? ( proxy )
+ proxy_stratum? ( proxy )
+ x6500? ( libusb )
+ ztex? ( libusb )
+"
+
+DEPEND="
+ net-misc/curl
+ ncurses? (
+ sys-libs/ncurses[unicode?]
+ )
+ >=dev-libs/jansson-2
+ net-libs/libblkmaker
+ udev? (
+ virtual/udev
+ )
+ hashbuster? (
+ dev-libs/hidapi
+ )
+ libusb? (
+ virtual/libusb:1
+ )
+ lm_sensors? (
+ sys-apps/lm_sensors
+ )
+ nanofury? (
+ dev-libs/hidapi
+ )
+ proxy_getwork? (
+ net-libs/libmicrohttpd
+ )
+ proxy_stratum? (
+ dev-libs/libevent
+ )
+"
+RDEPEND="${DEPEND}
+ opencl? (
+ virtual/opencl
+ )
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ >=dev-libs/uthash-1.9.7
+ sys-apps/sed
+ cpumining? (
+ amd64? (
+ >=dev-lang/yasm-1.0.1
+ )
+ x86? (
+ >=dev-lang/yasm-1.0.1
+ )
+ )
+"
+
+src_configure() {
+ local CFLAGS="${CFLAGS}"
+ local with_curses
+ use hardened && CFLAGS="${CFLAGS} -nopie"
+
+ if use ncurses; then
+ if use unicode; then
+ with_curses='--with-curses=ncursesw'
+ else
+ with_curses='--with-curses=ncurses'
+ fi
+ else
+ with_curses='--without-curses'
+ fi
+
+ CFLAGS="${CFLAGS}" \
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable adl) \
+ $(use_enable antminer) \
+ $(use_enable avalon) \
+ $(use_enable bifury) \
+ $(use_enable bitforce) \
+ $(use_enable bfsb) \
+ $(use_enable bigpic) \
+ $(use_enable bitfury) \
+ $(use_enable cpumining) \
+ $(use_enable drillbit) \
+ $(use_enable hashbuster) \
+ $(use_enable hashbuster2) \
+ $(use_enable hashfast) \
+ $(use_enable icarus) \
+ $(use_enable klondike) \
+ $(use_enable littlefury) \
+ $(use_enable metabank) \
+ $(use_enable modminer) \
+ $(use_enable nanofury) \
+ $(use_enable opencl) \
+ $(use_enable scrypt) \
+ $(use_enable twinfury) \
+ --with-system-libblkmaker \
+ $with_curses \
+ $(use_with udev libudev) \
+ $(use_with lm_sensors sensors) \
+ $(use_with proxy_getwork libmicrohttpd) \
+ $(use_with proxy_stratum libevent) \
+ $(use_enable x6500) \
+ $(use_enable ztex)
+}
+
+src_install() {
+ emake install DESTDIR="$D"
+ if ! use examples; then
+ rm -r "${D}/usr/share/doc/${PF}/rpc-examples"
+ fi
+}
diff --git a/net-misc/bfgminer/bfgminer-3.5.7.ebuild b/net-misc/bfgminer/bfgminer-3.5.7.ebuild
new file mode 100644
index 000000000000..ddafcb1b4eef
--- /dev/null
+++ b/net-misc/bfgminer/bfgminer-3.5.7.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/bfgminer-3.5.7.ebuild,v 1.1 2014/01/18 14:05:06 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Modular Bitcoin ASIC/FPGA/GPU/CPU miner in C"
+HOMEPAGE="https://bitcointalk.org/?topic=168174"
+SRC_URI="http://luke.dashjr.org/programs/bitcoin/files/${PN}/${PV}/${P}.tbz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+# Waiting for dev-libs/hidapi to be keyworded
+#KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+
+# TODO: knc (needs i2c-tools header)
+IUSE="+adl avalon bitforce bfsb bigpic bitfury cpumining examples hardened hashbuster icarus littlefury lm_sensors metabank modminer nanofury ncurses +opencl proxy proxy_getwork proxy_stratum scrypt +udev unicode x6500 ztex"
+REQUIRED_USE="
+ || ( avalon bitforce cpumining icarus modminer opencl proxy x6500 ztex )
+ adl? ( opencl )
+ bfsb? ( bitfury )
+ bigpic? ( bitfury )
+ hashbuster? ( bitfury )
+ littlefury? ( bitfury )
+ lm_sensors? ( opencl )
+ metabank? ( bitfury )
+ nanofury? ( bitfury )
+ scrypt? ( || ( cpumining opencl ) )
+ unicode? ( ncurses )
+ proxy? ( || ( proxy_getwork proxy_stratum ) )
+ proxy_getwork? ( proxy )
+ proxy_stratum? ( proxy )
+"
+
+DEPEND="
+ net-misc/curl
+ ncurses? (
+ sys-libs/ncurses[unicode?]
+ )
+ >=dev-libs/jansson-2
+ net-libs/libblkmaker
+ udev? (
+ virtual/udev
+ )
+ hashbuster? (
+ dev-libs/hidapi
+ )
+ lm_sensors? (
+ sys-apps/lm_sensors
+ )
+ nanofury? (
+ dev-libs/hidapi
+ )
+ proxy_getwork? (
+ net-libs/libmicrohttpd
+ )
+ proxy_stratum? (
+ dev-libs/libevent
+ )
+ x6500? (
+ virtual/libusb:1
+ )
+ ztex? (
+ virtual/libusb:1
+ )
+"
+RDEPEND="${DEPEND}
+ opencl? (
+ virtual/opencl
+ )
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ >=dev-libs/uthash-1.9.2
+ sys-apps/sed
+ cpumining? (
+ amd64? (
+ >=dev-lang/yasm-1.0.1
+ )
+ x86? (
+ >=dev-lang/yasm-1.0.1
+ )
+ )
+"
+
+src_configure() {
+ local CFLAGS="${CFLAGS}"
+ local with_curses
+ use hardened && CFLAGS="${CFLAGS} -nopie"
+
+ if use ncurses; then
+ if use unicode; then
+ with_curses='--with-curses=ncursesw'
+ else
+ with_curses='--with-curses=ncurses'
+ fi
+ else
+ with_curses='--without-curses'
+ fi
+
+ CFLAGS="${CFLAGS}" \
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable adl) \
+ $(use_enable avalon) \
+ $(use_enable bitforce) \
+ $(use_enable bfsb) \
+ $(use_enable bigpic) \
+ $(use_enable bitfury) \
+ $(use_enable cpumining) \
+ $(use_enable hashbuster) \
+ $(use_enable icarus) \
+ $(use_enable littlefury) \
+ $(use_enable metabank) \
+ $(use_enable modminer) \
+ $(use_enable nanofury) \
+ $(use_enable opencl) \
+ $(use_enable scrypt) \
+ --with-system-libblkmaker \
+ $with_curses \
+ $(use_with udev libudev) \
+ $(use_with lm_sensors sensors) \
+ $(use_with proxy_getwork libmicrohttpd) \
+ $(use_with proxy_stratum libevent) \
+ $(use_enable x6500) \
+ $(use_enable ztex)
+}
+
+src_install() {
+ emake install DESTDIR="$D"
+ if ! use examples; then
+ rm -r "${D}/usr/share/doc/${PF}/rpc-examples"
+ fi
+}
diff --git a/net-misc/bfgminer/metadata.xml b/net-misc/bfgminer/metadata.xml
index 7cba60eeb7f2..4159c3e21138 100644
--- a/net-misc/bfgminer/metadata.xml
+++ b/net-misc/bfgminer/metadata.xml
@@ -12,6 +12,7 @@
</maintainer>
<use>
<flag name='adl'>Enable support for controlling fans and overclocking on AMD cards with AMD Display Library</flag>
+ <flag name='antminer'>Enable support for mining with AntMiner U1 sticks</flag>
<flag name='avalon'>Enable support for mining with Avalon ASIC modules</flag>
<flag name='bifury'>Enable support for mining with Bi*fury USB sticks</flag>
<flag name='bitforce'>Enable support for mining with ButterFly Labs BitFORCE ASICs and/or FPGAs</flag>
@@ -19,8 +20,10 @@
<flag name='bigpic'>Enable support for mining with Big Picture Mining USB sticks (Red/BlueFury, BF1, etc)</flag>
<flag name='bitfury'>Enable support for mining with 55nm Bitfury-based devices</flag>
<flag name='cpumining'>Enable support for mining with CPUs</flag>
+ <flag name='drillbit'>Enable support for mining with Drillbit boards</flag>
<flag name='hashbuster'>Enable support for mining with HashBuster nano boards</flag>
<flag name='hashbuster2'>Enable support for mining with HashBuster micro boards</flag>
+ <flag name='hashfast'>Enable support for mining with HashFast devices</flag>
<flag name='icarus'>Enable support for mining with Icarus-compatible devices (including Block Erupter Sapphire ASICs)</flag>
<flag name='klondike'>Enable support for mining with Klondike USB miners</flag>
<flag name='libusb'>Use libusb</flag>