summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/clapack/ChangeLog10
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r2.ebuild52
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r4.ebuild (renamed from sci-libs/clapack/clapack-3.2.1-r3.ebuild)14
-rw-r--r--sci-libs/clapack/files/3.2.1-solib.patch27
-rw-r--r--sci-libs/clapack/files/clapack-3.2.1-fix_include_file.patch25
-rw-r--r--sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch2
6 files changed, 42 insertions, 88 deletions
diff --git a/sci-libs/clapack/ChangeLog b/sci-libs/clapack/ChangeLog
index 6b6c8509d764..ee8e49d3dd00 100644
--- a/sci-libs/clapack/ChangeLog
+++ b/sci-libs/clapack/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/clapack
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/ChangeLog,v 1.10 2011/02/11 20:32:58 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/ChangeLog,v 1.11 2011/04/30 09:50:09 scarabeus Exp $
+
+*clapack-3.2.1-r4 (30 Apr 2011)
+
+ 30 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ -files/3.2.1-solib.patch, -clapack-3.2.1-r2.ebuild, -clapack-3.2.1-r3.ebuild,
+ +clapack-3.2.1-r4.ebuild, +files/clapack-3.2.1-fix_include_file.patch,
+ files/clapack-3.2.1-noblasf2c.patch:
+ Revision bump to make this work with cpp. Add missing include line.
11 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
clapack-3.2.1-r3.ebuild:
diff --git a/sci-libs/clapack/clapack-3.2.1-r2.ebuild b/sci-libs/clapack/clapack-3.2.1-r2.ebuild
deleted file mode 100644
index a1b55e57a7ae..000000000000
--- a/sci-libs/clapack/clapack-3.2.1-r2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/clapack-3.2.1-r2.ebuild,v 1.1 2010/04/25 09:40:16 jlec Exp $
-
-EAPI="3"
-
-inherit eutils multilib toolchain-funcs versionator
-
-DESCRIPTION="f2c'ed version of LAPACK"
-HOMEPAGE="http://www.netlib.org/clapack/"
-SRC_URI="http://www.netlib.org/${PN}/${P}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-libs/libf2c-20081126[static-libs]"
-DEPEND="${RDEPEND}"
-S="${WORKDIR}"/CLAPACK-${PV}
-
-src_prepare() {
- rm -rf F2CLIBS BLAS
-
- epatch "${FILESDIR}"/${PV}-solib.patch
-
- sed \
- -e "s:^CC.*$:CC = $(tc-getCC):g" \
- -e "s:^CFLAGS.*$:CFLAGS = ${CFLAGS} -fPIC:g" \
- -e "s:^LOADER.*$:LOADER = $(tc-getCC):g" \
- -e "s:^LOADOPTS.*$:LOADOPTS = ${LDFLAGS} -Wl,-soname,libclapack.so.$(get_version_component_range 1-2):g" \
- -e "s:LAPACKLIB.*$:LAPACKLIB = libclapack.so.${PV}:g" \
- make.inc.example > make.inc
-
- sed \
- -e 's:"f2c.h":<f2c.h>:g' \
- -i SRC/*.c || die
-}
-
-src_compile() {
- emake -C INSTALL F2CLIB="${EPREFIX}"/usr/$(get_libdir)/libf2c.a || die "compile failed"
- emake -C SRC || die "compile failed"
-}
-
-src_install() {
- insinto /usr/include/${PN}
- doins INCLUDE/${PN}.h || die
- dolib.so lib${PN}.so.${PV} || die
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.$(get_version_component_range 1-2) || die
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.$(get_major_version) || die
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so || die
-}
diff --git a/sci-libs/clapack/clapack-3.2.1-r3.ebuild b/sci-libs/clapack/clapack-3.2.1-r4.ebuild
index ffba480b3c12..ed5db6298a09 100644
--- a/sci-libs/clapack/clapack-3.2.1-r3.ebuild
+++ b/sci-libs/clapack/clapack-3.2.1-r4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/clapack-3.2.1-r3.ebuild,v 1.5 2011/02/11 20:32:58 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/clapack-3.2.1-r4.ebuild,v 1.1 2011/04/30 09:50:09 scarabeus Exp $
-EAPI="3"
+EAPI=4
-inherit eutils cmake-utils
+inherit base cmake-utils
DESCRIPTION="f2c'ed version of LAPACK"
HOMEPAGE="http://www.netlib.org/clapack/"
@@ -21,10 +21,10 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${P}-CMAKE
-src_prepare() {
- epatch "${FILESDIR}"/${P}-noblasf2c.patch
- rm -rf INCLUDE/f2c.h F2CLIBS || die
-}
+PATCHES=(
+ "${FILESDIR}/${P}-fix_include_file.patch"
+ "${FILESDIR}/${P}-noblasf2c.patch"
+)
src_configure() {
local mycmakeargs=( $(cmake-utils_use_enable test TESTS) )
diff --git a/sci-libs/clapack/files/3.2.1-solib.patch b/sci-libs/clapack/files/3.2.1-solib.patch
deleted file mode 100644
index c35a5f7a7d7e..000000000000
--- a/sci-libs/clapack/files/3.2.1-solib.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/SRC/Makefile b/SRC/Makefile
-index 47bea67..bc23ad8 100644
---- a/SRC/Makefile
-+++ b/SRC/Makefile
-@@ -367,8 +367,7 @@ ALLOBJ=$(SLASRC) $(DLASRC) $(CLASRC) $(ZLASRC) $(SCLAUX) $(DZLAUX) \
- $(ALLAUX)
-
- ../$(LAPACKLIB): $(ALLOBJ) $(ALLXOBJ)
-- $(ARCH) $(ARCHFLAGS) $@ $(ALLOBJ) $(ALLXOBJ)
-- $(RANLIB) $@
-+ $(CC) $(LOADOPTS) -shared -o $@ $(ALLOBJ) $(ALLXOBJ) -lf2c
-
- single: $(SLASRC) $(ALLAUX) $(SCLAUX)
- $(ARCH) $(ARCHFLAGS) ../$(LAPACKLIB) $(SLASRC) $(ALLAUX) \
-diff --git a/make.inc.example b/make.inc.example
-index 0ac8bbb..5a0eac6 100644
---- a/make.inc.example
-+++ b/make.inc.example
-@@ -27,7 +27,7 @@ CC = gcc
- CFLAGS = -O3
- LOADER = gcc
- LOADOPTS =
--NOOPT = -O0
-+NOOPT = -O0 -fPIC
- DRVCFLAGS = $(CFLAGS)
- F2CCFLAGS = $(CFLAGS)
- #######################################################################
diff --git a/sci-libs/clapack/files/clapack-3.2.1-fix_include_file.patch b/sci-libs/clapack/files/clapack-3.2.1-fix_include_file.patch
new file mode 100644
index 000000000000..002336f2d124
--- /dev/null
+++ b/sci-libs/clapack/files/clapack-3.2.1-fix_include_file.patch
@@ -0,0 +1,25 @@
+diff -urN clapack-3.2.1-CMAKE.old/INCLUDE/clapack.h clapack-3.2.1-CMAKE/INCLUDE/clapack.h
+--- clapack-3.2.1-CMAKE.old/INCLUDE/clapack.h 2011-04-30 11:39:51.000000000 +0200
++++ clapack-3.2.1-CMAKE/INCLUDE/clapack.h 2011-04-30 11:40:39.000000000 +0200
+@@ -3,6 +3,12 @@
+ #ifndef __CLAPACK_H
+ #define __CLAPACK_H
+
++#include <f2c.h>
++
++#ifdef __cplusplus
++extern "C" {
++#endif
++
+ /* Subroutine */ int caxpy_(integer *n, complex *ca, complex *cx, integer *
+ incx, complex *cy, integer *incy);
+
+@@ -7250,5 +7256,8 @@
+ integer ilaenv_(integer *ispec, char *name__, char *opts, integer *n1,
+ integer *n2, integer *n3, integer *n4);
+
++#ifdef __cplusplus
++}
++#endif
+
+ #endif /* __CLAPACK_H */
diff --git a/sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch b/sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch
index 53e358991f7a..5ae9e63977c6 100644
--- a/sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch
+++ b/sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch
@@ -66,7 +66,7 @@ diff -u -r -N clapack-3.2.1-CMAKE.orig/SRC/CMakeLists.txt clapack-3.2.1-CMAKE/SR
-target_link_libraries(lapack blas)
+add_library(clapack SHARED ${ALLOBJ} ${ALLXOBJ})
-+target_link_libraries(clapack blas f2c)
++target_link_libraries(clapack blas f2c m)
+set_target_properties(clapack PROPERTIES SOVERSION "${CLAPACK_VERSION}")
+
+install(