summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-base/gnome-print/gnome-print-0.37.ebuild31
1 files changed, 12 insertions, 19 deletions
diff --git a/gnome-base/gnome-print/gnome-print-0.37.ebuild b/gnome-base/gnome-print/gnome-print-0.37.ebuild
index cb656427a3b1..a823e279a68a 100644
--- a/gnome-base/gnome-print/gnome-print-0.37.ebuild
+++ b/gnome-base/gnome-print/gnome-print-0.37.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/gnome-print-0.37.ebuild,v 1.14 2004/12/16 11:02:50 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/gnome-print-0.37.ebuild,v 1.15 2006/07/05 06:56:55 vapier Exp $
inherit gnome.org libtool eutils
@@ -9,7 +9,7 @@ HOMEPAGE="http://www.gnome.org/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
IUSE="nls"
RDEPEND=">=media-libs/gdk-pixbuf-0.11.0-r1
@@ -23,35 +23,29 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- #fix Makefile not to run gnome-font-install
- cp ${S}/installer/Makefile.in ${S}/installer/Makefile.in.orig
- sed -e 's:$(PERL) \($(top_srcdir)/run-gnome-font-install\):echo \1:' \
- ${S}/installer/Makefile.in.orig > ${S}/installer/Makefile.in
+ # fix Makefile not to run gnome-font-install
+ sed -i \
+ -e 's:$(PERL) \($(top_srcdir)/run-gnome-font-install\):echo \1:' \
+ "${S}"/installer/Makefile.in || die
# fix build with freetype 2.1.7 and up (#44114)
- epatch ${FILESDIR}/${P}-freetype_new_include.patch
+ epatch "${FILESDIR}"/${P}-freetype_new_include.patch
+ elibtoolize
}
src_compile() {
-
- elibtoolize
-
- econf `use_enable nls` || die
-
+ econf $(use_enable nls) || die
emake || die
-
}
src_install() {
-
einstall || die
insinto /usr/share/fonts
- doins ${S}/run-gnome-font-install
-
- dodoc AUTHORS COPYING ChangeLog NEWS README
+ doins "${S}"/run-gnome-font-install
+ dodoc AUTHORS ChangeLog NEWS README
}
pkg_postinst() {
@@ -61,4 +55,3 @@ pkg_postinst() {
/usr/bin/gnome-font-install \
/usr/share/fonts /usr/share/fonts /etc >/dev/null 2>/dev/null
}
-