summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/drip/ChangeLog11
-rw-r--r--media-video/drip/Manifest16
-rw-r--r--media-video/drip/drip-0.9.0.ebuild (renamed from media-video/drip/drip-0.9.0_rc1.ebuild)56
-rw-r--r--media-video/drip/drip-0.9.0_alpha3.ebuild97
-rw-r--r--media-video/drip/files/digest-drip-0.9.02
-rw-r--r--media-video/drip/files/digest-drip-0.9.0_alpha31
-rw-r--r--media-video/drip/files/digest-drip-0.9.0_rc11
-rw-r--r--media-video/drip/files/drip-0.9.0-cflags.patch12
-rw-r--r--media-video/drip/files/drip.desktop1
9 files changed, 58 insertions, 139 deletions
diff --git a/media-video/drip/ChangeLog b/media-video/drip/ChangeLog
index ddf9f25d68a1..3a75130db363 100644
--- a/media-video/drip/ChangeLog
+++ b/media-video/drip/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/drip
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/drip/ChangeLog,v 1.16 2004/06/25 00:38:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/drip/ChangeLog,v 1.17 2004/10/13 18:25:40 eradicator Exp $
+
+*drip-0.9.0 (13 Oct 2004)
+
+ 13 Oct 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/drip-0.9.0-cflags.patch, files/drip.desktop, +drip-0.9.0.ebuild,
+ -drip-0.9.0_alpha3.ebuild, -drip-0.9.0_rc1.ebuild:
+ Removed pre-release versions. Version bump to 0.9.0. Added debian patch to
+ fix support for libpeg2-0.4.0b. Honor user CFLAGS. Closes bugs #41880 and
+ #59513.
30 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> drip-0.8.1-r5.ebuild,
drip-0.9.0_alpha3.ebuild, drip-0.9.0_rc1.ebuild:
diff --git a/media-video/drip/Manifest b/media-video/drip/Manifest
index 721e70cfb271..db8d29e529fd 100644
--- a/media-video/drip/Manifest
+++ b/media-video/drip/Manifest
@@ -1,14 +1,12 @@
-MD5 e890f581249da653cd013b6cf031018a drip-0.9.0_rc1.ebuild 2531
-MD5 5c4e8e74b779e7af29af297d207f572c drip-0.8.1-r5.ebuild 3104
-MD5 b3153439d7b51b36a2fb6a24c2103173 drip-0.9.0_alpha3.ebuild 2404
MD5 aa86a15b21499c54be13e3089eb1d6ef ChangeLog 2972
+MD5 5c4e8e74b779e7af29af297d207f572c drip-0.8.1-r5.ebuild 3104
MD5 7300a7b361fa9f48e37722c6952bd432 metadata.xml 158
+MD5 390d6fa6c5d69193c2c9c2e74bdba673 drip-0.9.0.ebuild 2443
+MD5 39f83fd93ac2e8bb8b9b89afcbcaedcd files/digest-drip-0.8.1-r5 62
MD5 636fd81a0bb66385faca9b7c72cb1cbc files/drip-0.8.1-fix-dvd-symlink.patch 1305
-MD5 030a52bd54594455f9d77f959575036d files/drip-0.8.1-missing-stdio.patch 567
-MD5 27ca218152ac3b83a6f59a84c7a7f539 files/libmpeg2.patch 3677
MD5 e85fdab29910541239d107476ff1a592 files/drip-0.8.1-gcc-3.1.patch 546
-MD5 39f83fd93ac2e8bb8b9b89afcbcaedcd files/digest-drip-0.8.1-r5 62
-MD5 6ae51a54ca05edca6f931b33c8a24a0c files/digest-drip-0.9.0_rc1 66
-MD5 23432e9d253629f04e963b5f9ad807c9 files/digest-drip-0.9.0_alpha3 66
+MD5 030a52bd54594455f9d77f959575036d files/drip-0.8.1-missing-stdio.patch 567
+MD5 062194efdad2b8a1e02ded8b66d86fc3 files/drip.desktop 154
MD5 a7d5edb693cf81b8e5fbc833cf221516 files/dripgetdvd.sh 1330
-MD5 89536060720610232d7c3306761d93eb files/drip.desktop 119
+MD5 27ca218152ac3b83a6f59a84c7a7f539 files/libmpeg2.patch 3677
+MD5 7f9daf1e0ac3dae373c1c892c46d1476 files/digest-drip-0.9.0 137
diff --git a/media-video/drip/drip-0.9.0_rc1.ebuild b/media-video/drip/drip-0.9.0.ebuild
index 77ece73f042c..d08903bd849c 100644
--- a/media-video/drip/drip-0.9.0_rc1.ebuild
+++ b/media-video/drip/drip-0.9.0.ebuild
@@ -1,29 +1,27 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/drip/drip-0.9.0_rc1.ebuild,v 1.6 2004/06/25 00:38:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/drip/drip-0.9.0.ebuild,v 1.1 2004/10/13 18:25:40 eradicator Exp $
-inherit eutils libtool
+inherit eutils libtool flag-o-matic
-MY_P="${P/_}"
-MY_P="${MY_P/rc1/-RC1}"
-S="${WORKDIR}/${MY_P}"
DESCRIPTION="Drip - A DVD to DIVX convertor frontend"
-SRC_URI="http://drip.sourceforge.net/files/${MY_P}.tar.gz"
HOMEPAGE="http://drip.sourceforge.net/"
+SRC_URI="http://drip.sourceforge.net/files/${P}.tar.gz
+ mirror://debian/pool/main/d/drip/drip_0.8.3.2+0.9.0-rc3-5.diff.gz"
RDEPEND="gnome-base/gnome-libs
- >=media-video/avifile-0.7.22
+ >=media-video/avifile-0.7.34
>=media-libs/a52dec-0.7.3
>=media-libs/divx4linux-20020418
>=media-libs/libdvdcss-1.2.2
>=media-libs/libdvdread-0.9.3
- >=media-libs/libmpeg2-0.3.1
+ >=media-libs/libmpeg2-0.4.0
+ >=media-libs/xvid-0.9.2
media-gfx/imagemagick
media-libs/gdk-pixbuf
dev-libs/libxml2
sys-apps/eject
>=sys-devel/gcc-3"
-# As of 0.9.0-RC1 gcc3 is required
DEPEND="${RDEPEND}
dev-lang/nasm
@@ -31,24 +29,29 @@ DEPEND="${RDEPEND}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 -ppc"
+KEYWORDS="~x86"
IUSE="nls"
src_unpack() {
-
unpack ${A}
+ cd ${S}
+
+ # Many thanks to the Debian devs. Fixes libmpeg2-0.4.0 support.
+ epatch ${WORKDIR}/drip_0.8.3.2+0.9.0-rc3-5.diff
+ epatch ${S}/drip-0.8.3.2+0.9.0-rc3/debian/patches/magickfilter_ftbfs.diff
+ epatch ${S}/drip-0.8.3.2+0.9.0-rc3/debian/patches/mpeg2_api.diff
+ epatch ${S}/drip-0.8.3.2+0.9.0-rc3/debian/patches/noopt.diff
+
# Fix the problem that if the /dev/dvd symlink is not absolute,
# drip fails to start. We do this by tring to figure what the
# absolute path to the block device of a dvd drive is with help
# from the dripgetdvd.sh script.
# <azarah@gentoo.org>
- cd ${S} ; epatch ${FILESDIR}/${PN}-0.8.1-fix-dvd-symlink.patch
+ epatch ${FILESDIR}/${PN}-0.8.1-fix-dvd-symlink.patch
- # patch for changing types in >libmpeg-0.3.1
- if grep -q mpeg2_picture ${ROOT}/usr/include/mpeg2dec/mpeg2.h; then
- epatch ${FILESDIR}/libmpeg2.patch
- fi
+ # Honor user CFLAGS
+ epatch ${FILESDIR}/${P}-cflags.patch
# Remove stale script ... "automake --add-missing" will add it again
einfo "Rerunnig autoconf/automake..."
@@ -57,18 +60,15 @@ src_unpack() {
aclocal -I macros
automake --add-missing
autoconf
+ elibtoolize
}
src_compile() {
-
- elibtoolize
-
local myconf=
use nls || myconf="${myconf} --disable-nls"
- # Do not use custom CFLAGS !!!
- unset CFLAGS CXXFLAGS
+ use x86 && append-flags "-DARCH_X86"
econf ${myconf} || die
@@ -76,16 +76,11 @@ src_compile() {
}
src_install() {
-
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- localstatedir=${D}/var/lib \
- sysconfdir=${D}/etc \
+ einstall \
drip_helpdir=${D}/usr/share/gnome/help/drip/C \
drip_pixmapdir=${D}/usr/share/pixmaps \
pixdir=${D}/usr/share/pixmaps/drip \
- install || die
+ || die
# Custom script for drip to get the *real* dvd device
# It is a bit rough around the edges, but hopefully will do the trick.
@@ -93,9 +88,10 @@ src_install() {
insinto /usr/share/pixmaps
newins ${S}/pixmaps/drip_logo.jpg drip.jpg
- insinto /usr/share/gnome/apps/Multimedia
+ insinto /usr/share/applications
+ doins ${FILESDIR}/drip.desktop
+ insinto /usr/share/applnk/Multimedia
doins ${FILESDIR}/drip.desktop
dodoc AUTHORS BUG-REPORT.TXT COPYING ChangeLog NEWS README TODO
}
-
diff --git a/media-video/drip/drip-0.9.0_alpha3.ebuild b/media-video/drip/drip-0.9.0_alpha3.ebuild
deleted file mode 100644
index 19547d78cacd..000000000000
--- a/media-video/drip/drip-0.9.0_alpha3.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/drip/drip-0.9.0_alpha3.ebuild,v 1.8 2004/06/25 00:38:48 agriffis Exp $
-
-inherit eutils libtool
-
-MY_P="${P/_}"
-MY_P="${MY_P/alpha/cvs}"
-S="${WORKDIR}/${PN}"
-DESCRIPTION="Drip - A DVD to DIVX convertor frontend"
-SRC_URI="http://drip.sourceforge.net/files/${MY_P}.tar.gz"
-HOMEPAGE="http://drip.sourceforge.net/"
-
-RDEPEND="gnome-base/gnome-libs
- >=media-video/avifile-0.7.22
- >=media-libs/a52dec-0.7.3
- >=media-libs/divx4linux-20020418
- >=media-libs/libdvdcss-1.2.2
- >=media-libs/libdvdread-0.9.3
- >=media-libs/libmpeg2-0.3.1
- media-gfx/imagemagick
- media-libs/gdk-pixbuf
- dev-libs/libxml2
- sys-apps/eject"
-
-DEPEND="${RDEPEND}
- dev-lang/nasm
- >=sys-devel/automake-1.5-r1"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 -ppc"
-IUSE="nls"
-
-src_unpack() {
-
- unpack ${A}
-
- # Fix the problem that if the /dev/dvd symlink is not absolute,
- # drip fails to start. We do this by tring to figure what the
- # absolute path to the block device of a dvd drive is with help
- # from the dripgetdvd.sh script.
- # <azarah@gentoo.org>
- cd ${S} ; epatch ${FILESDIR}/${PN}-0.8.1-fix-dvd-symlink.patch
-
- # patch for changing types in >libmpeg-0.3.1
- epatch ${FILESDIR}/libmpeg2.patch
-
- # Remove stale script ... "automake --add-missing" will add it again
- einfo "Rerunnig autoconf/automake..."
- cd ${S} ; rm -f ${S}/missing
- export WANT_AUTOMAKE_1_5=1
- aclocal -I macros
- automake --add-missing
- autoconf
-}
-
-src_compile() {
-
- elibtoolize
-
- local myconf=
-
- use nls || myconf="${myconf} --disable-nls"
-
- # Do not use custom CFLAGS !!!
- unset CFLAGS CXXFLAGS
-
- econf ${myconf} || die
-
- make || die
-}
-
-src_install() {
-
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- localstatedir=${D}/var/lib \
- sysconfdir=${D}/etc \
- drip_helpdir=${D}/usr/share/gnome/help/drip/C \
- drip_pixmapdir=${D}/usr/share/pixmaps \
- pixdir=${D}/usr/share/pixmaps/drip \
- install || die
-
- # Custom script for drip to get the *real* dvd device
- # It is a bit rough around the edges, but hopefully will do the trick.
- dobin ${FILESDIR}/dripgetdvd.sh
-
- insinto /usr/share/pixmaps
- newins ${S}/pixmaps/drip_logo.jpg drip.jpg
- insinto /usr/share/gnome/apps/Multimedia
- doins ${FILESDIR}/drip.desktop
-
- dodoc AUTHORS BUG-REPORT.TXT COPYING ChangeLog NEWS README TODO
-}
-
diff --git a/media-video/drip/files/digest-drip-0.9.0 b/media-video/drip/files/digest-drip-0.9.0
new file mode 100644
index 000000000000..c5ed7ddd6e08
--- /dev/null
+++ b/media-video/drip/files/digest-drip-0.9.0
@@ -0,0 +1,2 @@
+MD5 a5a07b7646ad25a5c39d3cfd7bbab631 drip-0.9.0.tar.gz 821391
+MD5 b5cf583f7387480ae00ab2bc2076d943 drip_0.8.3.2+0.9.0-rc3-5.diff.gz 5242
diff --git a/media-video/drip/files/digest-drip-0.9.0_alpha3 b/media-video/drip/files/digest-drip-0.9.0_alpha3
deleted file mode 100644
index 6c6d46e5a2f0..000000000000
--- a/media-video/drip/files/digest-drip-0.9.0_alpha3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 02ab5f4a78f17c7c46266741d962dd41 drip-0.9.0cvs3.tar.gz 887447
diff --git a/media-video/drip/files/digest-drip-0.9.0_rc1 b/media-video/drip/files/digest-drip-0.9.0_rc1
deleted file mode 100644
index a7bf61fa932d..000000000000
--- a/media-video/drip/files/digest-drip-0.9.0_rc1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1bc27dbb4080da18e6153253a5087156 drip-0.9.0-RC1.tar.gz 716775
diff --git a/media-video/drip/files/drip-0.9.0-cflags.patch b/media-video/drip/files/drip-0.9.0-cflags.patch
new file mode 100644
index 000000000000..fa9de6ce80a8
--- /dev/null
+++ b/media-video/drip/files/drip-0.9.0-cflags.patch
@@ -0,0 +1,12 @@
+diff -Naur drip-0.9.0.orig/Makefile.am drip-0.9.0/Makefile.am
+--- drip-0.9.0.orig/Makefile.am 2004-04-20 13:58:33.000000000 -0700
++++ drip-0.9.0/Makefile.am 2004-10-13 11:21:24.670588437 -0700
+@@ -2,7 +2,7 @@
+
+ SUBDIRS = libspu encoder src plug-ins macros doc scripts pixmaps #libvcd
+ drip_pixmapdir = $(DESTDIR)/`$(GNOME_CONFIG) --prefix`/share/pixmaps
+-export COMPILE_OPTIM=-DARCH_X86 -funroll-all-loops -ffast-math -fexpensive-optimizations -fschedule-insns2 -Wno-deprecated -fomit-frame-pointer -march=athlon -mcpu=athlon
++export COMPILE_OPTIM=@CFLAGS@
+ export COMPILE_DEBUG=-D_REENTRANT -g -ggdb -Wno-deprecated $(MMX_CFLAGS) $(_3DNOW_CFLAGS) $(SSE_CFLAGS) #-DDEBUG
+ export L_DEBUG=-DNONE
+ EXTRA_DIST = \
diff --git a/media-video/drip/files/drip.desktop b/media-video/drip/files/drip.desktop
index b7daaab82347..9445535cc060 100644
--- a/media-video/drip/files/drip.desktop
+++ b/media-video/drip/files/drip.desktop
@@ -5,3 +5,4 @@ Exec=drip
Icon=drip.jpg
Terminal=0
Type=Application
+Categories=Application;AudioVideo;