summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/org-mode/ChangeLog8
-rw-r--r--app-emacs/org-mode/files/50org-mode-gentoo-7.8.03.el4
-rw-r--r--app-emacs/org-mode/files/org-mode-7.8.03-Makefile.patch22
-rw-r--r--app-emacs/org-mode/org-mode-7.8.03.ebuild54
4 files changed, 87 insertions, 1 deletions
diff --git a/app-emacs/org-mode/ChangeLog b/app-emacs/org-mode/ChangeLog
index 61e91a2c3bf6..0cbfe17faa60 100644
--- a/app-emacs/org-mode/ChangeLog
+++ b/app-emacs/org-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/org-mode
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/ChangeLog,v 1.137 2012/01/01 19:16:30 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/ChangeLog,v 1.138 2012/01/04 12:59:36 ulm Exp $
+
+*org-mode-7.8.03 (04 Jan 2012)
+
+ 04 Jan 2012; Ulrich Mueller <ulm@gentoo.org> +org-mode-7.8.03.ebuild,
+ +files/org-mode-7.8.03-Makefile.patch, +files/50org-mode-gentoo-7.8.03.el:
+ Version bump.
*org-mode-7.8.02-r1 (01 Jan 2012)
diff --git a/app-emacs/org-mode/files/50org-mode-gentoo-7.8.03.el b/app-emacs/org-mode/files/50org-mode-gentoo-7.8.03.el
new file mode 100644
index 000000000000..2b969904108b
--- /dev/null
+++ b/app-emacs/org-mode/files/50org-mode-gentoo-7.8.03.el
@@ -0,0 +1,4 @@
+n(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'auto-mode-alist '("\\.org\\'" . org-mode))
+(require 'org-install)
+(setq org-odt-data-dir "@SITEETC@")
diff --git a/app-emacs/org-mode/files/org-mode-7.8.03-Makefile.patch b/app-emacs/org-mode/files/org-mode-7.8.03-Makefile.patch
new file mode 100644
index 000000000000..918727f03aeb
--- /dev/null
+++ b/app-emacs/org-mode/files/org-mode-7.8.03-Makefile.patch
@@ -0,0 +1,22 @@
+Don't re-compile org-odt.el at install time.
+Patch submitted upstream:
+http://lists.gnu.org/archive/html/emacs-orgmode/2012-01/msg00005.html
+
+--- org-7.8.03-orig/Makefile
++++ org-7.8.03/Makefile
+@@ -247,14 +247,10 @@
+ g:
+ ${MAKE} pdf && open doc/orgguide.pdf
+
+-# Always force re-compilation of org-odt
+-lisp/org-odt.elc: org-odt-data-dir
+-org-odt-data-dir:
+-
+ # Sleight of hand to "hard code" the value of $(datadir) in
+ # org-odt.el. See variables `org-odt-styles-dir-list' and
+ # `org-odt-schema-dir-list'.
+-install-lisp: BATCH_EXTRA = -eval "(setq org-odt-data-dir (expand-file-name \"$(datadir)\"))"
++lisp/org-odt.elc: BATCH_EXTRA = -eval "(setq org-odt-data-dir (expand-file-name \"$(datadir)\"))"
+
+ install-lisp: $(LISPFILES) $(ELCFILES)
+ if [ ! -d $(lispdir) ]; then $(MKDIR) $(lispdir); else true; fi ;
diff --git a/app-emacs/org-mode/org-mode-7.8.03.ebuild b/app-emacs/org-mode/org-mode-7.8.03.ebuild
new file mode 100644
index 000000000000..a6a7a6627656
--- /dev/null
+++ b/app-emacs/org-mode/org-mode-7.8.03.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/org-mode-7.8.03.ebuild,v 1.1 2012/01/04 12:59:36 ulm Exp $
+
+EAPI=4
+NEED_EMACS=22
+
+inherit elisp
+
+DESCRIPTION="An Emacs mode for notes and project planning"
+HOMEPAGE="http://www.orgmode.org/"
+SRC_URI="http://orgmode.org/org-${PV}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.3 contrib? ( GPL-2 MIT as-is )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-macos"
+IUSE="contrib"
+
+S="${WORKDIR}/org-${PV}"
+ELISP_PATCHES="${P}-Makefile.patch"
+# Remove autoload file to make sure that it is regenerated with
+# the right Emacs version.
+ELISP_REMOVE="lisp/org-install.el"
+SITEFILE="50${PN}-gentoo-${PV}.el"
+
+src_compile() {
+ emake datadir="${SITEETC}/${PN}"
+}
+
+src_install() {
+ emake \
+ prefix="${ED}/usr" \
+ lispdir="${ED}${SITELISP}/${PN}" \
+ datadir="${ED}${SITEETC}/${PN}" \
+ infodir="${ED}/usr/share/info" \
+ install
+
+ cp "${FILESDIR}/${SITEFILE}" "${T}/${SITEFILE}"
+
+ if use contrib; then
+ elisp-install ${PN}/contrib contrib/lisp/*org*.el || die
+ insinto /usr/share/doc/${PF}/contrib
+ doins -r contrib/README contrib/babel contrib/odt contrib/scripts
+ find "${ED}/usr/share/doc/${PF}/contrib" -type f -name '.*' \
+ -exec rm -f '{}' '+'
+ # add the contrib subdirectory to load-path
+ sed -ie 's:\(.*@SITELISP@\)\(.*\):&\n\1/contrib\2:' \
+ "${T}/${SITEFILE}" || die
+ fi
+
+ elisp-site-file-install "${T}/${SITEFILE}" || die
+ doinfo doc/org
+ dodoc README doc/org.pdf doc/orgcard.pdf doc/orgguide.pdf
+}