summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/ark/ChangeLog7
-rw-r--r--kde-base/ark/ark-4.4.3.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/ark/ChangeLog b/kde-base/ark/ChangeLog
index 196de6860809..7c79ef93efbd 100644
--- a/kde-base/ark/ChangeLog
+++ b/kde-base/ark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ark
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.153 2010/03/31 21:57:46 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.154 2010/05/03 20:12:31 alexxy Exp $
+
+*ark-4.4.3 (03 May 2010)
+
+ 03 May 2010; Alexey Shvetsov <alexxy@gentoo.org> +ark-4.4.3.ebuild:
+ Version bump
31 Mar 2010; Dror Levin <spatz@gentoo.org> -ark-4.3.4.ebuild,
-ark-4.4.0.ebuild:
diff --git a/kde-base/ark/ark-4.4.3.ebuild b/kde-base/ark/ark-4.4.3.ebuild
new file mode 100644
index 000000000000..ab9529e0a2e0
--- /dev/null
+++ b/kde-base/ark/ark-4.4.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.4.3.ebuild,v 1.1 2010/05/03 20:12:31 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdeutils"
+inherit kde4-meta
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug +handbook lzma zip"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+ lzma? ( app-arch/xz-utils )
+ zip? ( >=dev-libs/libzip-0.8 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ $(cmake-utils_use_with zip LibZip)
+ )
+ kde4-meta_src_configure
+}