summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/sunpinyin/sunpinyin-2.0.3.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/app-i18n/sunpinyin/sunpinyin-2.0.3.ebuild b/app-i18n/sunpinyin/sunpinyin-2.0.3.ebuild
index a31848e64a6f..97f3f1e14b1b 100644
--- a/app-i18n/sunpinyin/sunpinyin-2.0.3.ebuild
+++ b/app-i18n/sunpinyin/sunpinyin-2.0.3.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/sunpinyin/sunpinyin-2.0.3.ebuild,v 1.1 2011/02/20 05:02:38 qiaomuf Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/sunpinyin/sunpinyin-2.0.3.ebuild,v 1.2 2011/02/20 06:48:00 qiaomuf Exp $
EAPI="1"
inherit scons-utils
-MY_P=${P/_/-}
-
DESCRIPTION="SunPinyin is a SLM (Statistical Language Model) based IME"
HOMEPAGE="http://sunpinyin.googlecode.com"
-SRC_URI="${HOMEPAGE}/files/${MY_P}.tar.gz
+SRC_URI="${HOMEPAGE}/files/${P}.tar.gz
http://open-gram.googlecode.com/files/dict.utf8.tar.bz2
http://open-gram.googlecode.com/files/lm_sc.t3g.arpa.tar.bz2"
@@ -21,10 +19,9 @@ IUSE=""
RDEPEND="dev-db/sqlite:3"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-S="${WORKDIR}/${MY_P}"
src_unpack() {
- unpack "${MY_P}.tar.gz"
+ unpack "${P}.tar.gz"
mv "${DISTDIR}/dict.utf8.tar.bz2" "${S}/raw/" || die "dict file not found"
mv "${DISTDIR}/lm_sc.t3g.arpa.tar.bz2" "${S}/raw/" || die "dict file not found"
}
@@ -39,8 +36,13 @@ src_install() {
pkg_postinst() {
elog ""
+ elog "If you have already installed former version of ${PN}"
+ elog "and any wrapper, please remerge the wrapper to make it work with"
+ elog "the new version."
+ elog ""
elog "To use any wrapper for ${PN}, please merge any of the following"
elog "packages: "
+ elog "emerge app-i18n/fcitx-sunpinyin"
elog "emerge app-i18n/ibus-sunpinyin"
elog "emerge app-i18n/scim-sunpinyin"
elog "emerge app-i18n/xsunpinyin"