summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libsoup-gnome/ChangeLog7
-rw-r--r--net-libs/libsoup-gnome/libsoup-gnome-2.36.1.ebuild6
-rw-r--r--net-libs/libsoup-gnome/libsoup-gnome-2.38.1.ebuild20
3 files changed, 21 insertions, 12 deletions
diff --git a/net-libs/libsoup-gnome/ChangeLog b/net-libs/libsoup-gnome/ChangeLog
index 9eef9998f06c..ae86e1ad2cfc 100644
--- a/net-libs/libsoup-gnome/ChangeLog
+++ b/net-libs/libsoup-gnome/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libsoup-gnome
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/ChangeLog,v 1.80 2012/10/16 05:05:52 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/ChangeLog,v 1.81 2012/10/20 06:06:42 tetromino Exp $
+
+ 20 Oct 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ libsoup-gnome-2.36.1.ebuild, libsoup-gnome-2.38.1.ebuild:
+ Explicitly disable apache-using tests to prevent access violation (bug
+ #438104, thanks to toon and Pedro Sanchez).
16 Oct 2012; Anthony G. Basile <blueness@gentoo.org>
libsoup-gnome-2.38.1.ebuild:
diff --git a/net-libs/libsoup-gnome/libsoup-gnome-2.36.1.ebuild b/net-libs/libsoup-gnome/libsoup-gnome-2.36.1.ebuild
index b9bd1c131a43..9cf789d9bc5c 100644
--- a/net-libs/libsoup-gnome/libsoup-gnome-2.36.1.ebuild
+++ b/net-libs/libsoup-gnome/libsoup-gnome-2.36.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/libsoup-gnome-2.36.1.ebuild,v 1.10 2012/10/10 03:18:31 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/libsoup-gnome-2.36.1.ebuild,v 1.11 2012/10/20 06:06:42 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
@@ -31,12 +31,14 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
pkg_setup() {
+ # Disable apache tests until they are usable on Gentoo, bug #326957
G2CONF="${G2CONF}
--disable-static
--disable-tls-check
$(use_enable introspection)
--with-libsoup-system
- --with-gnome"
+ --with-gnome
+ --without-apache-httpd"
DOCS="AUTHORS NEWS README"
}
diff --git a/net-libs/libsoup-gnome/libsoup-gnome-2.38.1.ebuild b/net-libs/libsoup-gnome/libsoup-gnome-2.38.1.ebuild
index a1aead892d70..6df04d6b693e 100644
--- a/net-libs/libsoup-gnome/libsoup-gnome-2.38.1.ebuild
+++ b/net-libs/libsoup-gnome/libsoup-gnome-2.38.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/libsoup-gnome-2.38.1.ebuild,v 1.10 2012/10/16 05:05:52 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/libsoup-gnome-2.38.1.ebuild,v 1.11 2012/10/20 06:06:42 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
@@ -31,25 +31,27 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
pkg_setup() {
+ # Disable apache tests until they are usable on Gentoo, bug #326957
G2CONF="${G2CONF}
--disable-static
--disable-tls-check
$(use_enable introspection)
--with-libsoup-system
- --with-gnome"
+ --with-gnome
+ --without-apache-httpd"
DOCS="AUTHORS NEWS README"
}
-src_configure() {
- # FIXME: we need addpredict to workaround bug #324779 until
- # root cause (bug #249496) is solved
- addpredict /usr/share/snmp/mibs/.index
- gnome2_src_configure
-}
-
src_prepare() {
# Use lib present on the system
epatch "${FILESDIR}"/${PN}-2.38.0-system-lib.patch
eautoreconf
gnome2_src_prepare
}
+
+src_configure() {
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ addpredict /usr/share/snmp/mibs/.index
+ gnome2_src_configure
+}