summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/nut/ChangeLog9
-rw-r--r--app-misc/nut/nut-18.5.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/app-misc/nut/ChangeLog b/app-misc/nut/ChangeLog
index 7f07a7770729..1c427cc029b5 100644
--- a/app-misc/nut/ChangeLog
+++ b/app-misc/nut/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/nut
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.52 2012/11/21 13:23:06 kensington Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.53 2013/01/30 06:59:55 patrick Exp $
+
+*nut-18.5 (30 Jan 2013)
+
+ 30 Jan 2013; Patrick Lauer <patrick@gentoo.org> +nut-18.5.ebuild:
+ Bump
21 Nov 2012; Michael Palimaka <kensington@gentoo.org>
-files/nut-17.7-makefile.patch, -nut-17.12.ebuild, -nut-17.7.ebuild:
diff --git a/app-misc/nut/nut-18.5.ebuild b/app-misc/nut/nut-18.5.ebuild
new file mode 100644
index 000000000000..6da52bd759ac
--- /dev/null
+++ b/app-misc/nut/nut-18.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-18.5.ebuild,v 1.1 2013/01/30 06:59:55 patrick Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Record what you eat and analyze your nutrient levels"
+HOMEPAGE="http://nut.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-17.12-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT="${CFLAGS}" FOODDIR=\\\"/usr/share/nut\\\"
+}
+
+src_install() {
+ insinto /usr/share/nut
+ doins raw.data/*
+ dobin nut
+ doman nut.1
+}