summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/readline/ChangeLog8
-rw-r--r--sys-libs/readline/Manifest4
-rw-r--r--sys-libs/readline/files/digest-readline-4.3-r56
-rw-r--r--sys-libs/readline/readline-4.3-r5.ebuild76
4 files changed, 91 insertions, 3 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index 11e61490829a..d6ca9a3813c3 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/readline
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.25 2003/09/17 22:41:05 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.26 2003/09/28 12:32:30 azarah Exp $
+
+*readline-4.3-r5 (28 Sep 2003)
+
+ 28 Sep 2003; Martin Schlemmer <azarah@gentoo.org> readline-4.3-r5.ebuild:
+ updUpdate to use official patches, which also have the bmulti-tybyte
+ stuff.
17 Sep 2003; Jon Portnoy <avenj@gentoo.org> readline-4.3-r4.ebuild :
ia64 keywords.
diff --git a/sys-libs/readline/Manifest b/sys-libs/readline/Manifest
index 85f31efb81d9..53245cf84bf4 100644
--- a/sys-libs/readline/Manifest
+++ b/sys-libs/readline/Manifest
@@ -1,9 +1,9 @@
MD5 a6cbe1fdd96b8617cb995c4a50c60a7d readline-4.3-r4.ebuild 1998
-MD5 bace29a722bdea8203afb6560f9b1950 ChangeLog 3556
+MD5 aeec6cbe6aec1cddde54c301587ee7a7 ChangeLog 3752
MD5 4bde8d05be10b22d5c3fc6ec39959e8f readline-4.1-r5.ebuild 1842
MD5 881f1b5751b65a13418d18f121228191 readline-4.2a-r2.ebuild 1739
MD5 9883706e21ec10f801e37e5b808c79ee readline-4.2a-r1.ebuild 1736
-MD5 1f965627c4db6bae9366bd0833f2c323 readline-4.3-r5.ebuild 2013
+MD5 b2b0ef92ff3530332404c4537896d524 readline-4.3-r5.ebuild 1887
MD5 c0828e7e5cc4b53b768cc6d2120abb87 readline-4.3-r3.ebuild 1838
MD5 ea89d08f5dd5239da0569ec2a56f8488 files/digest-readline-4.2a-r2 65
MD5 f9e8af7cdcf7ac973c77fc6a712af5de files/digest-readline-4.1-r5 64
diff --git a/sys-libs/readline/files/digest-readline-4.3-r5 b/sys-libs/readline/files/digest-readline-4.3-r5
new file mode 100644
index 000000000000..64e09d9247d2
--- /dev/null
+++ b/sys-libs/readline/files/digest-readline-4.3-r5
@@ -0,0 +1,6 @@
+MD5 f86f7cb717ab321fe15f1bbcb058c11e readline-4.3.tar.gz 961662
+MD5 aacf1c41717f305ab5ce45e9d028821d readline43-001 1126
+MD5 8df4bf2c7e77e05c4ecd949b9b5dedf3 readline43-002 738
+MD5 946ed64a306afadb981b294747578e95 readline43-003 2202
+MD5 392705156b3054eaae2f2a28238592fb readline43-004 3140
+MD5 0e4affc42a7bfc70f0a50529e7901954 readline43-005 1056
diff --git a/sys-libs/readline/readline-4.3-r5.ebuild b/sys-libs/readline/readline-4.3-r5.ebuild
new file mode 100644
index 000000000000..444f828f6b0a
--- /dev/null
+++ b/sys-libs/readline/readline-4.3-r5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r5.ebuild,v 1.1 2003/09/28 12:32:30 azarah Exp $
+
+inherit eutils
+
+# Official patches
+PLEVEL="x001 x002 x003 x004 x005"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Another cute console display library"
+SRC_URI="ftp://ftp.gnu.org/gnu/readline/${P}.tar.gz
+ ftp://gatekeeper.dec.com/pub/GNU/readline/${P}.tar.gz
+ ${PLEVEL//x/ftp://ftp.gnu.org/gnu/${PN}/${PN}-${PV}-patches/${PN}${PV/\.}-}"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~mips ~ia64"
+
+# We must be sertain that we have a bash that is linked
+# to its internal readline, else we may get problems.
+DEPEND=">=app-shells/bash-2.05b-r2
+ >=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ for x in ${PLEVEL//x}
+ do
+ epatch ${DISTDIR}/${PN}${PV/\.}-${x}
+ done
+}
+
+src_compile() {
+
+ econf --with-curses || die
+
+ emake || die
+ cd shlib
+ emake || die
+}
+
+
+src_install() {
+
+ make prefix=${D}/usr mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info install || die
+ cd ${S}/shlib
+ make prefix=${D}/usr mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info install || die
+
+ cd ${S}
+
+ dodir /lib
+ mv ${D}/usr/lib/*.so* ${D}/lib
+ rm -f ${D}/lib/*.old
+ # bug #4411
+ gen_usr_ldscript libreadline.so
+ gen_usr_ldscript libhistory.so
+ # end bug #4411
+ dosym libhistory.so.${PV/a/} /lib/libhistory.so
+ dosym libreadline.so.${PV/a/} /lib/libreadline.so
+ # Needed because make install uses ${D} for the link
+ dosym libhistory.so.${PV/a/} /lib/libhistory.so.4
+ dosym libreadline.so.${PV/a/} /lib/libreadline.so.4
+ chmod 755 ${D}/lib/*.${PV/a/}
+
+ dodoc CHANGELOG CHANGES COPYING MANIFEST README USAGE
+ docinto ps
+ dodoc doc/*.ps
+ dohtml -r doc
+}
+