summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/will_paginate/ChangeLog6
-rw-r--r--dev-ruby/will_paginate/will_paginate-2.3.15.ebuild4
2 files changed, 7 insertions, 3 deletions
diff --git a/dev-ruby/will_paginate/ChangeLog b/dev-ruby/will_paginate/ChangeLog
index 35c18f64bdd2..73e149dfcc3c 100644
--- a/dev-ruby/will_paginate/ChangeLog
+++ b/dev-ruby/will_paginate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/will_paginate
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/ChangeLog,v 1.13 2011/09/19 08:14:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/ChangeLog,v 1.14 2011/09/26 11:31:36 flameeyes Exp $
+
+ 26 Sep 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ will_paginate-2.3.15.ebuild:
+ Make sure to depend on slot 2.3 of activesupport to not conflict with rails.
*will_paginate-3.0.1 (19 Sep 2011)
diff --git a/dev-ruby/will_paginate/will_paginate-2.3.15.ebuild b/dev-ruby/will_paginate/will_paginate-2.3.15.ebuild
index 4da55f094e77..5f5e8c0cb044 100644
--- a/dev-ruby/will_paginate/will_paginate-2.3.15.ebuild
+++ b/dev-ruby/will_paginate/will_paginate-2.3.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/will_paginate-2.3.15.ebuild,v 1.3 2011/02/20 13:15:34 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/will_paginate-2.3.15.ebuild,v 1.4 2011/09/26 11:31:36 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18"
@@ -26,7 +26,7 @@ ruby_add_bdepend "
virtual/ruby-test-unit
!dev-ruby/test-unit:2
)"
-ruby_add_rdepend '>=dev-ruby/activesupport-1.4.4'
+ruby_add_rdepend 'dev-ruby/activesupport:2.3'
each_ruby_test() {
# Only works with 2.3.x, so guard against rails 3 being installed