summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/gpgme/ChangeLog9
-rw-r--r--app-crypt/gpgme/files/gpgme-1.3.0-gold.patch28
-rw-r--r--app-crypt/gpgme/gpgme-1.3.0-r1.ebuild50
3 files changed, 86 insertions, 1 deletions
diff --git a/app-crypt/gpgme/ChangeLog b/app-crypt/gpgme/ChangeLog
index edce183a17e8..cd0f4a556671 100644
--- a/app-crypt/gpgme/ChangeLog
+++ b/app-crypt/gpgme/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/gpgme
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/ChangeLog,v 1.183 2011/05/11 20:24:50 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/ChangeLog,v 1.184 2011/05/15 17:27:08 flameeyes Exp $
+
+*gpgme-1.3.0-r1 (15 May 2011)
+
+ 15 May 2011; Diego E. Pettenò <flameeyes@gentoo.org> +gpgme-1.3.0-r1.ebuild,
+ +files/gpgme-1.3.0-gold.patch:
+ Add patch to link properly with GNU gold (bug #367409); regenerate autotools;
+ remove .la files; bump to EAPI=4.
11 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
gpgme-1.3.0.ebuild, +files/gpgme-1.3.0-gnupg-2.0.17.patch:
diff --git a/app-crypt/gpgme/files/gpgme-1.3.0-gold.patch b/app-crypt/gpgme/files/gpgme-1.3.0-gold.patch
new file mode 100644
index 000000000000..227cff1791f8
--- /dev/null
+++ b/app-crypt/gpgme/files/gpgme-1.3.0-gold.patch
@@ -0,0 +1,28 @@
+From bc797eb1ebeb2e94573f1b9ad7ada21fe948d9dc Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20Petten=C3=B2?= <flameeyes@gmail.com>
+Date: Sun, 15 May 2011 19:07:41 +0200
+Subject: [gpgme PATCH] build-sys: link libassuan and libgpg-error in
+ gpgme-tool as well.
+
+Without this change, the binary would result "underlinked", and GNU gold
+would fail to link it.
+---
+ src/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 18c8b3b..0b240ee 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -240,7 +240,7 @@ libgpgme_qt_la_LIBADD = $(gpgme_res) @LIBASSUAN_LIBS@ @LTLIBOBJS@ \
+ endif
+
+ noinst_PROGRAMS = gpgme-tool
+-gpgme_tool_LDADD = libgpgme.la
++gpgme_tool_LDADD = libgpgme.la @LIBASSUAN_LIBS@ @GPG_ERROR_LIBS@
+
+ status-table.h : gpgme.h extra-stati.h
+ cat $(builddir)/gpgme.h $(srcdir)extra-stati.h \
+--
+1.7.5.rc3
+
diff --git a/app-crypt/gpgme/gpgme-1.3.0-r1.ebuild b/app-crypt/gpgme/gpgme-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..222b0b8dccea
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-1.3.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-1.3.0-r1.ebuild,v 1.1 2011/05/15 17:27:08 flameeyes Exp $
+
+EAPI="4"
+
+inherit eutils libtool autotools
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
+SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="common-lisp pth"
+
+DEPEND="app-crypt/gnupg
+ >=dev-libs/libassuan-1.1.0
+ >=dev-libs/libgpg-error-1.4
+ pth? ( >=dev-libs/pth-1.2 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.1.8-et_EE.patch"
+ epatch "${FILESDIR}/${P}-gnupg-2.0.17.patch"
+ epatch "${FILESDIR}/${P}-gold.patch"
+
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --includedir="${EPREFIX}/usr/include/gpgme" \
+ --with-gpg="${EPREFIX}/usr/bin/gpg" \
+ --with-gpgsm="${EPREFIX}/usr/bin/gpgsm" \
+ $(use_with pth)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ find "${D}" -name '*.la' -delete
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ if ! use common-lisp; then
+ rm -fr "${ED}usr/share/common-lisp"
+ fi
+}