summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-zope/zope-authentication/ChangeLog10
-rw-r--r--net-zope/zope-authentication/metadata.xml6
-rw-r--r--net-zope/zope-authentication/zope-authentication-3.7.0.ebuild34
3 files changed, 50 insertions, 0 deletions
diff --git a/net-zope/zope-authentication/ChangeLog b/net-zope/zope-authentication/ChangeLog
new file mode 100644
index 000000000000..c61f800362f7
--- /dev/null
+++ b/net-zope/zope-authentication/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zope-authentication
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-authentication/ChangeLog,v 1.1 2009/11/01 05:20:11 arfrever Exp $
+
+*zope-authentication-3.7.0 (01 Nov 2009)
+
+ 01 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zope-authentication-3.7.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/zope-authentication/metadata.xml b/net-zope/zope-authentication/metadata.xml
new file mode 100644
index 000000000000..ecc751f37510
--- /dev/null
+++ b/net-zope/zope-authentication/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/net-zope/zope-authentication/zope-authentication-3.7.0.ebuild b/net-zope/zope-authentication/zope-authentication-3.7.0.ebuild
new file mode 100644
index 000000000000..fa052e389626
--- /dev/null
+++ b/net-zope/zope-authentication/zope-authentication-3.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-authentication/zope-authentication-3.7.0.ebuild,v 1.1 2009/11/01 05:20:11 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Definition of authentication basics for the Zope Framework"
+HOMEPAGE="http://pypi.python.org/pypi/zope.authentication"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-zope/zope-browser
+ net-zope/zope-component
+ net-zope/zope-interface
+ net-zope/zope-schema
+ net-zope/zope-security"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN/-//}"
+DOCS="CHANGES.txt README.txt"