summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/pam_ssh_agent/ChangeLog8
-rw-r--r--sys-libs/pam_ssh_agent/Manifest14
-rw-r--r--sys-libs/pam_ssh_agent/files/digest-pam_ssh_agent-0.2-r11
-rw-r--r--sys-libs/pam_ssh_agent/files/pam_ssh_agent-0.2-openpam.patch35
-rw-r--r--sys-libs/pam_ssh_agent/pam_ssh_agent-0.2-r1.ebuild36
5 files changed, 82 insertions, 12 deletions
diff --git a/sys-libs/pam_ssh_agent/ChangeLog b/sys-libs/pam_ssh_agent/ChangeLog
index 2f2442440582..3aed8a0f7675 100644
--- a/sys-libs/pam_ssh_agent/ChangeLog
+++ b/sys-libs/pam_ssh_agent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/pam_ssh_agent
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam_ssh_agent/ChangeLog,v 1.5 2005/05/16 01:24:27 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam_ssh_agent/ChangeLog,v 1.6 2005/05/20 12:12:10 flameeyes Exp $
+
+*pam_ssh_agent-0.2-r1 (20 May 2005)
+
+ 20 May 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/pam_ssh_agent-0.2-openpam.patch, +pam_ssh_agent-0.2-r1.ebuild:
+ Added support for OpenPAM using the new pam eclass.
16 May 2005; Diego Pettenò <flameeyes@gentoo.org>
pam_ssh_agent-0.1.ebuild, pam_ssh_agent-0.2.ebuild:
diff --git a/sys-libs/pam_ssh_agent/Manifest b/sys-libs/pam_ssh_agent/Manifest
index a8062f5f7add..e3e89d42720d 100644
--- a/sys-libs/pam_ssh_agent/Manifest
+++ b/sys-libs/pam_ssh_agent/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 a6d16332152d73c8568d026bc29b6baa ChangeLog 877
MD5 a8cd1dda22d8abb57607d6a9120cbdee metadata.xml 306
MD5 1e5dc0bbe0ea0a7cabf31c4f3a440321 pam_ssh_agent-0.1.ebuild 806
-MD5 4199f38ca4a9632559fe0c513c549a66 pam_ssh_agent-0.2.ebuild 945
+MD5 2baccbb09b5a355751b0d539798f6fbe pam_ssh_agent-0.2-r1.ebuild 914
MD5 fc8f4b2dfc03ece3f7da24ed6b8258fa files/digest-pam_ssh_agent-0.1 68
MD5 d9ee254275c299e8f21bdcb01001bbc1 files/digest-pam_ssh_agent-0.2 68
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCh/ZWj5H05b2HAEkRAusqAJ9W5eNLiyRlFKe9EWGMTwY7g5InJQCfdQgb
-ji5DdC8Kb/TXLe/vUgBC8jU=
-=9ao+
------END PGP SIGNATURE-----
+MD5 8d7932cec30451a7cd9370aa8bcf16d0 files/pam_ssh_agent-0.2-openpam.patch 1040
+MD5 d9ee254275c299e8f21bdcb01001bbc1 files/digest-pam_ssh_agent-0.2-r1 68
diff --git a/sys-libs/pam_ssh_agent/files/digest-pam_ssh_agent-0.2-r1 b/sys-libs/pam_ssh_agent/files/digest-pam_ssh_agent-0.2-r1
new file mode 100644
index 000000000000..a41473cc815b
--- /dev/null
+++ b/sys-libs/pam_ssh_agent/files/digest-pam_ssh_agent-0.2-r1
@@ -0,0 +1 @@
+MD5 3514f813c6df58de28cc56c7c76566d7 pam_ssh_agent-0.2.tar.gz 11625
diff --git a/sys-libs/pam_ssh_agent/files/pam_ssh_agent-0.2-openpam.patch b/sys-libs/pam_ssh_agent/files/pam_ssh_agent-0.2-openpam.patch
new file mode 100644
index 000000000000..32120c137048
--- /dev/null
+++ b/sys-libs/pam_ssh_agent/files/pam_ssh_agent-0.2-openpam.patch
@@ -0,0 +1,35 @@
+diff -ur pam_ssh_agent-0.2/main.c pam_ssh_agent-0.2-openpam/main.c
+--- pam_ssh_agent-0.2/main.c 2004-02-28 21:54:52 +0000
++++ pam_ssh_agent-0.2-openpam/main.c 2005-05-16 08:38:55 +0000
+@@ -4,6 +4,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
++#include <stdlib.h>
+ #include "popen2.h"
+
+ #define DEFAULT_USER "nobody"
+@@ -11,7 +12,7 @@
+ #define MODULE_NAME "ssh_pam_agent"
+
+ #include <security/pam_modules.h>
+-#include <security/_pam_macros.h>
++#include <security/pam_appl.h>
+
+ #define CMD_LEN 512
+
+diff -ur pam_ssh_agent-0.2/popen2.c pam_ssh_agent-0.2-openpam/popen2.c
+--- pam_ssh_agent-0.2/popen2.c 2004-02-28 21:43:03 +0000
++++ pam_ssh_agent-0.2-openpam/popen2.c 2005-05-16 08:30:58 +0000
+@@ -1,9 +1,10 @@
+ #include "popen2.h"
+ #include <unistd.h>
++#include <stdlib.h>
+
+ #include <sys/types.h>
+ #include <sys/socket.h>
+-#include <wait.h>
++#include <sys/wait.h>
+
+ int popen2(const char* cmd, FILE **in, FILE **out, pid_t *child) {
+ int in_socks[2];
diff --git a/sys-libs/pam_ssh_agent/pam_ssh_agent-0.2-r1.ebuild b/sys-libs/pam_ssh_agent/pam_ssh_agent-0.2-r1.ebuild
new file mode 100644
index 000000000000..7cf542926aab
--- /dev/null
+++ b/sys-libs/pam_ssh_agent/pam_ssh_agent-0.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam_ssh_agent/pam_ssh_agent-0.2-r1.ebuild,v 1.1 2005/05/20 12:12:10 flameeyes Exp $
+
+inherit toolchain-funcs flag-o-matic eutils pam
+
+DESCRIPTION="PAM module that spawns a ssh-agent and adds identities using the password supplied at login"
+HOMEPAGE="http://pam-ssh-agent.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pam-ssh-agent/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="net-misc/keychain
+ virtual/pam
+ dev-tcltk/expect"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-openpam.patch
+ sed -i -e "s:gcc:$(tc-getCC) \${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ append-flags -fPIC
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dopammod ${S}/pam_ssh_agent.so
+ dodoc README
+}