summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/phploc/ChangeLog10
-rw-r--r--dev-php/phploc/phploc-1.6.1.ebuild19
-rw-r--r--dev-php/phploc/phploc-1.6.4.ebuild26
3 files changed, 34 insertions, 21 deletions
diff --git a/dev-php/phploc/ChangeLog b/dev-php/phploc/ChangeLog
index e209db19b9a7..67cf43efad65 100644
--- a/dev-php/phploc/ChangeLog
+++ b/dev-php/phploc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/phploc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phploc/ChangeLog,v 1.2 2011/12/14 22:51:26 mabi Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phploc/ChangeLog,v 1.3 2012/03/10 16:31:14 olemarkus Exp $
+
+*phploc-1.6.4 (10 Mar 2012)
+
+ 10 Mar 2012; Ole Markus With <olemarkus@gentoo.org> +phploc-1.6.4.ebuild,
+ -phploc-1.6.1.ebuild:
+ Version bump
14 Dec 2011; Matti Bickel <mabi@gentoo.org> phploc-1.6.1.ebuild:
Merging categories dev-php5 and dev-php (bug #324665)
diff --git a/dev-php/phploc/phploc-1.6.1.ebuild b/dev-php/phploc/phploc-1.6.1.ebuild
deleted file mode 100644
index 88f9cd6dbee7..000000000000
--- a/dev-php/phploc/phploc-1.6.1.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phploc/phploc-1.6.1.ebuild,v 1.3 2011/12/14 22:51:26 mabi Exp $
-
-EAPI="3"
-PHP_PEAR_CHANNEL="${FILESDIR}/channel.xml"
-PHP_PEAR_PN="phploc"
-inherit php-pear-lib-r1
-
-DESCRIPTION="A tool for quickly measuring the size of a PHP project"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-HOMEPAGE="http://www.phpunit.de"
-
-RDEPEND="${RDEPEND}
- >=dev-php/file-iterator-1.1.0
- >=dev-php/ezc-ConsoleTools-1.6.0"
diff --git a/dev-php/phploc/phploc-1.6.4.ebuild b/dev-php/phploc/phploc-1.6.4.ebuild
new file mode 100644
index 000000000000..ba297ac689d2
--- /dev/null
+++ b/dev-php/phploc/phploc-1.6.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phploc/phploc-1.6.4.ebuild,v 1.1 2012/03/10 16:31:13 olemarkus Exp $
+
+EAPI=4
+
+PEAR_PV="1.6.4"
+PHP_PEAR_PKG_NAME="phploc"
+
+inherit php-pear-r1
+
+DESCRIPTION="A tool for quickly measuring the size of a PHP project."
+HOMEPAGE="http://pear.phpunit.de"
+SRC_URI="http://pear.phpunit.de/get/phploc-1.6.4.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-lang/php[tokenizer]
+ >=dev-lang/php-5.2.7
+ >=dev-php/PEAR-PEAR-1.9.4
+ >=dev-php/File_Iterator-1.3.0
+ >=dev-php/ezc-ConsoleTools-1.6"
+RDEPEND="${DEPEND}"