summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/testify/ChangeLog7
-rw-r--r--dev-python/testify/files/testify-0.2.6-tests.patch7
-rw-r--r--dev-python/testify/testify-0.2.8.ebuild6
3 files changed, 9 insertions, 11 deletions
diff --git a/dev-python/testify/ChangeLog b/dev-python/testify/ChangeLog
index 838a0437a1d2..eb5be98811c4 100644
--- a/dev-python/testify/ChangeLog
+++ b/dev-python/testify/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/testify
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.4 2012/10/09 12:56:06 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.5 2012/11/12 16:22:17 idella4 Exp $
+
+ 13 Nov 2012; Ian Delaney <idella4@gentoo.org> files/testify-0.2.6-tests.patch,
+ testify-0.2.8.ebuild:
+ Unrestricted pypy from build, test restricted pypy, rem 1 redundant hunk from
+ tests patch, fixes Bug #438032
*testify-0.2.8 (09 Oct 2012)
diff --git a/dev-python/testify/files/testify-0.2.6-tests.patch b/dev-python/testify/files/testify-0.2.6-tests.patch
index 68a6fafdf029..fefb9b80d3db 100644
--- a/dev-python/testify/files/testify-0.2.6-tests.patch
+++ b/dev-python/testify/files/testify-0.2.6-tests.patch
@@ -27,10 +27,3 @@ https://github.com/Yelp/Testify/issues/65
def test_http_reporter_reports(self):
"""A simple test to make sure the HTTPReporter actually reports things."""
-@@ -74,4 +82,4 @@
- (first, second) = self.results_reported
-
- assert_equal(first['runner_id'], 'tries_twice')
-- assert_equal(first, second)
-\ Brak znaku nowej linii na końcu pliku
-+ assert_equal(first, second)
diff --git a/dev-python/testify/testify-0.2.8.ebuild b/dev-python/testify/testify-0.2.8.ebuild
index 35cca4c29ccf..3b655894531e 100644
--- a/dev-python/testify/testify-0.2.8.ebuild
+++ b/dev-python/testify/testify-0.2.8.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.2.8.ebuild,v 1.1 2012/10/09 12:56:06 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.2.8.ebuild,v 1.2 2012/11/12 16:22:17 idella4 Exp $
EAPI=4
SUPPORT_PYTHON_ABIS=1
# TODO: verify 2.5
-RESTRICT_PYTHON_ABIS="2.5 3.* 2.7-pypy-*"
-
+RESTRICT_PYTHON_ABIS="2.5 3.*"
+PYTHON_TESTS_RESTRICTED_ABIS="2.7-pypy-1.*"
inherit eutils distutils vcs-snapshot
DESCRIPTION="A more pythonic replacement for the unittest module and nose"