summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-roguelike/tomenet/ChangeLog6
-rw-r--r--games-roguelike/tomenet/files/tomenet-4.5.5-makefile.patch64
-rw-r--r--games-roguelike/tomenet/tomenet-4.5.5.ebuild100
3 files changed, 5 insertions, 165 deletions
diff --git a/games-roguelike/tomenet/ChangeLog b/games-roguelike/tomenet/ChangeLog
index 50a8ae567a88..2d79abd473f4 100644
--- a/games-roguelike/tomenet/ChangeLog
+++ b/games-roguelike/tomenet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/tomenet
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tomenet/ChangeLog,v 1.23 2015/02/18 09:13:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tomenet/ChangeLog,v 1.24 2015/02/19 04:13:40 mr_bones_ Exp $
+
+ 19 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/tomenet-4.5.5-makefile.patch, -tomenet-4.5.5.ebuild:
+ old
*tomenet-4.5.9 (18 Feb 2015)
diff --git a/games-roguelike/tomenet/files/tomenet-4.5.5-makefile.patch b/games-roguelike/tomenet/files/tomenet-4.5.5-makefile.patch
deleted file mode 100644
index d42c608e7b2e..000000000000
--- a/games-roguelike/tomenet/files/tomenet-4.5.5-makefile.patch
+++ /dev/null
@@ -1,64 +0,0 @@
---- src/makefile
-+++ src/makefile
-@@ -203,7 +203,7 @@
- #
- # This is my compiler of choice, it seems to work most everywhere
- #
--CC = gcc
-+CC ?= gcc
-
- # For allowing #if..#else..#endif constructs in LUA files - C. Blue
- # Note: The flags must contain
-@@ -215,16 +215,26 @@
- # need to use the gcc invocation below instead.
- #
- # cpp variant:
--CPP = cpp
--CPPFLAGS = -C -P
-+#CPP = cpp
-+#CPPFLAGS = -C -P
- # gcc variant:
--#CPP = gcc
--#CPPFLAGS = -x c -E -Wp,-C,-P
-+CPP ?= gcc
-+CPPFLAGS = -x c -E -Wp,-C,-P
-
-
- # For variations with X11
- X11BASE = /usr/X11R6
-
-+# defines
-+ifdef USE_SDL
-+CFLAGS += -DSOUND_SDL $(shell sdl-config --cflags)
-+SDL_LIBS = $(shell sdl-config --libs) -lSDL_mixer
-+endif
-+
-+ifdef USE_X
-+CFLAGS += -I${X11BASE}/include -DUSE_X11
-+LIBS += -L${X11BASE}/lib -lX11
-+endif
-
- ##
- ## Standard version -- supports X11 (main-x11.c)
-@@ -256,8 +266,9 @@
- # attempt to "guess" at many of these flags based on your system.
- #
- ## With SDL
--CFLAGS = -g -pipe -Wall -DUSE_X11 -DUSE_GCU -I${X11BASE}/include -D_XOPEN_SOURCE -D_BSD_SOURCE -DMEXP=19937 -DSOUND_SDL `sdl-config --cflags`
--LIBS = -L${X11BASE}/lib -L/usr/pkg/lib -lX11 -lncurses -lcrypt -lm `sdl-config --libs` -lSDL_mixer
-+CFLAGS += -Wall
-+CFLAGS += -DUSE_GCU -D_XOPEN_SOURCE -D_BSD_SOURCE -DMEXP=19937
-+LIBS += -L/usr/pkg/lib $(shell ${PKG_CONFIG} --libs ncurses) -lcrypt -lm ${SDL_LIBS}
- ##
- ## Without SDL
- #CFLAGS = -g -pipe -Wall -DUSE_X11 -DUSE_GCU -I${X11BASE}/include -D_XOPEN_SOURCE -D_BSD_SOURCE -DMEXP=19937
-@@ -357,9 +368,6 @@
- # Compile a client with 'test client' version/tag
- tomenet.test: CFLAGS += -DTEST_CLIENT -O0
-
--# Normal release build
--tomenet: CFLAGS += -O2
--
-
- # Lua
- SRCS += $(LUASRCS)
diff --git a/games-roguelike/tomenet/tomenet-4.5.5.ebuild b/games-roguelike/tomenet/tomenet-4.5.5.ebuild
deleted file mode 100644
index 7304c1a4868e..000000000000
--- a/games-roguelike/tomenet/tomenet-4.5.5.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tomenet/tomenet-4.5.5.ebuild,v 1.5 2015/02/18 09:13:13 mr_bones_ Exp $
-
-EAPI=5
-inherit eutils gnome2-utils toolchain-funcs games
-
-DESCRIPTION="A MMORPG based on the works of J.R.R. Tolkien"
-HOMEPAGE="http://www.tomenet.net/"
-SRC_URI="http://www.tomenet.net/downloads/${P}.tar.bz2"
-
-LICENSE="Moria"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="dedicated server +sound X"
-
-RDEPEND="sys-libs/ncurses
- !dedicated? (
- X? (
- x11-libs/libX11
- )
- sound? (
- media-libs/libsdl[sound]
- media-libs/sdl-mixer[vorbis,smpeg,mp3]
- )
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- !dedicated? ( sound? ( app-arch/p7zip[wxwidgets] ) )"
-
-S=${WORKDIR}/${P}/src
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
- use server || use dedicated || { rm -r ../lib/{config,data,save} || die ;}
-
- sed \
- -e "s#@LIBDIR@#${GAMES_DATADIR}/${PN}#" \
- "${FILESDIR}"/${PN}-wrapper > "${T}"/${PN} || die
-
- if use server || use dedicated ; then
- sed \
- -e "s#@LIBDIR@#${GAMES_DATADIR}/${PN}#" \
- "${FILESDIR}"/${PN}-server-wrapper > "${T}"/${PN}.server || die
- fi
-
- tc-export PKG_CONFIG
-}
-
-src_compile() {
- local mytargets="$(usex dedicated "accedit tomenet.server evilmeta" "$(usex server "all" "tomenet")")"
- emake \
- $(usex dedicated "" "$(usex X "USE_X=1" "")") \
- $(usex dedicated "" "$(usex sound "USE_SDL=1" "")") \
- -f makefile \
- ${mytargets[@]}
-}
-
-src_install() {
- dodoc ../TomeNET-Guide.txt
-
- if ! use dedicated ; then
- newgamesbin ${PN} ${PN}.bin
- dogamesbin "${T}"/${PN}
-
- doicon -s 48 client/tomenet4.png
- make_desktop_entry ${PN} ${PN} ${PN}4
- fi
-
- if use server || use dedicated ; then
- newgamesbin tomenet.server tomenet.server.bin
- dogamesbin "${T}"/${PN}.server accedit evilmeta
- fi
-
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r ../lib/*
- doins ../.tomenetrc
-
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
- gnome2_icon_cache_update
-
- if use sound; then
- elog "You can get soundpacks from here:"
- elog ' http://tomenet.net/downloads.php'
- elog "They must be placed inside ~/.tomenet directory."
- fi
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}