summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/kdelibs/kdelibs-3.2.3-r7.ebuild8
-rw-r--r--kde-base/kdelibs/kdelibs-3.2.3-r9.ebuild14
-rw-r--r--kde-base/kdelibs/kdelibs-3.3.2-r9.ebuild12
-rw-r--r--kde-base/kdelibs/kdelibs-3.4.0-r2.ebuild10
-rw-r--r--kde-base/kdelibs/kdelibs-3.4.1-r1.ebuild10
5 files changed, 27 insertions, 27 deletions
diff --git a/kde-base/kdelibs/kdelibs-3.2.3-r7.ebuild b/kde-base/kdelibs/kdelibs-3.2.3-r7.ebuild
index 22ec04313fa1..4eab5f90a224 100644
--- a/kde-base/kdelibs/kdelibs-3.2.3-r7.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.2.3-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.2.3-r7.ebuild,v 1.7 2005/07/08 20:35:36 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.2.3-r7.ebuild,v 1.8 2005/07/08 23:20:48 swegener Exp $
inherit kde eutils
@@ -9,7 +9,7 @@ set-kdedir ${PV}
DESCRIPTION="KDE libraries needed by all kde programs"
HOMEPAGE="http://www.kde.org/"
-SRC_URI="mirror://kde/stable/${PV}/src/${PN}-${PV}.tar.bz2
+SRC_URI="mirror://kde/stable/${PV}/src/${P}.tar.bz2
mirror://kde/security_patches/post-3.2.3-kdelibs-kcookiejar.patch
mirror://kde/security_patches/post-3.2.3-kdelibs-kstandarddirs.patch
mirror://kde/security_patches/post-3.2.3-kdelibs-htmlframes2.patch
@@ -48,11 +48,11 @@ RDEPEND="${DEPEND}
dev-lang/python"
src_unpack() {
- unpack $PN-$PV.tar.bz2
+ unpack ${P}.tar.bz2
# This is an ugly hack: it makes base_src_unpack do nothing, but still lets us enjoy
# the other things kde_src_unpack does.
kde_src_unpack nounpack
-
+
epatch ${DISTDIR}/post-3.2.3-kdelibs-kcookiejar.patch
epatch ${DISTDIR}/post-3.2.3-kdelibs-kstandarddirs.patch
epatch ${FILESDIR}/post-3.2.3-kdelibs-htmlframes.patch
diff --git a/kde-base/kdelibs/kdelibs-3.2.3-r9.ebuild b/kde-base/kdelibs/kdelibs-3.2.3-r9.ebuild
index 07d6b8770d88..fd7abc4ffe03 100644
--- a/kde-base/kdelibs/kdelibs-3.2.3-r9.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.2.3-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.2.3-r9.ebuild,v 1.6 2005/07/08 20:35:36 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.2.3-r9.ebuild,v 1.7 2005/07/08 23:20:48 swegener Exp $
inherit kde eutils
@@ -9,7 +9,7 @@ set-kdedir ${PV}
DESCRIPTION="KDE libraries needed by all kde programs"
HOMEPAGE="http://www.kde.org/"
-SRC_URI="mirror://kde/stable/${PV}/src/${PN}-${PV}.tar.bz2
+SRC_URI="mirror://kde/stable/${PV}/src/${P}.tar.bz2
mirror://kde/security_patches/post-3.2.3-kdelibs-kcookiejar.patch
mirror://kde/security_patches/post-3.2.3-kdelibs-kstandarddirs.patch
mirror://kde/security_patches/post-3.2.3-kdelibs-htmlframes2.patch
@@ -49,10 +49,10 @@ RDEPEND="${DEPEND}
dev-lang/python"
src_unpack() {
- unpack $PN-$PV.tar.bz2
- # This is an ugly hack: it makes base_src_unpack do nothing, but still lets us enjoy
- # the other things kde_src_unpack does.
- kde_src_unpack nounpack
+ unpack ${P}.tar.bz2
+ # This is an ugly hack: it makes base_src_unpack do nothing, but still lets us enjoy
+ # the other things kde_src_unpack does.
+ kde_src_unpack nounpack
epatch ${DISTDIR}/post-3.2.3-kdelibs-kcookiejar.patch
epatch ${DISTDIR}/post-3.2.3-kdelibs-kstandarddirs.patch
@@ -61,7 +61,7 @@ src_unpack() {
epatch ${FILESDIR}/post-3.2.3-kdelibs-khtml.diff
epatch ${DISTDIR}/post-3.2.3-kdelibs-kioslave.patch
epatch ${FILESDIR}/kde3-dcopidlng.patch
- cd ${S}/kio && patch -p0 < ${DISTDIR}/post-3.2.3-kdelibs-kio.diff
+ cd ${S}/kio && patch -p0 < ${DISTDIR}/post-3.2.3-kdelibs-kio.diff
cd ${S}/dcop && patch -p0 < ${DISTDIR}/post-3.2.3-kdelibs-dcopserver.patch
cd ${S}
epatch ${DISTDIR}/post-3.2.3-kdelibs-dcop.patch
diff --git a/kde-base/kdelibs/kdelibs-3.3.2-r9.ebuild b/kde-base/kdelibs/kdelibs-3.3.2-r9.ebuild
index cb0aa65b037a..8c4d7ea68062 100644
--- a/kde-base/kdelibs/kdelibs-3.3.2-r9.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.3.2-r9.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.3.2-r9.ebuild,v 1.10 2005/07/08 20:35:36 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.3.2-r9.ebuild,v 1.11 2005/07/08 23:20:48 swegener Exp $
inherit kde eutils flag-o-matic
set-kdedir 3.3
DESCRIPTION="KDE libraries needed by all kde programs"
HOMEPAGE="http://www.kde.org/"
-SRC_URI="mirror://kde/stable/${PV}/src/${PN}-${PV}.tar.bz2
+SRC_URI="mirror://kde/stable/${PV}/src/${P}.tar.bz2
mirror://kde/security_patches/post-3.3.2-kdelibs-dcop.patch
mirror://kde/security_patches/post-3.3.2-kdelibs-idn-2.patch
mirror://kde/security_patches/post-3.3.2-kdelibs-kimgio-fixed.diff
@@ -49,10 +49,10 @@ DEPEND="${RDEPEND}
!kde-misc/kgamma"
src_unpack() {
- unpack $PN-$PV.tar.bz2
- # This is an ugly hack: it makes base_src_unpack do nothing, but still lets us enjoy
- # the other things kde_src_unpack does.
- kde_src_unpack nounpack
+ unpack ${P}.tar.bz2
+ # This is an ugly hack: it makes base_src_unpack do nothing, but still lets us enjoy
+ # the other things kde_src_unpack does.
+ kde_src_unpack nounpack
cd $S/kio/kio && patch -p0 <${DISTDIR}/post-3.3.2-kdelibs-kio.diff
cd $S
diff --git a/kde-base/kdelibs/kdelibs-3.4.0-r2.ebuild b/kde-base/kdelibs/kdelibs-3.4.0-r2.ebuild
index cfedf76b252c..a69ed65629cd 100644
--- a/kde-base/kdelibs/kdelibs-3.4.0-r2.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.4.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.4.0-r2.ebuild,v 1.4 2005/07/08 20:35:37 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.4.0-r2.ebuild,v 1.5 2005/07/08 23:20:48 swegener Exp $
inherit kde eutils flag-o-matic
set-qtdir 3
@@ -50,10 +50,10 @@ DEPEND="${RDEPEND}
#PATCHES="${FILESDIR}/${PN}-3.4.0_beta2-export-kio-symbols.diff"
src_unpack() {
- unpack $PN-$PV.tar.bz2
- # This is an ugly hack: it makes base_src_unpack do nothing, but still lets us enjoy
- # the other things kde_src_unpack does.
- kde_src_unpack nounpack
+ unpack ${P}.tar.bz2
+ # This is an ugly hack: it makes base_src_unpack do nothing, but still lets us enjoy
+ # the other things kde_src_unpack does.
+ kde_src_unpack nounpack
# Fix freezing in web forms (kde bug 100963). Applied for 3.4.1.
epatch "${FILESDIR}/${P}-form-freeze.patch"
diff --git a/kde-base/kdelibs/kdelibs-3.4.1-r1.ebuild b/kde-base/kdelibs/kdelibs-3.4.1-r1.ebuild
index db7d4a5e85b0..7e50ef60ba23 100644
--- a/kde-base/kdelibs/kdelibs-3.4.1-r1.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.4.1-r1.ebuild,v 1.8 2005/07/08 20:35:37 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.4.1-r1.ebuild,v 1.9 2005/07/08 23:20:48 swegener Exp $
inherit kde flag-o-matic eutils multilib
set-qtdir 3
@@ -47,10 +47,10 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_unpack() {
- unpack $PN-$PV.tar.bz2
- # This is an ugly hack: it makes base_src_unpack do nothing, but still lets us enjoy
- # the other things kde_src_unpack does.
- kde_src_unpack nounpack
+ unpack ${P}.tar.bz2
+ # This is an ugly hack: it makes base_src_unpack do nothing, but still lets us enjoy
+ # the other things kde_src_unpack does.
+ kde_src_unpack nounpack
epatch "${FILESDIR}/${P}-configure.patch"