summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/haskell-src-exts/ChangeLog9
-rw-r--r--dev-haskell/haskell-src-exts/files/haskell-src-exts-1.10.2-Setup.hs8
-rw-r--r--dev-haskell/haskell-src-exts/haskell-src-exts-1.11.1.ebuild37
3 files changed, 52 insertions, 2 deletions
diff --git a/dev-haskell/haskell-src-exts/ChangeLog b/dev-haskell/haskell-src-exts/ChangeLog
index 2e3785250d13..8513577e0c70 100644
--- a/dev-haskell/haskell-src-exts/ChangeLog
+++ b/dev-haskell/haskell-src-exts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/haskell-src-exts
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src-exts/ChangeLog,v 1.13 2010/07/12 18:53:17 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src-exts/ChangeLog,v 1.14 2012/01/23 11:36:28 gienah Exp $
+
+*haskell-src-exts-1.11.1 (23 Jan 2012)
+
+ 23 Jan 2012; Mark Wright <gienah@gentoo.org> +haskell-src-exts-1.11.1.ebuild:
+ Bump haskell-src-exts to 1.11.1.
12 Jul 2010; Sergei Trofimovich <slyfox@gentoo.org>
haskell-src-exts-0.2.ebuild:
diff --git a/dev-haskell/haskell-src-exts/files/haskell-src-exts-1.10.2-Setup.hs b/dev-haskell/haskell-src-exts/files/haskell-src-exts-1.10.2-Setup.hs
new file mode 100644
index 000000000000..63a6c22bf33c
--- /dev/null
+++ b/dev-haskell/haskell-src-exts/files/haskell-src-exts-1.10.2-Setup.hs
@@ -0,0 +1,8 @@
+import Distribution.Simple
+import System.Process (rawSystem)
+import System.Exit (ExitCode(..))
+import System.FilePath ((</>))
+main = defaultMainWithHooks $ simpleUserHooks { runTests = \args _ _ _ -> do
+ ExitSuccess <- rawSystem "runhaskell" ("-package-conf=dist/package.conf.inplace" : "Test/Runner.hs" : args)
+ return ()
+ }
diff --git a/dev-haskell/haskell-src-exts/haskell-src-exts-1.11.1.ebuild b/dev-haskell/haskell-src-exts/haskell-src-exts-1.11.1.ebuild
new file mode 100644
index 000000000000..e6e5d8d377c9
--- /dev/null
+++ b/dev-haskell/haskell-src-exts/haskell-src-exts-1.11.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src-exts/haskell-src-exts-1.11.1.ebuild,v 1.1 2012/01/23 11:36:28 gienah Exp $
+
+# ebuild generated by hackport 0.2.14
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Manipulating Haskell source: abstract syntax, lexer, parser, and pretty-printer"
+HOMEPAGE="http://code.haskell.org/haskell-src-exts"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cpphs-1.3
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+ dev-haskell/happy"
+
+src_prepare() {
+ # test suite is broken, expects the package to be already installed.
+ # this new Setup.hs will use the package inplice for tests
+ cp "${FILESDIR}/haskell-src-exts-1.10.2-Setup.hs" "${S}/Setup.hs" \
+ || die "Could not cp Setup.hs for tests"
+
+ # remove broken tests. they will fail if you expect them to pass, and pass
+ # if you expect them to fail...
+ rm "${S}/Test/examples/Unicode"{.hs,Syntax.hs} \
+ || die "Could not rm broken tests"
+}