summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-astronomy/celestia/ChangeLog8
-rw-r--r--sci-astronomy/celestia/celestia-1.6.1.ebuild11
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-as-needed.patch19
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-gold.patch23
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-linking.patch54
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-underlinking.patch21
6 files changed, 64 insertions, 72 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 3f58509d5ac7..dba5254c92a6 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.80 2011/10/31 23:20:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.81 2011/11/01 08:13:01 xarthisius Exp $
+
+ 01 Nov 2011; Kacper Kowalik <xarthisius@gentoo.org> celestia-1.6.1.ebuild,
+ -files/celestia-1.6.1-as-needed.patch, -files/celestia-1.6.1-gold.patch,
+ +files/celestia-1.6.1-linking.patch,
+ -files/celestia-1.6.1-underlinking.patch:
+ Combine all patches fixing linking issues into one
31 Oct 2011; Samuli Suominen <ssuominen@gentoo.org>
-files/celestia-1.4.1-as-needed.patch, -files/celestia-1.5.1-gcc44.patch,
diff --git a/sci-astronomy/celestia/celestia-1.6.1.ebuild b/sci-astronomy/celestia/celestia-1.6.1.ebuild
index 281fbd49953c..e4cfab331154 100644
--- a/sci-astronomy/celestia/celestia-1.6.1.ebuild
+++ b/sci-astronomy/celestia/celestia-1.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.1.ebuild,v 1.9 2011/10/31 20:08:58 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.1.ebuild,v 1.10 2011/11/01 08:13:01 xarthisius Exp $
EAPI=2
@@ -54,16 +54,11 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.5.0-desktop.patch
# add a ~/.celestia for extra directories
epatch "${FILESDIR}"/${PN}-1.6.0-cfg.patch
- # --as-needed fix
- epatch "${FILESDIR}"/${P}-as-needed.patch
# fix missing includes for gcc-4.6
epatch "${FILESDIR}"/${P}-gcc46.patch
- # underlinking fix with USE="-gnome -gtk"
- epatch "${FILESDIR}"/${P}-gold.patch
# missing zlib.h include with libpng15
- epatch "${FILESDIR}"/${P}-libpng15.patch
- # another underlinking fix, bug 387609
- epatch "${FILESDIR}"/${P}-underlinking.patch
+ epatch "${FILESDIR}"/${P}-libpng15.patch \
+ "${FILESDIR}"/${P}-linking.patch
# remove flags to let the user decide
for cf in -O2 -ffast-math \
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-as-needed.patch b/sci-astronomy/celestia/files/celestia-1.6.1-as-needed.patch
deleted file mode 100644
index 5b9d2ddfc03c..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.1-as-needed.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Fixes building with as-needed
-
-Patch written by Nils Larsson <ni1s@nerdshack.com>
---- src/celestia/Makefile.am
-+++ src/celestia/Makefile.am
-@@ -10,11 +10,13@@
- celestiaKDELIBS = $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE) \
- $(LIBSOCKET) kde/libkdegui.a
- celestia_LDFLAGS = $(all_libraries) $(KDE_RPATH)
-+LIBS += $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE)
- endif
-
- if ENABLE_GTK
- SUBDIRS += gtk
- celestiaGTKLIBS = $(GTK_LIBS) gtk/libgtkgui.a
-+LIBS += $(GTK_LIBS)
- endif
-
- COMMONSOURCES = \
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-gold.patch b/sci-astronomy/celestia/files/celestia-1.6.1-gold.patch
deleted file mode 100644
index 392523324e09..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.1-gold.patch
+++ /dev/null
@@ -1,23 +0,0 @@
- src/celestia/Makefile.am | 2 ++
- 1 files changed, 2 insertions(+), 0 deletions(-)
-
-diff --git a/src/celestia/Makefile.am b/src/celestia/Makefile.am
-index b1e4b3f..b0809a5 100644
---- a/src/celestia/Makefile.am
-+++ b/src/celestia/Makefile.am
-@@ -62,6 +62,7 @@ endif
-
- if ENABLE_GLUT
- GLUTSOURCES = glutmain.cpp
-+GLUTLIBS = -lGL
- endif
-
- if ENABLE_THEORA
-@@ -83,6 +84,7 @@ celestia_LDADD = \
- $(DL_LIBS) \
- $(LUA_LIBS) \
- $(THEORA_LIBS) \
-+ $(GLUTLIBS) \
- ../celengine/libcelengine.a \
- ../celtxf/libceltxf.a \
- ../cel3ds/libcel3ds.a \
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-linking.patch b/sci-astronomy/celestia/files/celestia-1.6.1-linking.patch
new file mode 100644
index 000000000000..d610d5243f2a
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.6.1-linking.patch
@@ -0,0 +1,54 @@
+Fix linking issues:
+ * underlinking GLUT (bug #372123, #387609)
+ * as-needed (bug #281258)
+
+--- a/src/celestia/Makefile.am
++++ b/src/celestia/Makefile.am
+@@ -7,14 +7,15 @@
+
+ if ENABLE_KDE
+ SUBDIRS += kde
+-celestiaKDELIBS = $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE) \
+- $(LIBSOCKET) -lDCOP kde/libkdegui.a
++celestiaKDELIBS = kde/libkdegui.a
+ celestia_LDFLAGS = $(all_libraries) $(KDE_RPATH)
++LIBS += $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE) $(LIBSOCKET) -lDCOP
+ endif
+
+ if ENABLE_GTK
+ SUBDIRS += gtk
+-celestiaGTKLIBS = $(GTK_LIBS) gtk/libgtkgui.a
++celestiaGTKLIBS = gtk/libgtkgui.a
++LIBS += $(GTK_LIBS)
+ endif
+
+ COMMONSOURCES = \
+@@ -62,6 +63,7 @@
+
+ if ENABLE_GLUT
+ GLUTSOURCES = glutmain.cpp
++GLUTLIBS = -lGL
+ endif
+
+ if ENABLE_THEORA
+@@ -80,15 +82,16 @@
+ celestia_LDADD = \
+ $(celestiaKDELIBS) \
+ $(celestiaGTKLIBS) \
+- $(DL_LIBS) \
+- $(LUA_LIBS) \
+- $(THEORA_LIBS) \
+ ../celengine/libcelengine.a \
+ ../celtxf/libceltxf.a \
+ ../cel3ds/libcel3ds.a \
+ ../celmath/libcelmath.a \
+ ../celutil/libcelutil.a \
+- $(SPICE_LIBS)
++ $(LUA_LIBS) \
++ $(THEORA_LIBS) \
++ $(GLUTLIBS) \
++ $(SPICE_LIBS) \
++ $(DL_LIBS)
+
+ noinst_HEADERS = $(wildcard *.h)
+ noinst_DATA = ../../celestia
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-underlinking.patch b/sci-astronomy/celestia/files/celestia-1.6.1-underlinking.patch
deleted file mode 100644
index 3cb62f3b8583..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.1-underlinking.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ruN celestia-1.6.1.orig/src/celestia/Makefile.am celestia-1.6.1/src/celestia/Makefile.am
---- celestia-1.6.1.orig/src/celestia/Makefile.am 2011-06-05 18:11:13.000000000 +0200
-+++ celestia-1.6.1/src/celestia/Makefile.am 2011-10-31 21:02:23.000000000 +0100
-@@ -80,7 +80,6 @@
- celestia_LDADD = \
- $(celestiaKDELIBS) \
- $(celestiaGTKLIBS) \
-- $(DL_LIBS) \
- $(LUA_LIBS) \
- $(THEORA_LIBS) \
- ../celengine/libcelengine.a \
-@@ -88,7 +87,8 @@
- ../cel3ds/libcel3ds.a \
- ../celmath/libcelmath.a \
- ../celutil/libcelutil.a \
-- $(SPICE_LIBS)
-+ $(SPICE_LIBS) \
-+ $(DL_LIBS)
-
- noinst_HEADERS = $(wildcard *.h)
- noinst_DATA = ../../celestia