summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/kf/ChangeLog8
-rw-r--r--net-im/kf/kf-0.1.3.ebuild8
-rw-r--r--net-im/kf/kf-0.1.4.1.ebuild15
-rw-r--r--net-im/kf/kf-0.1.5.ebuild16
-rw-r--r--net-im/kf/kf-0.5.4.1.ebuild18
5 files changed, 39 insertions, 26 deletions
diff --git a/net-im/kf/ChangeLog b/net-im/kf/ChangeLog
index fc8b18b4a90a..e0f2d0afc490 100644
--- a/net-im/kf/ChangeLog
+++ b/net-im/kf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/kf
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kf/ChangeLog,v 1.13 2008/03/14 10:21:54 phreak Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/kf/ChangeLog,v 1.14 2011/03/02 21:03:56 signals Exp $
+
+ 02 Mar 2011; Kevin McCarthy <signals@gentoo.org> kf-0.1.3.ebuild,
+ kf-0.1.4.1.ebuild, kf-0.1.5.ebuild, kf-0.5.4.1.ebuild:
+ Slotted gtk+ depend and EAPI=2 bump to support it.
14 Mar 2008; Christian Heim <phreak@gentoo.org> kf-0.1.3.ebuild,
kf-0.1.4.1.ebuild, kf-0.1.5.ebuild, kf-0.5.4.1.ebuild:
diff --git a/net-im/kf/kf-0.1.3.ebuild b/net-im/kf/kf-0.1.3.ebuild
index c22a8690eef6..c3a593b0010a 100644
--- a/net-im/kf/kf-0.1.3.ebuild
+++ b/net-im/kf/kf-0.1.3.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kf/kf-0.1.3.ebuild,v 1.6 2008/03/14 10:21:54 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kf/kf-0.1.3.ebuild,v 1.7 2011/03/02 21:03:56 signals Exp $
+
+EAPI=2
DESCRIPTION="kf is a simple Jabber messenger."
HOMEPAGE="http://www.habazie.rams.pl/kf/"
SRC_URI="http://www.habazie.rams.pl/kf/files/${P}.tar.gz"
LICENSE="GPL-2"
-DEPEND=">=x11-libs/gtk+-2
+DEPEND="x11-libs/gtk+:2
>=net-libs/loudmouth-0.15.1
>=gnome-base/libglade-2"
SLOT="0"
diff --git a/net-im/kf/kf-0.1.4.1.ebuild b/net-im/kf/kf-0.1.4.1.ebuild
index a6b84cb24fc8..08c931dd38ed 100644
--- a/net-im/kf/kf-0.1.4.1.ebuild
+++ b/net-im/kf/kf-0.1.4.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kf/kf-0.1.4.1.ebuild,v 1.5 2008/03/14 10:21:54 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kf/kf-0.1.4.1.ebuild,v 1.6 2011/03/02 21:03:56 signals Exp $
+EAPI=2
inherit eutils
DESCRIPTION="kf is a simple Jabber messenger."
@@ -10,19 +11,21 @@ SRC_URI="http://www.habazie.rams.pl/kf/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
IUSE="spell"
-DEPEND=">=x11-libs/gtk+-2
+DEPEND="x11-libs/gtk+:2
>=net-libs/loudmouth-0.16
>=gnome-base/libglade-2
spell? ( >=app-text/gtkspell-2.0.4 )"
KEYWORDS="~x86 ~ppc ~sparc"
-src_unpack() {
- unpack ${A}
+src_prepare() {
epatch "${FILESDIR}"/${P}-gtkspell-2.0.4-compatibility.diff
}
-src_compile() {
+src_configure() {
econf `use_enable spell gtkspell` || die 'econf failed'
+}
+
+src_compile() {
emake || die 'emake failed'
}
diff --git a/net-im/kf/kf-0.1.5.ebuild b/net-im/kf/kf-0.1.5.ebuild
index b63916af27ca..5b13e6909742 100644
--- a/net-im/kf/kf-0.1.5.ebuild
+++ b/net-im/kf/kf-0.1.5.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kf/kf-0.1.5.ebuild,v 1.2 2008/03/14 10:21:54 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kf/kf-0.1.5.ebuild,v 1.3 2011/03/02 21:03:56 signals Exp $
+EAPI=2
inherit eutils
DESCRIPTION="kf is a simple Jabber messenger."
@@ -10,20 +11,21 @@ SRC_URI="http://www.habazie.rams.pl/kf/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
IUSE="spell"
-DEPEND=">=x11-libs/gtk+-2
+DEPEND="x11-libs/gtk+:2
>=net-libs/loudmouth-0.16
>=gnome-base/libglade-2
spell? ( >=app-text/gtkspell-2.0.4 )"
KEYWORDS="~x86 ~ppc ~sparc"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-0.1.4.1-gtkspell-2.0.4-compatibility.diff
}
-src_compile() {
+src_configure() {
econf `use_enable spell gtkspell` || die 'econf failed'
+}
+
+src_install() {
emake || die 'emake failed'
}
diff --git a/net-im/kf/kf-0.5.4.1.ebuild b/net-im/kf/kf-0.5.4.1.ebuild
index 66b0bffa2bf1..5e463831574e 100644
--- a/net-im/kf/kf-0.5.4.1.ebuild
+++ b/net-im/kf/kf-0.5.4.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kf/kf-0.5.4.1.ebuild,v 1.2 2008/03/14 10:21:54 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kf/kf-0.5.4.1.ebuild,v 1.3 2011/03/02 21:03:56 signals Exp $
+EAPI=2
inherit eutils
DESCRIPTION="kf is a simple Jabber messenger."
@@ -10,23 +11,24 @@ SRC_URI="http://files.jabberstudio.org/kf/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
IUSE="spell debug"
-DEPEND=">=x11-libs/gtk+-2
+DEPEND="x11-libs/gtk+:2
>=net-libs/loudmouth-0.16
>=gnome-base/libglade-2
spell? ( >=app-text/gtkspell-2.0.4 )"
KEYWORDS="~x86 ~ppc ~sparc"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# wrong use of typedef struct _KfJispManager
epatch "${FILESDIR}"/${P}-typedef_KfJispManager.patch
}
-src_compile() {
+
+src_configure() {
econf $(use_enable spell gtkspell) \
$(use_enable debug) || die 'econf failed'
+}
+
+src_compile() {
emake || die 'emake failed'
}