summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/netcdf/ChangeLog8
-rw-r--r--sci-libs/netcdf/metadata.xml14
-rw-r--r--sci-libs/netcdf/netcdf-4.1.1-r4.ebuild5
-rw-r--r--sci-libs/netcdf/netcdf-4.1.3.ebuild9
-rw-r--r--sci-libs/netcdf/netcdf-4.2.1.1.ebuild5
-rw-r--r--sci-libs/netcdf/netcdf-4.2.1.ebuild5
-rw-r--r--sci-libs/netcdf/netcdf-4.2.ebuild5
7 files changed, 28 insertions, 23 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index 5f5dccca4f2c..a4b788341032 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/netcdf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.106 2012/10/14 19:25:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.107 2012/10/16 20:31:51 jlec Exp $
+
+ 16 Oct 2012; Justin Lecher <jlec@gentoo.org> netcdf-4.1.1-r4.ebuild,
+ netcdf-4.1.3.ebuild, netcdf-4.2.ebuild, netcdf-4.2.1.ebuild,
+ netcdf-4.2.1.1.ebuild, metadata.xml:
+ Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the
+ updated fortran-2.eclass
14 Oct 2012; Justin Lecher <jlec@gentoo.org> netcdf-4.1.1-r4.ebuild,
netcdf-4.1.3.ebuild:
diff --git a/sci-libs/netcdf/metadata.xml b/sci-libs/netcdf/metadata.xml
index ded8ea141227..c42a692152a7 100644
--- a/sci-libs/netcdf/metadata.xml
+++ b/sci-libs/netcdf/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
NetCDF (network Common Data Form) is an interface for scientific
data access and a freely-distributed software library that provides an
implementation of the interface. The netCDF library also defines a
@@ -10,9 +10,9 @@
Together, the interface, library, and format support the creation,
access, and sharing of scientific data.
</longdescription>
-<use>
- <flag name="dap">Support for remote data access with the built-in OPeNDAP client</flag>
- <flag name="hdf">Add support for the Hierarchical Data Format v.4 <pkg>sci-libs/hdf</pkg></flag>
- <flag name="tools">Build the utilities nccopy, ncgen and ncdump</flag>
-</use>
+ <use>
+ <flag name="dap">Support for remote data access with the built-in OPeNDAP client</flag>
+ <flag name="hdf">Add support for the Hierarchical Data Format v.4 <pkg>sci-libs/hdf</pkg></flag>
+ <flag name="tools">Build the utilities nccopy, ncgen and ncdump</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild b/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild
index 14f946bc95b6..c6d56d5e6da1 100644
--- a/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild
+++ b/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild,v 1.18 2012/10/14 19:25:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild,v 1.19 2012/10/16 20:31:51 jlec Exp $
EAPI=3
@@ -19,7 +19,6 @@ KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86
IUSE="cxx dap doc fortran hdf5 static-libs szip"
RDEPEND="
- fortran? ( virtual/fortran )
dap? ( net-misc/curl )
hdf5? ( >=sci-libs/hdf5-1.8[zlib,szip?,fortran?] )"
@@ -38,7 +37,7 @@ PATCHES=(
)
pkg_setup() {
- use fortran && fortran-2_pkg_setup
+ fortran-2_pkg_setup
if use hdf5 && has_version sci-libs/hdf5[mpi]; then
export CC=mpicc
if use cxx; then
diff --git a/sci-libs/netcdf/netcdf-4.1.3.ebuild b/sci-libs/netcdf/netcdf-4.1.3.ebuild
index 6d229f9c2882..3d7c0dee140b 100644
--- a/sci-libs/netcdf/netcdf-4.1.3.ebuild
+++ b/sci-libs/netcdf/netcdf-4.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.1.3.ebuild,v 1.7 2012/10/14 19:25:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.1.3.ebuild,v 1.8 2012/10/16 20:31:51 jlec Exp $
EAPI=4
@@ -19,7 +19,6 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos
IUSE="cxx dap doc fortran hdf5 static-libs"
RDEPEND="
- fortran? ( virtual/fortran )
dap? ( net-misc/curl )
hdf5? ( >=sci-libs/hdf5-1.8.6[zlib,szip,fortran?] )"
@@ -36,10 +35,8 @@ PATCHES=(
)
pkg_setup() {
- if use fortran; then
- FORTRAN_STANDARD="77 90"
- fortran-2_pkg_setup
- fi
+ FORTRAN_STANDARD="77 90"
+ fortran-2_pkg_setup
if use hdf5 && has_version sci-libs/hdf5[mpi]; then
export CC=mpicc
use cxx && export CXX=mpicxx
diff --git a/sci-libs/netcdf/netcdf-4.2.1.1.ebuild b/sci-libs/netcdf/netcdf-4.2.1.1.ebuild
index d60150ca4ecb..cfda9317f582 100644
--- a/sci-libs/netcdf/netcdf-4.2.1.1.ebuild
+++ b/sci-libs/netcdf/netcdf-4.2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.2.1.1.ebuild,v 1.1 2012/08/08 21:35:31 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.2.1.1.ebuild,v 1.2 2012/10/16 20:31:51 jlec Exp $
EAPI=4
@@ -15,7 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="+dap doc examples hdf +hdf5 mpi static-libs szip test tools"
-RDEPEND="dap? ( net-misc/curl )
+RDEPEND="
+ dap? ( net-misc/curl )
hdf? ( sci-libs/hdf >=sci-libs/hdf5-1.8.8 )
hdf5? ( >=sci-libs/hdf5-1.8.8[mpi=,szip=,zlib] )"
diff --git a/sci-libs/netcdf/netcdf-4.2.1.ebuild b/sci-libs/netcdf/netcdf-4.2.1.ebuild
index 464e150848c6..5d26dbb7f45c 100644
--- a/sci-libs/netcdf/netcdf-4.2.1.ebuild
+++ b/sci-libs/netcdf/netcdf-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.2.1.ebuild,v 1.1 2012/08/02 21:14:43 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.2.1.ebuild,v 1.2 2012/10/16 20:31:51 jlec Exp $
EAPI=4
@@ -15,7 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="+dap doc examples hdf +hdf5 mpi static-libs szip test tools"
-RDEPEND="dap? ( net-misc/curl )
+RDEPEND="
+ dap? ( net-misc/curl )
hdf? ( sci-libs/hdf >=sci-libs/hdf5-1.8.8 )
hdf5? ( >=sci-libs/hdf5-1.8.8[mpi=,szip=,zlib] )"
diff --git a/sci-libs/netcdf/netcdf-4.2.ebuild b/sci-libs/netcdf/netcdf-4.2.ebuild
index e9f7723bcb11..a6715d115a6c 100644
--- a/sci-libs/netcdf/netcdf-4.2.ebuild
+++ b/sci-libs/netcdf/netcdf-4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.2.ebuild,v 1.2 2012/04/23 16:11:43 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.2.ebuild,v 1.3 2012/10/16 20:31:51 jlec Exp $
EAPI=4
@@ -15,7 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="+dap doc hdf +hdf5 mpi static-libs szip tools"
-RDEPEND="dap? ( net-misc/curl )
+RDEPEND="
+ dap? ( net-misc/curl )
hdf? ( sci-libs/hdf >=sci-libs/hdf5-1.8.8 )
hdf5? ( >=sci-libs/hdf5-1.8.8[mpi=,szip=,zlib] )"