summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/parcellite/ChangeLog8
-rw-r--r--x11-misc/parcellite/parcellite-0.9.1.ebuild44
-rw-r--r--x11-misc/parcellite/parcellite-1.0.2_rc5-r1.ebuild (renamed from x11-misc/parcellite/parcellite-1.0.1.ebuild)38
3 files changed, 28 insertions, 62 deletions
diff --git a/x11-misc/parcellite/ChangeLog b/x11-misc/parcellite/ChangeLog
index a54e1f04dd2b..39d5834df3f0 100644
--- a/x11-misc/parcellite/ChangeLog
+++ b/x11-misc/parcellite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/parcellite
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.22 2012/09/28 14:57:59 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.23 2012/09/28 15:50:45 jer Exp $
+
+*parcellite-1.0.2_rc5-r1 (28 Sep 2012)
+
+ 28 Sep 2012; Jeroen Roovers <jer@gentoo.org> -parcellite-0.9.1.ebuild,
+ -parcellite-1.0.1.ebuild, +parcellite-1.0.2_rc5-r1.ebuild:
+ Add LINGUAS support so that USE=nls actually makes sense.
28 Sep 2012; Jeroen Roovers <jer@gentoo.org> parcellite-1.0.2_rc5.ebuild:
Fix Manifest to allow newer tarball with same name but without the compiled
diff --git a/x11-misc/parcellite/parcellite-0.9.1.ebuild b/x11-misc/parcellite/parcellite-0.9.1.ebuild
deleted file mode 100644
index da6af8c6fdbf..000000000000
--- a/x11-misc/parcellite/parcellite-0.9.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-0.9.1.ebuild,v 1.5 2012/07/31 22:41:49 hasufell Exp $
-
-EAPI=2
-inherit fdo-mime flag-o-matic
-
-DESCRIPTION="A lightweight GTK+ based clipboard manager."
-HOMEPAGE="http://parcellite.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="nls"
-
-RDEPEND="x11-libs/gtk+:2
- dev-libs/glib:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext
- dev-util/intltool )"
-
-src_configure() {
- append-libs -lX11
- econf --disable-dependency-tracking $(use_enable nls)
-}
-
-src_compile() {
- emake || die "emake failed."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog NEWS README TODO
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
-}
diff --git a/x11-misc/parcellite/parcellite-1.0.1.ebuild b/x11-misc/parcellite/parcellite-1.0.2_rc5-r1.ebuild
index 75eb8ab5b06a..6387ca4b5c8d 100644
--- a/x11-misc/parcellite/parcellite-1.0.1.ebuild
+++ b/x11-misc/parcellite/parcellite-1.0.2_rc5-r1.ebuild
@@ -1,40 +1,44 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-1.0.1.ebuild,v 1.3 2012/07/31 22:41:49 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-1.0.2_rc5-r1.ebuild,v 1.1 2012/09/28 15:50:45 jer Exp $
-EAPI=2
-inherit fdo-mime flag-o-matic autotools
+EAPI=4
+inherit autotools eutils fdo-mime
+
+MY_P=${PN}-${PV/_}
DESCRIPTION="A lightweight GTK+ based clipboard manager."
HOMEPAGE="http://parcellite.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls"
-RDEPEND=">=x11-libs/gtk+-2.10:2
- >=dev-libs/glib-2.14:2"
+PL_LINGUAS="ca cs da de es fr hu it ja nb pl pl_PL pt_BR ro ru sv tr zh_CN"
+for lingua in ${PL_LINGUAS}; do
+ IUSE+=" linguas_${lingua}"
+done
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.10:2"
DEPEND="${RDEPEND}
virtual/pkgconfig
- nls? ( sys-devel/gettext
- dev-util/intltool )"
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
+
+S=${WORKDIR}/${MY_P}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-glib-2.31.patch
eautoreconf
}
src_configure() {
- append-libs -lX11
- econf \
- --disable-dependency-tracking \
- $(use_enable nls)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README TODO
+ econf $(use_enable nls)
}
pkg_postinst() {