summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/test-unit/ChangeLog7
-rw-r--r--dev-ruby/test-unit/test-unit-2.5.3.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 358bfc97484a..696cd44ceaa2 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.65 2012/10/28 17:34:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.66 2012/12/05 09:15:58 graaff Exp $
+
+*test-unit-2.5.3 (05 Dec 2012)
+
+ 05 Dec 2012; Hans de Graaff <graaff@gentoo.org> +test-unit-2.5.3.ebuild:
+ Version bump.
28 Oct 2012; Raúl Porcel <armin76@gentoo.org> test-unit-1.2.3.ebuild,
test-unit-2.1.2-r1.ebuild, test-unit-2.4.8.ebuild, test-unit-2.5.1-r1.ebuild,
diff --git a/dev-ruby/test-unit/test-unit-2.5.3.ebuild b/dev-ruby/test-unit/test-unit-2.5.3.ebuild
new file mode 100644
index 000000000000..c0ba980d12f7
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-2.5.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.5.3.ebuild,v 1.1 2012/12/05 09:15:58 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
+
+inherit ruby-fakegem
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+# redcloth is also needed to build documentation, but not available for
+# jruby. Since we build documentation with the main ruby implementation
+# only we skip the dependency for jruby in this roundabout way, assuming
+# that jruby won't be the main ruby.
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "doc? ( dev-ruby/redcloth )"
+
+DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
+HOMEPAGE="http://test-unit.rubyforge.org/"
+
+LICENSE="Ruby"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ yard doc --title ${PN} || die
+ fi
+}
+
+each_ruby_test() {
+ # the rake audit using dev-ruby/zentest currently fails, and we
+ # just need to call the testsuite directly.
+ # rake audit || die "rake audit failed"
+ local rubyflags
+
+ [[ ${RUBY} == */jruby ]] && rubyflags="-X+O"
+
+ ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbin "${FILESDIR}"/testrb testrb-2
+}