summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-calculators/qalculate-currency/ChangeLog8
-rw-r--r--sci-calculators/qalculate-currency/qalculate-currency-0.9.4-r2.ebuild25
2 files changed, 14 insertions, 19 deletions
diff --git a/sci-calculators/qalculate-currency/ChangeLog b/sci-calculators/qalculate-currency/ChangeLog
index f79bcbe9a2a3..c16ddfa5c1f2 100644
--- a/sci-calculators/qalculate-currency/ChangeLog
+++ b/sci-calculators/qalculate-currency/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-calculators/qalculate-currency
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/qalculate-currency/ChangeLog,v 1.15 2011/03/02 13:30:09 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/qalculate-currency/ChangeLog,v 1.16 2012/04/26 15:59:35 jlec Exp $
+
+ 26 Apr 2012; Justin Lecher <jlec@gentoo.org>
+ qalculate-currency-0.9.4-r2.ebuild:
+ Move to EAPI=4
02 Mar 2011; Justin Lecher <jlec@gentoo.org>
qalculate-currency-0.9.4-r2.ebuild:
diff --git a/sci-calculators/qalculate-currency/qalculate-currency-0.9.4-r2.ebuild b/sci-calculators/qalculate-currency/qalculate-currency-0.9.4-r2.ebuild
index dec512b54919..1d1e15442848 100644
--- a/sci-calculators/qalculate-currency/qalculate-currency-0.9.4-r2.ebuild
+++ b/sci-calculators/qalculate-currency/qalculate-currency-0.9.4-r2.ebuild
@@ -1,41 +1,32 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/qalculate-currency/qalculate-currency-0.9.4-r2.ebuild,v 1.4 2011/03/02 13:30:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/qalculate-currency/qalculate-currency-0.9.4-r2.ebuild,v 1.5 2012/04/26 15:59:35 jlec Exp $
-EAPI="1"
+EAPI=4
inherit autotools
DESCRIPTION="A GTK+ currency converter"
-LICENSE="GPL-2"
HOMEPAGE="http://qalculate.sourceforge.net/"
SRC_URI="mirror://sourceforge/qalculate/${P}.tar.gz"
SLOT="0"
+LICENSE="GPL-2"
IUSE="nls"
KEYWORDS="~amd64 x86"
RDEPEND="
- >=sci-libs/libqalculate-0.9.6-r1
+ sci-libs/libqalculate
x11-libs/gtk+:2
nls? ( sys-devel/gettext )"
-
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-cln-config.patch
eautoconf
}
-src_compile() {
- econf --disable-clntest || die "Configuration failed."
- emake || die "Compilation failed."
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "Installation failed."
- dodoc AUTHORS ChangeLog README || die "Failed to install documentation."
+src_configure() {
+ econf --disable-clntest
}