summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/mono/ChangeLog7
-rw-r--r--dev-lang/mono/files/mono-2.2-freebsd-elf_common.patch20
-rw-r--r--dev-lang/mono/mono-2.2-r4.ebuild12
3 files changed, 30 insertions, 9 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 6a8f3ccbb0fd..4941a175e834 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.156 2009/03/27 15:50:10 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.157 2009/03/28 00:53:50 loki_val Exp $
+
+ 28 Mar 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/mono-2.2-freebsd-elf_common.patch, mono-2.2-r4.ebuild:
+ Fix bug 258722, mono fails to build on solaris. Fix bug 262429, dodoc not
+ finding target files.
27 Mar 2009; Brent Baude <ranger@gentoo.org> mono-2.0.1-r1.ebuild:
Marking mono-2.0.1-r1 ppc stable for bug 234305
diff --git a/dev-lang/mono/files/mono-2.2-freebsd-elf_common.patch b/dev-lang/mono/files/mono-2.2-freebsd-elf_common.patch
new file mode 100644
index 000000000000..3dc66cc4b9aa
--- /dev/null
+++ b/dev-lang/mono/files/mono-2.2-freebsd-elf_common.patch
@@ -0,0 +1,20 @@
+--- mono/utils/freebsd-elf_common.h.orig 2009-02-12 10:56:14.604852206 +0100
++++ mono/utils/freebsd-elf_common.h 2009-02-12 10:56:52.034748775 +0100
+@@ -42,10 +42,14 @@
+ * not include the padding.
+ */
+
++/*
++ * Patched acording to: http://lists.ximian.com/pipermail/mono-patches/2009-January/138782.html
++ */
++
+ typedef struct {
+- u_int32_t n_namesz; /* Length of name. */
+- u_int32_t n_descsz; /* Length of descriptor. */
+- u_int32_t n_type; /* Type of this note. */
++ uint32_t n_namesz; /* Length of name. */
++ uint32_t n_descsz; /* Length of descriptor. */
++ uint32_t n_type; /* Type of this note. */
+ } Elf_Note;
+
+ /* Indexes into the e_ident array. Keep synced with
diff --git a/dev-lang/mono/mono-2.2-r4.ebuild b/dev-lang/mono/mono-2.2-r4.ebuild
index d26bd89278bd..414f613b325f 100644
--- a/dev-lang/mono/mono-2.2-r4.ebuild
+++ b/dev-lang/mono/mono-2.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.2-r4.ebuild,v 1.1 2009/03/22 21:35:13 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.2-r4.ebuild,v 1.2 2009/03/28 00:53:50 loki_val Exp $
EAPI=2
@@ -40,6 +40,7 @@ PATCHES=(
"${FILESDIR}/mono-2.2-uselibdir.patch"
"${FILESDIR}/mono-2.2-r121596-work-around-runtime-crash.patch"
"${FILESDIR}/mono-2.2-r123987-bless-crash.patch"
+ "${FILESDIR}/mono-2.2-freebsd-elf_common.patch"
)
pkg_setup() {
@@ -73,7 +74,8 @@ src_configure() {
--with-libgdiplus=$(use minimal && printf "no" || printf "installed" ) \
$(use_with xen xen_opt) \
--without-ikvm-native \
- --with-jit
+ --with-jit \
+ --disable-dtrace
}
@@ -95,12 +97,6 @@ src_install() {
sed -i -e "s:mono/2.0/mod.exe:mono/1.0/mod.exe:" \
"${D}"/usr/bin/mod || die "Failed to fix mod."
- docinto docs
- dodoc docs/*
-
- docinto libgc
- dodoc libgc/ChangeLog
-
find "${D}"/usr/ -name '*nunit-docs*' -exec rm -rf '{}' '+' || die "Removing nunit .docs failed"
#Standardize install paths for eselect-nunit