summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/notecase/ChangeLog7
-rw-r--r--app-text/notecase/notecase-1.7.9.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/app-text/notecase/ChangeLog b/app-text/notecase/ChangeLog
index 52c35f7fbd00..2a30d5b73880 100644
--- a/app-text/notecase/ChangeLog
+++ b/app-text/notecase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/notecase
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/ChangeLog,v 1.11 2008/01/20 11:50:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/ChangeLog,v 1.12 2008/02/05 21:32:51 armin76 Exp $
+
+*notecase-1.7.9 (05 Feb 2008)
+
+ 05 Feb 2008; Raúl Porcel <armin76@gentoo.org> +notecase-1.7.9.ebuild:
+ Version bump
20 Jan 2008; Raúl Porcel <armin76@gentoo.org> notecase-1.7.6.ebuild:
Fix sed, bug #206755
diff --git a/app-text/notecase/notecase-1.7.9.ebuild b/app-text/notecase/notecase-1.7.9.ebuild
new file mode 100644
index 000000000000..f70633fa05ec
--- /dev/null
+++ b/app-text/notecase/notecase-1.7.9.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/notecase-1.7.9.ebuild,v 1.1 2008/02/05 21:32:51 armin76 Exp $
+
+inherit eutils fdo-mime
+
+DESCRIPTION="Hierarchical note manager written using GTK+ and C++"
+HOMEPAGE="http://notecase.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}_src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome nls"
+
+RDEPEND=">=x11-libs/gtk+-2.6"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# test doesn't work
+RESTRICT="test"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect CFLAGS and don't use --as-needed by default
+ epatch "${FILESDIR}/notecase-1.7.2-CFLAGS.patch"
+
+ if ! use gnome; then
+ # Comment variable in the Makefile if we don't have gnome
+ sed -i -e 's/HAVE_GNOME_VFS=1/#HAVE_GNOME_VFS=1/g' \
+ -e 's/AUTODETECT_GNOME_VFS=1/#AUTODETECT_GNOME_VFS=1/g' \
+ Makefile || die "gnome sed failed"
+ fi
+
+ ! use nls && {
+ sed -i -e 's/notecase$(EXE) poinstall/notecase$(EXE)/g' \
+ Makefile || die "nls sed failed"
+ }
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc readme.txt
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}