summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/sphinx/ChangeLog9
-rw-r--r--dev-python/sphinx/sphinx-0.3.ebuild41
-rw-r--r--dev-python/sphinx/sphinx-0.4.2.ebuild50
-rw-r--r--dev-python/sphinx/sphinx-0.6.1.ebuild (renamed from dev-python/sphinx/sphinx-0.5.1.ebuild)16
4 files changed, 16 insertions, 100 deletions
diff --git a/dev-python/sphinx/ChangeLog b/dev-python/sphinx/ChangeLog
index 8ea77bda3ac8..c8161a160db1 100644
--- a/dev-python/sphinx/ChangeLog
+++ b/dev-python/sphinx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/sphinx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.11 2009/03/27 09:57:42 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.12 2009/04/07 08:07:15 bicatali Exp $
+
+*sphinx-0.6.1 (07 Apr 2009)
+
+ 07 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org> -sphinx-0.3.ebuild,
+ -sphinx-0.4.2.ebuild, -sphinx-0.5.1.ebuild, +sphinx-0.6.1.ebuild:
+ Version bump, dropped some keywords waiting for jinja2 keywording (bug
+ #263948)
*sphinx-0.5.2 (27 Mar 2009)
diff --git a/dev-python/sphinx/sphinx-0.3.ebuild b/dev-python/sphinx/sphinx-0.3.ebuild
deleted file mode 100644
index 2aacb18063ec..000000000000
--- a/dev-python/sphinx/sphinx-0.3.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.3.ebuild,v 1.6 2008/08/01 17:07:28 dev-zero Exp $
-
-inherit distutils
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A tool that makes it easy to create intelligent and beautiful documentation for Python projects."
-HOMEPAGE="http://sphinx.pocoo.org/"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc"
-
-DEPEND=">=dev-python/pygments-0.8
- >=dev-python/jinja-1.1
- >=dev-python/docutils-0.4
- dev-python/setuptools"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- DOCS="CHANGES"
- distutils_src_compile
-
- if use doc ; then
- cd doc
- PYTHONPATH="../" emake SPHINXBUILD="${python} ../sphinx-build.py" html || die "making docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
- if use doc ; then
- dohtml -A txt -r doc/_build/html/*
- fi
-}
diff --git a/dev-python/sphinx/sphinx-0.4.2.ebuild b/dev-python/sphinx/sphinx-0.4.2.ebuild
deleted file mode 100644
index 9839fe11c621..000000000000
--- a/dev-python/sphinx/sphinx-0.4.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.4.2.ebuild,v 1.4 2008/10/07 00:01:05 ranger Exp $
-
-inherit distutils
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A tool that makes it easy to create intelligent and beautiful documentation for Python projects."
-HOMEPAGE="http://sphinx.pocoo.org/"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/pygments-0.8
- >=dev-python/jinja-1.1
- >=dev-python/docutils-0.4
- dev-python/setuptools"
-
-DEPEND="${RDEPEND}
- test? ( dev-python/nose )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- DOCS="CHANGES"
- distutils_src_compile
-
- if use doc ; then
- cd doc
- PYTHONPATH="../" emake SPHINXBUILD="${python} ../sphinx-build.py" html || die "making docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
- if use doc ; then
- dohtml -A txt -r doc/_build/html/*
- fi
-}
-
-src_test() {
- #Tests fail without this directory, fixed in next release
- #http://bugs.python.org/issue3484
- mkdir tests/root/_build
- PYTHONPATH=. "${python}" tests/run.py || die "Tests failed"
-}
diff --git a/dev-python/sphinx/sphinx-0.5.1.ebuild b/dev-python/sphinx/sphinx-0.6.1.ebuild
index c822dd8a543c..14a6d0a367e9 100644
--- a/dev-python/sphinx/sphinx-0.5.1.ebuild
+++ b/dev-python/sphinx/sphinx-0.6.1.ebuild
@@ -1,30 +1,28 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.5.1.ebuild,v 1.2 2009/03/27 09:57:42 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.1.ebuild,v 1.1 2009/04/07 08:07:15 bicatali Exp $
inherit distutils
MY_PN="Sphinx"
MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A tool that makes it easy to create intelligent and beautiful documentation for Python projects."
+DESCRIPTION="Tool to create documentation for Python projects"
HOMEPAGE="http://sphinx.pocoo.org/"
SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~ia64 ~x86"
IUSE="doc test"
RDEPEND=">=dev-python/pygments-0.8
- >=dev-python/jinja-1.1
+ >=dev-python/jinja2-2.1
>=dev-python/docutils-0.4"
DEPEND="${RDEPEND}
dev-python/setuptools
test? ( dev-python/nose )"
-# tests buggy - bug #262608
-RESTRICT=test
S="${WORKDIR}/${MY_P}"
src_compile() {
@@ -33,14 +31,16 @@ src_compile() {
if use doc ; then
cd doc
- PYTHONPATH="../" emake SPHINXBUILD="${python} ../sphinx-build.py" html || die "making docs failed"
+ PYTHONPATH="../" emake \
+ SPHINXBUILD="${python} ../sphinx-build.py" \
+ html || die "making docs failed"
fi
}
src_install() {
distutils_src_install
if use doc ; then
- dohtml -A txt -r doc/_build/html/*
+ dohtml -A txt -r doc/_build/html/* || die
fi
}