summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/crossover-office-pro-bin/ChangeLog10
-rw-r--r--app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.0.0.ebuild49
2 files changed, 57 insertions, 2 deletions
diff --git a/app-emulation/crossover-office-pro-bin/ChangeLog b/app-emulation/crossover-office-pro-bin/ChangeLog
index d5de2d08e699..b55c9ac6a000 100644
--- a/app-emulation/crossover-office-pro-bin/ChangeLog
+++ b/app-emulation/crossover-office-pro-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/crossover-office-pro-bin
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/ChangeLog,v 1.15 2009/08/23 10:53:04 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/ChangeLog,v 1.16 2010/04/20 07:51:42 vapier Exp $
+
+*crossover-office-pro-bin-9.0.0 (20 Apr 2010)
+
+ 20 Apr 2010; Mike Frysinger <vapier@gentoo.org>
+ +crossover-office-pro-bin-9.0.0.ebuild:
+ Version bump #311943 by Pacho Ramos.
*crossover-office-pro-bin-8.0.0 (23 Aug 2009)
*crossover-office-pro-bin-7.1.0 (23 Aug 2009)
diff --git a/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.0.0.ebuild b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.0.0.ebuild
new file mode 100644
index 000000000000..c707c243fcbf
--- /dev/null
+++ b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.0.0.ebuild,v 1.1 2010/04/20 07:51:42 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="simplified/streamlined version of wine with commercial support"
+HOMEPAGE="http://www.codeweavers.com/products/cxoffice/"
+SRC_URI="install-crossover-pro-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="nas"
+RESTRICT="fetch strip"
+
+RDEPEND="sys-libs/glibc
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ dev-util/desktop-file-utils
+ nas? ( media-libs/nas )
+ amd64? ( app-emulation/emul-linux-x86-xlibs )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ dodir /opt/cxoffice
+ cp -r * "${D}"/opt/cxoffice || die "cp failed"
+ rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+ insinto /opt/cxoffice/etc
+ doins share/crossover/data/cxoffice.conf
+}
+
+pkg_postinst() {
+ elog "Run /opt/cxoffice/bin/cxsetup as normal user to create"
+ elog "bottles and install Windows applications."
+}