summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/molmol/ChangeLog7
-rw-r--r--sci-chemistry/molmol/files/cast.patch13
-rw-r--r--sci-chemistry/molmol/molmol-2k_p2-r2.ebuild4
3 files changed, 22 insertions, 2 deletions
diff --git a/sci-chemistry/molmol/ChangeLog b/sci-chemistry/molmol/ChangeLog
index 457597cafeb4..077529eca7a7 100644
--- a/sci-chemistry/molmol/ChangeLog
+++ b/sci-chemistry/molmol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/molmol
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/ChangeLog,v 1.19 2010/03/30 19:55:26 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/ChangeLog,v 1.20 2010/04/23 14:19:41 jlec Exp $
+
+ 23 Apr 2010; Justin Lecher <jlec@gentoo.org> molmol-2k_p2-r2.ebuild,
+ +files/cast.patch:
+ fix instance of cast from pointer to integer of different size, stolen
+ from fink
*molmol-2k_p2-r2 (30 Mar 2010)
diff --git a/sci-chemistry/molmol/files/cast.patch b/sci-chemistry/molmol/files/cast.patch
new file mode 100644
index 000000000000..643b92d2a4cf
--- /dev/null
+++ b/sci-chemistry/molmol/files/cast.patch
@@ -0,0 +1,13 @@
+diff --git a/src/data/DataDist.c b/src/data/DataDist.c
+index 7f7121f..d303e9e 100644
+--- a/src/data/DataDist.c
++++ b/src/data/DataDist.c
+@@ -89,7 +89,7 @@ hashInter(void *p, unsigned size)
+ {
+ TabEntryInter *entryP = p;
+
+- return ((unsigned) entryP->atom1P + (unsigned) entryP->atom2P) % size;
++ return ((unsigned)(uintptr_t) entryP->atom1P + (unsigned)(uintptr_t) entryP->atom2P) % size;
+ }
+
+ static int
diff --git a/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild b/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild
index 5e6d3ba2cae3..3278d5632256 100644
--- a/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild
+++ b/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild,v 1.1 2010/03/30 19:55:26 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild,v 1.2 2010/04/23 14:19:41 jlec Exp $
EAPI="3"
@@ -59,6 +59,8 @@ src_prepare() {
-e "s:^MCFLAGS.*:MCFLAGS = ${CFLAGS}:" \
-e "s:^CC.*:CC = $(tc-getCC):" \
"${S}"/makedef
+
+ epatch "${FILESDIR}"/cast.patch
}
src_compile() {