summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/httpup/ChangeLog8
-rw-r--r--dev-util/httpup/files/httpup-0.3.2-darwin.patch13
-rw-r--r--dev-util/httpup/httpup-0.3.2.ebuild7
3 files changed, 23 insertions, 5 deletions
diff --git a/dev-util/httpup/ChangeLog b/dev-util/httpup/ChangeLog
index af62ad44b9d5..3dd6cc1acf63 100644
--- a/dev-util/httpup/ChangeLog
+++ b/dev-util/httpup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/httpup
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/ChangeLog,v 1.6 2009/08/25 19:54:09 vostorga Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/ChangeLog,v 1.7 2010/02/21 01:29:43 abcd Exp $
+
+ 21 Feb 2010; Jonathan Callen <abcd@gentoo.org> httpup-0.3.2.ebuild,
+ +files/httpup-0.3.2-darwin.patch:
+ Transfer prefix keywords, add patch for Darwin
25 Aug 2009; Víctor Ostorga <vostorga@gentoo.org> httpup-0.3.2.ebuild,
+files/httpup-0.3.2-gcc44.patch:
diff --git a/dev-util/httpup/files/httpup-0.3.2-darwin.patch b/dev-util/httpup/files/httpup-0.3.2-darwin.patch
new file mode 100644
index 000000000000..30a76c5fa8c3
--- /dev/null
+++ b/dev-util/httpup/files/httpup-0.3.2-darwin.patch
@@ -0,0 +1,13 @@
+* Darwin and BSD need libgen.h for basename, on linux this header is
+ also available
+
+--- httpup.cpp
++++ httpup.cpp
+@@ -15,6 +15,7 @@
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <dirent.h>
++#include <libgen.h>
+
+ #include "fileutils.h"
+ #include "httpup.h"
diff --git a/dev-util/httpup/httpup-0.3.2.ebuild b/dev-util/httpup/httpup-0.3.2.ebuild
index 42e2cdb764fc..bf064bcadd9d 100644
--- a/dev-util/httpup/httpup-0.3.2.ebuild
+++ b/dev-util/httpup/httpup-0.3.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/httpup-0.3.2.ebuild,v 1.4 2009/08/25 19:54:09 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/httpup-0.3.2.ebuild,v 1.5 2010/02/21 01:29:43 abcd Exp $
inherit eutils toolchain-funcs
@@ -10,7 +10,7 @@ SRC_URI="http://jw.tks6.net/files/crux/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~ppc"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""
DEPEND="net-misc/curl"
@@ -19,6 +19,7 @@ RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-darwin.patch
sed -i \
-e 's:g++:$(CXX) $(CFLAGS) $(LDFLAGS):' \
Makefile