summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-astronomy/celestia/ChangeLog8
-rw-r--r--sci-astronomy/celestia/celestia-1.6.0.ebuild8
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.0-gcc45.patch51
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.0-parallel_install.patch16
4 files changed, 79 insertions, 4 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 62248df510e2..86b0812114b2 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.62 2010/03/08 18:24:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.63 2010/06/24 17:20:48 xarthisius Exp $
+
+ 24 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org> celestia-1.6.0.ebuild,
+ +files/celestia-1.6.0-gcc45.patch,
+ +files/celestia-1.6.0-parallel_install.patch:
+ Fix parallel install, fix build with GCC-4.5 wrt bug 317507. Thanks to
+ Philipp <sefi@s-e-f-i.de> for reporting and patch.
08 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> celestia-1.6.0.ebuild,
+files/celestia-1.6.0-libpng14.patch:
diff --git a/sci-astronomy/celestia/celestia-1.6.0.ebuild b/sci-astronomy/celestia/celestia-1.6.0.ebuild
index 6d328679280e..0e659ac101d7 100644
--- a/sci-astronomy/celestia/celestia-1.6.0.ebuild
+++ b/sci-astronomy/celestia/celestia-1.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.0.ebuild,v 1.11 2010/03/08 18:24:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.0.ebuild,v 1.12 2010/06/24 17:20:48 xarthisius Exp $
EAPI=2
inherit eutils flag-o-matic gnome2 autotools
@@ -58,8 +58,10 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.5.1-gcc44.patch
# needed for proper detection of kde-3.5 in the presence
# of kde4
- epatch "${FILESDIR}"/${P}-kde-3.5.patch
- epatch "${FILESDIR}"/${P}-libpng14.patch
+ epatch "${FILESDIR}"/${P}-kde-3.5.patch \
+ "${FILESDIR}"/${P}-libpng14.patch \
+ "${FILESDIR}"/${P}-gcc45.patch \
+ "${FILESDIR}"/${P}-parallel_install.patch
# remove flags to let the user decide
for cf in -O2 -ffast-math \
-fexpensive-optimizations \
diff --git a/sci-astronomy/celestia/files/celestia-1.6.0-gcc45.patch b/sci-astronomy/celestia/files/celestia-1.6.0-gcc45.patch
new file mode 100644
index 000000000000..8ee9adb2aa8a
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.6.0-gcc45.patch
@@ -0,0 +1,51 @@
+Fixing build with GCC-4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=317507
+
+Patch written by Philipp <sefi@s-e-f-i.de>
+--- src/celengine/overlay.h
++++ src/celengine/overlay.h
+@@ -12,6 +12,7 @@
+
+ #include <string>
+ #include <iostream>
++#include <cstdio>
+ #include <celtxf/texturefont.h>
+
+
+--- src/celmath/mathlib.h
++++ src/celmath/mathlib.h
+@@ -44,11 +44,6 @@
+ template<class T> T radToDeg(T r)
+ return r * 180 / static_cast<T>(PI);
+ }
+
+-template<class T> T abs(T x)
+-{
+- return (x < 0) ? -x : x;
+-}
+-
+ template<class T> T square(T x)
+ {
+ return x * x;
+--- src/celengine/star.cpp
++++ src/celengine/star.cpp
+@@ -10,6 +10,7 @@
+ #include <celmath/mathlib.h>
+ #include <cstring>
+ #include <cassert>
++#include <cstdio>
+ #include "celestia.h"
+ #include "astro.h"
+ #include "orbit.h"
+--- src/celestia/celx_object.cpp
++++ src/celestia/celx_object.cpp
+@@ -773,7 +773,7 @@ static int object_mark(lua_State* l)
+ markAlpha = 1.0f;
+
+ Color markColorAlpha(0.0f, 1.0f, 0.0f, 0.9f);
+- markColorAlpha = Color::Color(markColor, markAlpha);
++ markColorAlpha = Color(markColor, markAlpha);
+
+ const char* markLabel = celx.safeGetString(6, WrongType, "Fifth argument to object:mark must be a string");
+ if (markLabel == NULL)
diff --git a/sci-astronomy/celestia/files/celestia-1.6.0-parallel_install.patch b/sci-astronomy/celestia/files/celestia-1.6.0-parallel_install.patch
new file mode 100644
index 000000000000..e40ca40fd6cd
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.6.0-parallel_install.patch
@@ -0,0 +1,16 @@
+--- data/Makefile.am
++++ data/Makefile.am
+@@ -11,12 +11,11 @@
+
+ pkgdata_DATA = \
+ $(wildcard *.ssc) \
+- $(wildcard *.dat) \
+ $(wildcard *.xyz) \
+ $(wildcard *.xyzv) \
+ $(wildcard *.dsc) \
+ $(wildcard *.stc) \
+- stars.dat
++ asterisms.dat boundaries.dat hdxindex.dat saoxindex.dat starnames.dat stars.dat
+
+ EXTRA_DIST = \
+ $(pkgdata_DATA) \