summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/mercury/ChangeLog9
-rw-r--r--dev-lang/mercury/files/mercury-0.12.2-bootstrap.patch27
-rw-r--r--dev-lang/mercury/files/mercury-0.13.1-bootstrap.patch70
-rw-r--r--dev-lang/mercury/mercury-0.12.2-r4.ebuild3
-rw-r--r--dev-lang/mercury/mercury-0.13.1-r1.ebuild3
5 files changed, 107 insertions, 5 deletions
diff --git a/dev-lang/mercury/ChangeLog b/dev-lang/mercury/ChangeLog
index 1bf807db5db9..263fd5fca4e3 100644
--- a/dev-lang/mercury/ChangeLog
+++ b/dev-lang/mercury/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/mercury
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/ChangeLog,v 1.70 2007/01/07 03:34:51 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/ChangeLog,v 1.71 2007/01/08 06:27:34 keri Exp $
+
+ 08 Jan 2007; keri <keri@gentoo.org> files/mercury-0.12.2-bootstrap.patch,
+ -files/mercury-0.12.2-unboxed_floats.patch,
+ files/mercury-0.13.1-bootstrap.patch,
+ -files/mercury-0.13.1-unboxed_floats.patch, mercury-0.12.2-r4.ebuild,
+ mercury-0.13.1-r1.ebuild:
+ Do not rebuild C files in a stage1 bootstrap without a Mercury compiler handy.
07 Jan 2007; keri <keri@gentoo.org>
+files/mercury-0.12.2-unboxed_floats.patch,
diff --git a/dev-lang/mercury/files/mercury-0.12.2-bootstrap.patch b/dev-lang/mercury/files/mercury-0.12.2-bootstrap.patch
index f8922bb2e0a9..68e6dbc0ac94 100644
--- a/dev-lang/mercury/files/mercury-0.12.2-bootstrap.patch
+++ b/dev-lang/mercury/files/mercury-0.12.2-bootstrap.patch
@@ -58,3 +58,30 @@
#-----------------------------------------------------------------------------#
+@@ -9980,10 +9980,10 @@
+
+ fi
+ #-----------------------------------------------------------------------------#
+-if test "$BOOTSTRAP_MC" = ""; then
+- BOOTSTRAP_MC=mmc
+-fi
+-BOOTSTRAP_MC="$BOOTSTRAP_MC $HAVE_BOXED_FLOATS --conf-low-tag-bits $LOW_TAG_BITS --bits-per-word $BITS_PER_WORD --bytes-per-word $BYTES_PER_WORD"
++#if test "$BOOTSTRAP_MC" = ""; then
++# BOOTSTRAP_MC=mmc
++#fi
++#BOOTSTRAP_MC="$BOOTSTRAP_MC $HAVE_BOXED_FLOATS --conf-low-tag-bits $LOW_TAG_BITS --bits-per-word $BITS_PER_WORD --bytes-per-word $BYTES_PER_WORD"
+
+ #-----------------------------------------------------------------------------#
+
+@@ -12010,6 +12010,11 @@
+ rm -f confscratch $to_delete
+ fi
+ #-----------------------------------------------------------------------------#
++if test "$BOOTSTRAP_MC" = ""; then
++ BOOTSTRAP_MC=mmc
++fi
++BOOTSTRAP_MC="$BOOTSTRAP_MC $HAVE_BOXED_FLOATS --conf-low-tag-bits $LOW_TAG_BITS --bits-per-word $BITS_PER_WORD --bytes-per-word $BYTES_PER_WORD"
++#-----------------------------------------------------------------------------#
+
+ echo "$as_me:$LINENO: checking for C shell executable" >&5
+ echo $ECHO_N "checking for C shell executable... $ECHO_C" >&6
diff --git a/dev-lang/mercury/files/mercury-0.13.1-bootstrap.patch b/dev-lang/mercury/files/mercury-0.13.1-bootstrap.patch
index 2245a826f6d7..d6f22e0a2fa9 100644
--- a/dev-lang/mercury/files/mercury-0.13.1-bootstrap.patch
+++ b/dev-lang/mercury/files/mercury-0.13.1-bootstrap.patch
@@ -1,5 +1,42 @@
--- mercury-compiler-0.13.1.orig/configure 2006-12-01 22:37:01.000000000 +1300
+++ mercury-compiler-0.13.1/configure 2006-12-04 20:50:57.000000000 +1300
+@@ -7410,21 +7410,21 @@
+
+ echo "$as_me:$LINENO: result: $mercury_cv_unboxed_floats" >&5
+ echo "${ECHO_T}$mercury_cv_unboxed_floats" >&6
+-if test "$mercury_cv_unboxed_floats" = yes; then
+- if test "$BOOTSTRAP_MC" = ""; then
+- { echo "$as_me:$LINENO: WARNING: Mercury compiler not yet installed -
+-**** cannot use unboxed floats, bootstrapping using boxed floats
+-**** after installation is complete you may want to reinstall
+-**** from scratch so you can use unboxed floats, which are more
+-**** efficient." >&5
+-echo "$as_me: WARNING: Mercury compiler not yet installed -
+-**** cannot use unboxed floats, bootstrapping using boxed floats
+-**** after installation is complete you may want to reinstall
+-**** from scratch so you can use unboxed floats, which are more
+-**** efficient." >&2;}
+- mercury_cv_unboxed_floats=no
+- fi
+-fi
++#if test "$mercury_cv_unboxed_floats" = yes; then
++# if test "$BOOTSTRAP_MC" = ""; then
++# { echo "$as_me:$LINENO: WARNING: Mercury compiler not yet installed -
++#**** cannot use unboxed floats, bootstrapping using boxed floats
++#**** after installation is complete you may want to reinstall
++#**** from scratch so you can use unboxed floats, which are more
++#**** efficient." >&5
++#echo "$as_me: WARNING: Mercury compiler not yet installed -
++#**** cannot use unboxed floats, bootstrapping using boxed floats
++#**** after installation is complete you may want to reinstall
++#**** from scratch so you can use unboxed floats, which are more
++#**** efficient." >&2;}
++# mercury_cv_unboxed_floats=no
++# fi
++#fi
+ if test "$mercury_cv_unboxed_floats" = yes; then
+ HAVE_BOXED_FLOATS="--unboxed-float"
+ else
@@ -8980,34 +8980,34 @@
if test "$BEST_GRADE_FOR_COMPILER" != "$BOOTSTRAP_GRADE"; then
@@ -58,3 +95,36 @@
#-----------------------------------------------------------------------------#
+@@ -10222,12 +10222,12 @@
+
+ fi
+ #-----------------------------------------------------------------------------#
+-if test "$BOOTSTRAP_MC" = ""; then
+- BOOTSTRAP_MC=mmc
+-fi
+-BOOTSTRAP_MC_COMPILER="$BOOTSTRAP_MC"
+-BOOTSTRAP_MC_ARGS="$HAVE_BOXED_FLOATS --conf-low-tag-bits $LOW_TAG_BITS --bits-per-word $BITS_PER_WORD --bytes-per-word $BYTES_PER_WORD"
+-BOOTSTRAP_MC="$BOOTSTRAP_MC_COMPILER $BOOTSTRAP_MC_ARGS"
++#if test "$BOOTSTRAP_MC" = ""; then
++# BOOTSTRAP_MC=mmc
++#fi
++#BOOTSTRAP_MC_COMPILER="$BOOTSTRAP_MC"
++#BOOTSTRAP_MC_ARGS="$HAVE_BOXED_FLOATS --conf-low-tag-bits $LOW_TAG_BITS --bits-per-word $BITS_PER_WORD --bytes-per-word $BYTES_PER_WORD"
++#BOOTSTRAP_MC="$BOOTSTRAP_MC_COMPILER $BOOTSTRAP_MC_ARGS"
+
+
+
+@@ -12260,6 +12260,13 @@
+ rm -f confscratch $to_delete
+ fi
+ #-----------------------------------------------------------------------------#
++if test "$BOOTSTRAP_MC" = ""; then
++ BOOTSTRAP_MC=mmc
++fi
++BOOTSTRAP_MC_COMPILER="$BOOTSTRAP_MC"
++BOOTSTRAP_MC_ARGS="$HAVE_BOXED_FLOATS --conf-low-tag-bits $LOW_TAG_BITS --bits-per-word $BITS_PER_WORD --bytes-per-word $BYTES_PER_WORD"
++BOOTSTRAP_MC="$BOOTSTRAP_MC_COMPILER $BOOTSTRAP_MC_ARGS"
++#-----------------------------------------------------------------------------#
+
+ echo "$as_me:$LINENO: checking for C shell executable" >&5
+ echo $ECHO_N "checking for C shell executable... $ECHO_C" >&6
diff --git a/dev-lang/mercury/mercury-0.12.2-r4.ebuild b/dev-lang/mercury/mercury-0.12.2-r4.ebuild
index 6b9d0f8cfdb7..9d6daee54bee 100644
--- a/dev-lang/mercury/mercury-0.12.2-r4.ebuild
+++ b/dev-lang/mercury/mercury-0.12.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.12.2-r4.ebuild,v 1.3 2007/01/07 03:34:51 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.12.2-r4.ebuild,v 1.4 2007/01/08 06:27:34 keri Exp $
inherit eutils
@@ -29,7 +29,6 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-CFLAGS.patch
epatch "${FILESDIR}"/${P}-MAKEOPTS.patch
epatch "${FILESDIR}"/${P}-bootstrap.patch
- epatch "${FILESDIR}"/${P}-unboxed_floats.patch
epatch "${FILESDIR}"/${P}-LIBDIR.patch
epatch "${FILESDIR}"/${P}-libgrades.patch
epatch "${FILESDIR}"/${P}-parallel-install_grades.patch
diff --git a/dev-lang/mercury/mercury-0.13.1-r1.ebuild b/dev-lang/mercury/mercury-0.13.1-r1.ebuild
index ecd4e4953f5d..1ca36db4f066 100644
--- a/dev-lang/mercury/mercury-0.13.1-r1.ebuild
+++ b/dev-lang/mercury/mercury-0.13.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.13.1-r1.ebuild,v 1.3 2007/01/07 03:34:51 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.13.1-r1.ebuild,v 1.4 2007/01/08 06:27:34 keri Exp $
inherit eutils
@@ -29,7 +29,6 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-CFLAGS.patch
epatch "${FILESDIR}"/${P}-MAKEOPTS.patch
epatch "${FILESDIR}"/${P}-bootstrap.patch
- epatch "${FILESDIR}"/${P}-unboxed_floats.patch
epatch "${FILESDIR}"/${P}-LIBDIR.patch
epatch "${FILESDIR}"/${P}-libgrades.patch
epatch "${FILESDIR}"/${P}-parallel-install_grades.patch