summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-freebsd/freebsd-ubin/ChangeLog6
-rw-r--r--sys-freebsd/freebsd-ubin/files/freebsd-ubin-6.1-gcc41.patch35
-rw-r--r--sys-freebsd/freebsd-ubin/freebsd-ubin-6.1.ebuild5
3 files changed, 43 insertions, 3 deletions
diff --git a/sys-freebsd/freebsd-ubin/ChangeLog b/sys-freebsd/freebsd-ubin/ChangeLog
index 405120b50402..c20d26ed2b68 100644
--- a/sys-freebsd/freebsd-ubin/ChangeLog
+++ b/sys-freebsd/freebsd-ubin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-freebsd/freebsd-ubin
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/ChangeLog,v 1.12 2006/05/09 07:44:23 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/ChangeLog,v 1.13 2006/05/30 01:22:19 flameeyes Exp $
+
+ 30 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/freebsd-ubin-6.1-gcc41.patch, freebsd-ubin-6.1.ebuild:
+ Add patch to build with GCC 4.1.
*freebsd-ubin-6.1 (09 May 2006)
diff --git a/sys-freebsd/freebsd-ubin/files/freebsd-ubin-6.1-gcc41.patch b/sys-freebsd/freebsd-ubin/files/freebsd-ubin-6.1-gcc41.patch
new file mode 100644
index 000000000000..00d7a9e96b22
--- /dev/null
+++ b/sys-freebsd/freebsd-ubin/files/freebsd-ubin-6.1-gcc41.patch
@@ -0,0 +1,35 @@
+Index: fbsd-6.1/usr.bin/window/wwgets.c
+===================================================================
+--- fbsd-6.1.orig/usr.bin/window/wwgets.c
++++ fbsd-6.1/usr.bin/window/wwgets.c
+@@ -43,6 +43,8 @@ static char rcsid[] =
+ #include "ww.h"
+ #include "char.h"
+
++static void rub();
++
+ wwgets(buf, n, w)
+ char *buf;
+ int n;
+@@ -51,7 +53,6 @@ register struct ww *w;
+ register char *p = buf;
+ register int c;
+ char uc = w->ww_unctrl;
+- static void rub();
+
+ w->ww_unctrl = 0;
+ for (;;) {
+Index: fbsd-6.1/usr.bin/xlint/xlint/xlint.c
+===================================================================
+--- fbsd-6.1.orig/usr.bin/xlint/xlint/xlint.c
++++ fbsd-6.1/usr.bin/xlint/xlint/xlint.c
+@@ -402,7 +402,8 @@ main(int argc, char *argv[])
+ break;
+
+ case 'p':
+- appcstrg(&lcflags, "-Wtraditional -Wno-system-headers");
++ appcstrg(&lcflags, "-Wtraditional");
++ appcstrg(&lcflags, "-Wno-system-headers");
+ appcstrg(&l1flags, "-p");
+ appcstrg(&l2flags, "-p");
+ if (*deflibs != NULL) {
diff --git a/sys-freebsd/freebsd-ubin/freebsd-ubin-6.1.ebuild b/sys-freebsd/freebsd-ubin/freebsd-ubin-6.1.ebuild
index 7e5ac00fcf9f..cb4d823b8c13 100644
--- a/sys-freebsd/freebsd-ubin/freebsd-ubin-6.1.ebuild
+++ b/sys-freebsd/freebsd-ubin/freebsd-ubin-6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/freebsd-ubin-6.1.ebuild,v 1.1 2006/05/09 07:44:23 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/freebsd-ubin-6.1.ebuild,v 1.2 2006/05/30 01:22:19 flameeyes Exp $
inherit bsdmk freebsd flag-o-matic pam
@@ -51,7 +51,8 @@ PATCHES="${FILESDIR}/${PN}-6.0-bsdcmp.patch
${FILESDIR}/${PN}-6.0-fixmakefiles.patch
${FILESDIR}/${PN}-setXid.patch
${FILESDIR}/${PN}-lint-stdarg.patch
- ${FILESDIR}/${PN}-6.0-kdump-ioctl.patch"
+ ${FILESDIR}/${PN}-6.0-kdump-ioctl.patch
+ ${FILESDIR}/${P}-gcc41.patch"
# Here we remove some sources we don't need because they are already
# provided by portage's packages or similar. In order: