summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-scheme/hop/ChangeLog7
-rw-r--r--dev-scheme/hop/hop-1.11.0.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-scheme/hop/ChangeLog b/dev-scheme/hop/ChangeLog
index f5b0c84ee077..79ef6ff8f3bb 100644
--- a/dev-scheme/hop/ChangeLog
+++ b/dev-scheme/hop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/hop
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/ChangeLog,v 1.7 2009/02/14 16:17:08 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/ChangeLog,v 1.8 2009/06/24 15:23:28 hkbst Exp $
+
+*hop-1.11.0 (24 Jun 2009)
+
+ 24 Jun 2009; Marijn Schouten <hkBst@gentoo.org> +hop-1.11.0.ebuild:
+ bump
14 Feb 2009; Marijn Schouten <hkBst@gentoo.org> -hop-1.7.0.ebuild,
-hop-1.8.1.ebuild, -hop-1.8.5.ebuild:
diff --git a/dev-scheme/hop/hop-1.11.0.ebuild b/dev-scheme/hop/hop-1.11.0.ebuild
new file mode 100644
index 000000000000..1ebfdd226039
--- /dev/null
+++ b/dev-scheme/hop/hop-1.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/hop-1.11.0.ebuild,v 1.1 2009/06/24 15:23:28 hkbst Exp $
+
+inherit multilib eutils
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Hop is a higher-order language for programming interactive web applications such as web agendas, web galleries, music players, etc. that is implemented as a Web broker"
+HOMEPAGE="http://hop.inria.fr/"
+SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Hop/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-scheme/bigloo-3.2b"
+RDEPEND=""
+
+IUSE="ssl threads"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ enewgroup hop
+ enewuser hop -1 -1 /var/www hop
+}
+
+src_compile() {
+ # Hop doesn't use autoconf and consequently a lot of options used by econf give errors
+ # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
+ ./configure --prefix=/usr --libdir=/usr/$(get_libdir) --etcdir=/etc/hop $(use_enable ssl) $(use_enable threads) || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+}