summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/pwlib/files/digest-pwlib-1.4.71
-rw-r--r--dev-libs/pwlib/pwlib-1.3.11-r1.ebuild23
-rw-r--r--dev-libs/pwlib/pwlib-1.4.11.ebuild42
-rw-r--r--dev-libs/pwlib/pwlib-1.4.7.ebuild101
-rw-r--r--dev-libs/pwlib/pwlib-1.5.0.ebuild32
5 files changed, 39 insertions, 160 deletions
diff --git a/dev-libs/pwlib/files/digest-pwlib-1.4.7 b/dev-libs/pwlib/files/digest-pwlib-1.4.7
deleted file mode 100644
index c3c75121dcba..000000000000
--- a/dev-libs/pwlib/files/digest-pwlib-1.4.7
+++ /dev/null
@@ -1 +0,0 @@
-MD5 24f2b7f2e983f48141d9657931f16fc4 pwlib_1.4.7.tar.gz 920485
diff --git a/dev-libs/pwlib/pwlib-1.3.11-r1.ebuild b/dev-libs/pwlib/pwlib-1.3.11-r1.ebuild
index 25f49dc2c8b4..ff1e077b3cb8 100644
--- a/dev-libs/pwlib/pwlib-1.3.11-r1.ebuild
+++ b/dev-libs/pwlib/pwlib-1.3.11-r1.ebuild
@@ -1,34 +1,30 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/pwlib-1.3.11-r1.ebuild,v 1.6 2003/02/13 10:50:45 vapier Exp $
-
-S=${WORKDIR}/${PN}
-
-IUSE="ssl"
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/pwlib-1.3.11-r1.ebuild,v 1.7 2003/08/03 02:25:45 vapier Exp $
DESCRIPTION="Libs needed for GnomeMeeting"
-HOMEPAGE="http://www.openh323.org"
+HOMEPAGE="http://www.openh323.org/"
SRC_URI="http://www.openh323.org/bin/${PN}_${PV}.tar.gz"
-SLOT="0"
LICENSE="MPL-1.1"
-KEYWORDS="x86 ppc -sparc "
+SLOT="0"
+KEYWORDS="x86 ppc -sparc"
+IUSE="ssl"
DEPEND=">=sys-devel/bison-1.28
>=sys-devel/flex-2.5.4a
dev-libs/expat
ssl? ( dev-libs/openssl )"
-src_unpack() {
+S=${WORKDIR}/${PN}
+src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${PF}.diff || die
-
+ epatch ${FILESDIR}/${PF}.diff
}
src_compile() {
-
export PWLIBDIR=${S}
export PWLIB_BUILD="yes"
@@ -42,11 +38,9 @@ src_compile() {
cd tools/asnparser
make optshared || die
-
}
src_install() {
-
dodir /usr/lib /usr/include/ptlib/unix/ptlib \
/usr/share/pwlib /usr/include/ptclib
@@ -74,5 +68,4 @@ src_install() {
else
ln -sf libpt_linux_x86_r.so.${PV} libpt.so
fi
-
}
diff --git a/dev-libs/pwlib/pwlib-1.4.11.ebuild b/dev-libs/pwlib/pwlib-1.4.11.ebuild
index 82c19af149c4..4437d222f0a9 100644
--- a/dev-libs/pwlib/pwlib-1.4.11.ebuild
+++ b/dev-libs/pwlib/pwlib-1.4.11.ebuild
@@ -1,48 +1,41 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/pwlib-1.4.11.ebuild,v 1.3 2003/05/16 23:30:11 liquidx Exp $
-
-S=${WORKDIR}/${PN}
-
-IUSE="ssl"
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/pwlib-1.4.11.ebuild,v 1.4 2003/08/03 02:25:45 vapier Exp $
DESCRIPTION="Libs needed for GnomeMeeting"
-HOMEPAGE="http://www.openh323.org"
+HOMEPAGE="http://www.openh323.org/"
SRC_URI="http://www.openh323.org/bin/${PN}_${PV}.tar.gz"
-SLOT="0"
LICENSE="MPL-1.1"
+SLOT="0"
KEYWORDS="x86 ~ppc -sparc"
+IUSE="ssl"
DEPEND=">=sys-devel/bison-1.28
>=sys-devel/flex-2.5.4a
dev-libs/expat
ssl? ( dev-libs/openssl )"
+S=${WORKDIR}/${PN}
+
src_unpack() {
unpack ${A}
cd ${S}/make
-
- # filter out -O3 and -mcpu embedded compiler flags
- cp unix.mak unix.mak.orig
- sed \
+
+ # filter out -O3 and -mcpu embedded compiler flags
+ sed -i \
-e "s:-mcpu=\$(CPUTYPE)::" \
-e "s:-O3 -DNDEBUG:-DNDEBUG:" \
- < unix.mak.orig > unix.mak
-
- # patch unix.mak so it doesn't require annoying upgrades
- cp unix.mak unix.mak.orig2
- sed \
- -e "s:-DP_SSL -I\$(OPENSSLDIR)/include -I\$(OPENSSLDIR)/crypto:-DP_SSL:" \
- -e "s:^LDFLAGS.*\+= -L\$(OPENSSLDIR)/lib -L\$(OPENSSLDIR):LDFLAGS +=:" \
- < unix.mak.orig2 > unix.mak
-
- rm unix.mak.orig unix.mak.orig2
-
+ unix.mak
+
+ # patch unix.mak so it doesn't require annoying upgrades
+ sed -i \
+ -e "s:-DP_SSL -I\$(OPENSSLDIR)/include -I\$(OPENSSLDIR)/crypto:-DP_SSL:" \
+ -e "s:^LDFLAGS.*\+= -L\$(OPENSSLDIR)/lib -L\$(OPENSSLDIR):LDFLAGS +=:" \
+ unix.mak
}
src_compile() {
-
export PWLIBDIR=${S}
export PWLIB_BUILD="yes"
@@ -56,11 +49,9 @@ src_compile() {
cd tools/asnparser
make optshared || die
-
}
src_install() {
-
dodir /usr/lib /usr/include/ptlib/unix/ptlib \
/usr/share/pwlib /usr/include/ptclib
@@ -88,5 +79,4 @@ src_install() {
else
ln -sf libpt_linux_x86_r.so.${PV} libpt.so
fi
-
}
diff --git a/dev-libs/pwlib/pwlib-1.4.7.ebuild b/dev-libs/pwlib/pwlib-1.4.7.ebuild
deleted file mode 100644
index 427f134b806c..000000000000
--- a/dev-libs/pwlib/pwlib-1.4.7.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/pwlib-1.4.7.ebuild,v 1.8 2003/04/01 12:45:27 liquidx Exp $
-
-S=${WORKDIR}/${PN}
-
-IUSE="ssl"
-
-DESCRIPTION="Libs needed for GnomeMeeting"
-HOMEPAGE="http://www.openh323.org"
-#SRC_URI="http://www.openh323.org/bin/${PN}_${PV}.tar.gz"
-SRC_URI="http://www.gnomemeeting.org/downloads/latest/sources/${PN}_${PV}.tar.gz"
-
-SLOT="0"
-LICENSE="MPL-1.1"
-KEYWORDS="x86 ~ppc -sparc"
-
-DEPEND=">=sys-devel/bison-1.28
- >=sys-devel/flex-2.5.4a
- dev-libs/expat
- ssl? ( dev-libs/openssl )"
-
-src_unpack() {
- ewarn ""
- ewarn "Your compile WILL fail if you are upgrading from"
- ewarn "a previous version of pwlib."
- ewarn ""
- ewarn "emerge unmerge pwlib"
- ewarn "BEFORE upgrading to a newer version"
- ewarn ""
- ewarn "You have been warned :)"
- ewarn ""
- sleep 5
-
- unpack ${A}
- cd ${S}/make
- cp unix.mak unix.mak.orig
- sed \
- -e "s:-mcpu=\$(CPUTYPE)::" \
- -e "s:-O3 -DNDEBUG:-DNDEBUG:" \
- < unix.mak.orig > unix.mak
-
- # patch unix.mak so it doesn't require annoying upgrades
- cp unix.mak unix.mak.orig2
- sed \
- -e "s:-DP_SSL -I\$(OPENSSLDIR)/include -I\$(OPENSSLDIR)/crypto:-DP_SSL:" \
- -e "s:^LDFLAGS.*\+= -L\$(OPENSSLDIR)/lib -L\$(OPENSSLDIR):LDFLAGS +=:" \
- < unix.mak.orig2 > unix.mak
-
- rm unix.mak.orig unix.mak.orig2
-}
-
-src_compile() {
-
- export PWLIBDIR=${S}
- export PWLIB_BUILD="yes"
-
- if [ "`use ssl`" ]; then
- export OPENSSLFLAG=1
- export OPENSSLDIR=/usr
- export OPENSSLLIBS="-lssl -lcrypt"
- fi
-
- make optshared || die
-
- cd tools/asnparser
- make optshared || die
-
-}
-
-src_install() {
-
- dodir /usr/lib /usr/include/ptlib/unix/ptlib \
- /usr/share/pwlib /usr/include/ptclib
-
- cd ${S}
- cp -a lib/*so* ${D}/usr/lib
- cp -a include/ptlib.h ${D}/usr/include
- cp -a include/ptlib/*.h ${D}/usr/include/ptlib/
- cp -a include/ptlib/*.inl ${D}/usr/include/ptlib/
- cp -a include/ptlib/unix/ptlib/*.h ${D}/usr/include/ptlib/unix/ptlib
- cp -a include/ptlib/unix/ptlib/*.inl ${D}/usr/include/ptlib/unix/ptlib
- cp -a include/ptclib/*.h ${D}/usr/include/ptclib/
-
- cp -a * ${D}/usr/share/pwlib/
- rm -rf ${D}/usr/share/pwlib/make/CVS
- rm -rf ${D}/usr/share/pwlib/tools/CVS
- rm -rf ${D}/usr/share/pwlib/tools/asnparser/CVS
- rm -rf ${D}/usr/share/pwlib/src
- rm -rf ${D}/usr/share/pwlib/include/CVS
- rm -rf ${D}/usr/share/pwlib/include/ptlib/unix/CVS
- rm -rf ${D}/usr/share/pwlib/include/ptlib/CVS
-
- cd ${D}/usr/lib
- if [ ${ARCH} = "ppc" ] ; then
- ln -sf libpt_linux_ppc_r.so.${PV} libpt.so
- else
- ln -sf libpt_linux_x86_r.so.${PV} libpt.so
- fi
-
-}
diff --git a/dev-libs/pwlib/pwlib-1.5.0.ebuild b/dev-libs/pwlib/pwlib-1.5.0.ebuild
index 756d8dbc9c9d..0657d2e42289 100644
--- a/dev-libs/pwlib/pwlib-1.5.0.ebuild
+++ b/dev-libs/pwlib/pwlib-1.5.0.ebuild
@@ -1,18 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/pwlib-1.5.0.ebuild,v 1.4 2003/07/02 09:29:52 phosphan Exp $
-
-S=${WORKDIR}/${PN}
-
-IUSE="ssl sdl"
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/pwlib-1.5.0.ebuild,v 1.5 2003/08/03 02:25:45 vapier Exp $
DESCRIPTION="Portable Multiplatform Class Libraries for OpenH323"
-HOMEPAGE="http://www.openh323.org"
+HOMEPAGE="http://www.openh323.org/"
SRC_URI="http://www.openh323.org/bin/${PN}_${PV}.tar.gz"
-SLOT="0"
LICENSE="MPL-1.1"
+SLOT="0"
KEYWORDS="~x86 ~ppc -sparc"
+IUSE="ssl sdl"
DEPEND=">=sys-devel/bison-1.28
>=sys-devel/flex-2.5.4a
@@ -22,22 +19,24 @@ DEPEND=">=sys-devel/bison-1.28
sdl? ( media-libs/libsdl )
ssl? ( dev-libs/openssl )"
+S=${WORKDIR}/${PN}
+
src_unpack() {
unpack ${A}
cd ${S}/make
- # filter out -O3 and -mcpu embedded compiler flags
- sed -e "s:-mcpu=\$(CPUTYPE)::" \
- -e "s:-O3 -DNDEBUG:-DNDEBUG:" \
- -i unix.mak
+ # filter out -O3 and -mcpu embedded compiler flags
+ sed -i \
+ -e "s:-mcpu=\$(CPUTYPE)::" \
+ -e "s:-O3 -DNDEBUG:-DNDEBUG:" \
+ unix.mak
}
src_compile() {
-
if [ "`use ssl`" ]; then
export OPENSSLFLAG=1
- export OPENSSLDIR=/usr
- export OPENSSLLIBS="-lssl -lcrypt"
+ export OPENSSLDIR=/usr
+ export OPENSSLLIBS="-lssl -lcrypt"
fi
econf || die "configure failed"
@@ -78,9 +77,8 @@ src_install() {
fi
# strip ${S} stuff
- sed -i -e "s:^PWLIBDIR.*:PWLIBDIR=/usr/share/pwlib:" ${D}/usr/bin/ptlib-config
- sed -i -e "s:^PWLIBDIR.*:PWLIBDIR=/usr/share/pwlib:" ${D}/usr/share/pwlib/make/ptbuildopts.mak
-
+ dosed "s:^PWLIBDIR.*:PWLIBDIR=/usr/share/pwlib:" /usr/bin/ptlib-config
+ dosed "s:^PWLIBDIR.*:PWLIBDIR=/usr/share/pwlib:" /usr/share/pwlib/make/ptbuildopts.mak
dodoc ReadMe.txt History.txt
}