summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/fping/ChangeLog7
-rw-r--r--net-analyzer/fping/fping-3.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/net-analyzer/fping/ChangeLog b/net-analyzer/fping/ChangeLog
index 072c444e920a..d303021fbe1c 100644
--- a/net-analyzer/fping/ChangeLog
+++ b/net-analyzer/fping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/fping
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fping/ChangeLog,v 1.46 2012/04/01 15:36:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fping/ChangeLog,v 1.47 2012/05/03 15:02:38 jer Exp $
+
+*fping-3.1 (03 May 2012)
+
+ 03 May 2012; Jeroen Roovers <jer@gentoo.org> +fping-3.1.ebuild:
+ Version bump.
01 Apr 2012; Raúl Porcel <armin76@gentoo.org> fping-3.0.ebuild:
alpha/ia64/sparc stable wrt #407153
diff --git a/net-analyzer/fping/fping-3.1.ebuild b/net-analyzer/fping/fping-3.1.ebuild
new file mode 100644
index 000000000000..7c38613a7d34
--- /dev/null
+++ b/net-analyzer/fping/fping-3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fping/fping-3.1.ebuild,v 1.1 2012/05/03 15:02:38 jer Exp $
+
+EAPI=4
+
+inherit flag-o-matic
+
+DESCRIPTION="A utility to ping multiple hosts at once"
+HOMEPAGE="http://fping.org/"
+SRC_URI="http://fping.org/dist/${P}.tar.gz"
+
+LICENSE="fping"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="ipv6"
+
+src_prepare() {
+ if use ipv6; then
+ cp -a "${S}" "${S}-6"
+ fi
+}
+
+src_configure() {
+ default
+ if use ipv6; then
+ cd "${S}-6"
+ append-flags -DIPV6
+ econf
+ fi
+}
+
+src_compile() {
+ default
+ if use ipv6; then
+ cd "${S}-6"
+ emake
+ fi
+}
+
+src_install () {
+ dosbin "${S}"/src/${PN}
+ fperms 4555 /usr/sbin/fping #241930
+ if use ipv6; then
+ newsbin "${S}"-6/src/fping fping6
+ fperms 4555 /usr/sbin/fping6
+ fi
+ doman doc/fping.8
+ dodoc ChangeLog README
+}