summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-extra/evolution-data-server/ChangeLog8
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-2.32.1-r1.ebuild5
-rw-r--r--gnome-extra/evolution-data-server/files/evolution-data-server-2.32.1-no-kerberos.patch125
3 files changed, 136 insertions, 2 deletions
diff --git a/gnome-extra/evolution-data-server/ChangeLog b/gnome-extra/evolution-data-server/ChangeLog
index c3d709bbd08e..b7ef284cb863 100644
--- a/gnome-extra/evolution-data-server/ChangeLog
+++ b/gnome-extra/evolution-data-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-data-server
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.282 2011/01/01 18:03:40 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.283 2011/01/03 14:15:47 pacho Exp $
+
+ 03 Jan 2011; Pacho Ramos <pacho@gentoo.org>
+ evolution-data-server-2.32.1-r1.ebuild,
+ +files/evolution-data-server-2.32.1-no-kerberos.patch:
+ Fix building without kerberos, bug #348260 by Stephan Friedrichs and
+ backported patch from Jonathan-Christofer Demay.
*evolution-data-server-2.32.1-r1 (01 Jan 2011)
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-2.32.1-r1.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-2.32.1-r1.ebuild
index 1a0ced2ae627..c09c1b346fe1 100644
--- a/gnome-extra/evolution-data-server/evolution-data-server-2.32.1-r1.ebuild
+++ b/gnome-extra/evolution-data-server/evolution-data-server-2.32.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-2.32.1-r1.ebuild,v 1.1 2011/01/01 18:03:40 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-2.32.1-r1.ebuild,v 1.2 2011/01/03 14:15:47 pacho Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -69,6 +69,9 @@ src_prepare() {
# Adjust to gentoo's /etc/service
epatch "${FILESDIR}/${PN}-2.31-gentoo_etc_services.patch"
+ # Fix building without kerberos, bug #348260
+ epatch "${FILESDIR}/${PN}-2.32.1-no-kerberos.patch"
+
# Apply upstream patches committed to gnome-2.32 branch
epatch "${WORKDIR}"/${P}-patches/*.patch
diff --git a/gnome-extra/evolution-data-server/files/evolution-data-server-2.32.1-no-kerberos.patch b/gnome-extra/evolution-data-server/files/evolution-data-server-2.32.1-no-kerberos.patch
new file mode 100644
index 000000000000..d042a5f74551
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/evolution-data-server-2.32.1-no-kerberos.patch
@@ -0,0 +1,125 @@
+--- a/camel/camel-sasl-gssapi.c
++++ b/camel/camel-sasl-gssapi.c
+@@ -20,54 +20,61 @@
+ *
+ */
+
++/* If building without Kerberos support, this class is an empty shell. */
++
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+ #endif
+
+ #include <errno.h>
+
+-#ifdef HAVE_KRB5
+ #include <netdb.h>
+ #include <string.h>
+ #include <sys/socket.h>
+ #include <sys/types.h>
++
++#include <gio/gio.h>
++#include <glib/gi18n-lib.h>
++
++#include "camel-net-utils.h"
++#include "camel-sasl-gssapi.h"
++#include "camel-session.h"
++
++#ifdef HAVE_KRB5
++
+ #ifdef HAVE_HEIMDAL_KRB5
+ #include <krb5.h>
+ #else
+ #include <krb5/krb5.h>
+-#endif
++#endif /* HAVE_HEIMDAL_KRB5 */
++
+ #ifdef HAVE_ET_COM_ERR_H
+ #include <et/com_err.h>
+ #else
+ #ifdef HAVE_COM_ERR_H
+ #include <com_err.h>
+-#endif
+-#endif
++#endif /* HAVE_COM_ERR_H */
++#endif /* HAVE_ET_COM_ERR_H */
++
+ #ifdef HAVE_MIT_KRB5
+ #include <gssapi/gssapi.h>
+ #include <gssapi/gssapi_generic.h>
+-#endif
++#endif /* HAVE_MIT_KRB5 */
++
+ #ifdef HAVE_HEIMDAL_KRB5
+ #include <gssapi.h>
+ #else
+-#ifdef HAVE_SUN_KRB5
++#ifdef HAVE_SUN_KRB5
+ #include <gssapi/gssapi.h>
+ #include <gssapi/gssapi_ext.h>
+ extern gss_OID gss_nt_service_name;
+-#endif
+-#endif
++#endif /* HAVE_SUN_KRB5 */
++#endif /* HAVE_HEIMDAL_KRB5 */
+
+ #ifndef GSS_C_OID_KRBV5_DES
+ #define GSS_C_OID_KRBV5_DES GSS_C_NO_OID
+ #endif
+
+-#include <glib/gi18n-lib.h>
+-#include <gio/gio.h>
+-
+-#include "camel-net-utils.h"
+-#include "camel-sasl-gssapi.h"
+-#include "camel-session.h"
+-
+ #define DBUS_PATH "/org/gnome/KrbAuthDialog"
+ #define DBUS_INTERFACE "org.gnome.KrbAuthDialog"
+ #define DBUS_METHOD "org.gnome.KrbAuthDialog.acquireTgt"
+@@ -105,8 +112,12 @@ struct _CamelSaslGssapiPrivate {
+ gss_name_t target;
+ };
+
++#endif /* HAVE_KRB5 */
++
+ G_DEFINE_TYPE (CamelSaslGssapi, camel_sasl_gssapi, CAMEL_TYPE_SASL)
+
++#ifdef HAVE_KRB5
++
+ static void
+ gssapi_set_exception (OM_uint32 major,
+ OM_uint32 minor,
+@@ -413,9 +424,12 @@ sasl_gssapi_challenge (CamelSasl *sasl,
+ return challenge;
+ }
+
++#endif /* HAVE_KRB5 */
++
+ static void
+ camel_sasl_gssapi_class_init (CamelSaslGssapiClass *class)
+ {
++#ifdef HAVE_KRB5
+ GObjectClass *object_class;
+ CamelSaslClass *sasl_class;
+
+@@ -426,16 +440,17 @@ camel_sasl_gssapi_class_init (CamelSaslG
+
+ sasl_class = CAMEL_SASL_CLASS (class);
+ sasl_class->challenge = sasl_gssapi_challenge;
++#endif /* HAVE_KRB5 */
+ }
+
+ static void
+ camel_sasl_gssapi_init (CamelSaslGssapi *sasl)
+ {
++#ifdef HAVE_KRB5
+ sasl->priv = CAMEL_SASL_GSSAPI_GET_PRIVATE (sasl);
+
+ sasl->priv->state = GSSAPI_STATE_INIT;
+ sasl->priv->ctx = GSS_C_NO_CONTEXT;
+ sasl->priv->target = GSS_C_NO_NAME;
+-}
+-
+ #endif /* HAVE_KRB5 */
++}