summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-visualization/qtiplot/ChangeLog9
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.6-fitplugins.patch32
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.6-profile.patch89
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.6.ebuild105
4 files changed, 234 insertions, 1 deletions
diff --git a/sci-visualization/qtiplot/ChangeLog b/sci-visualization/qtiplot/ChangeLog
index 995987c60839..0ab1627b6cea 100644
--- a/sci-visualization/qtiplot/ChangeLog
+++ b/sci-visualization/qtiplot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-visualization/qtiplot
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.22 2008/04/30 15:37:36 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.23 2008/05/18 16:26:49 grozin Exp $
+
+*qtiplot-0.9.6 (19 May 2008)
+
+ 19 May 2008; Andrey Grozin <grozin@gentoo.org>
+ +files/qtiplot-0.9.6-fitplugins.patch, +files/qtiplot-0.9.6-profile.patch,
+ +qtiplot-0.9.6.ebuild:
+ Version bump. Translations are now handled correctly.
*qtiplot-0.9.5-r1 (30 Apr 2008)
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.6-fitplugins.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.6-fitplugins.patch
new file mode 100644
index 000000000000..64e54655df61
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.6-fitplugins.patch
@@ -0,0 +1,32 @@
+diff -U2 -r qtiplot-0.9.6.orig/fitPlugins/fitRational0/fitRational0.pro qtiplot-0.9.6/fitPlugins/fitRational0/fitRational0.pro
+--- qtiplot-0.9.6.orig/fitPlugins/fitRational0/fitRational0.pro 2007-10-29 05:44:06.000000000 +0600
++++ qtiplot-0.9.6/fitPlugins/fitRational0/fitRational0.pro 2008-05-15 10:42:10.000000000 +0700
+@@ -13,10 +13,8 @@
+
+ # statically link against GSL in 3rdparty
+-INCLUDEPATH += ../../3rdparty/gsl/include/
+-LIBS += ../../3rdparty/gsl/lib/libgsl.a
+-LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
++INCLUDEPATH += /usr/include/gsl
+
+ #dynamically link against GSL installed system-wide
+-#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
++unix:LIBS += $$system(pkg-config --libs gsl)
+
+ target.path=/usr/lib$${libsuff}/qtiplot/plugins
+diff -U2 -r qtiplot-0.9.6.orig/fitPlugins/fitRational1/fitRational1.pro qtiplot-0.9.6/fitPlugins/fitRational1/fitRational1.pro
+--- qtiplot-0.9.6.orig/fitPlugins/fitRational1/fitRational1.pro 2007-10-29 05:44:06.000000000 +0600
++++ qtiplot-0.9.6/fitPlugins/fitRational1/fitRational1.pro 2008-05-15 10:43:01.000000000 +0700
+@@ -13,10 +13,8 @@
+
+ # statically link against GSL in 3rdparty
+-INCLUDEPATH += ../../3rdparty/gsl/include/
+-LIBS += ../../3rdparty/gsl/lib/libgsl.a
+-LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
++INCLUDEPATH += /usr/include/gsl
+
+ #dynamically link against GSL installed system-wide
+-#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
++unix:LIBS += $$system(pkg-config --libs gsl)
+
+ target.path=/usr/lib$${libsuff}/qtiplot/plugins
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.6-profile.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.6-profile.patch
new file mode 100644
index 000000000000..18b1a1babfe4
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.6-profile.patch
@@ -0,0 +1,89 @@
+diff -r -U2 qtiplot-0.9.6.orig/qtiplot/qtiplot.pro qtiplot-0.9.6/qtiplot/qtiplot.pro
+--- qtiplot-0.9.6.orig/qtiplot/qtiplot.pro 2008-05-13 17:22:46.000000000 +0700
++++ qtiplot-0.9.6/qtiplot/qtiplot.pro 2008-05-19 05:59:59.000000000 +0700
+@@ -18,8 +18,8 @@
+ # the *.path variables defined bellow.
+ ######################################################################################
+-#CONFIG += CustomInstall
++CONFIG += CustomInstall
+
+-#CONFIG += release
+-CONFIG += debug
++CONFIG += release
++#CONFIG += debug
+ win32: CONFIG += console
+
+@@ -28,10 +28,9 @@
+ #############################################################################
+
+-INCLUDEPATH += ../3rdparty/muparser/include
+-INCLUDEPATH += ../3rdparty/qwtplot3d/include
+-INCLUDEPATH += ../3rdparty/qwt/src
+-INCLUDEPATH += ../3rdparty/liborigin
+-INCLUDEPATH += ../3rdparty/gsl/include
+-INCLUDEPATH += ../3rdparty/zlib123/include
++INCLUDEPATH += /usr/include/muparser
++INCLUDEPATH += /usr/include/qwtplot3d
++INCLUDEPATH += /usr/include/qwt5
++INCLUDEPATH += /usr/include/liborigin
++INCLUDEPATH += /usr/include/gsl
+
+ ##################### 3rd PARTY LIBRARIES SECTION ###########################
+@@ -42,15 +41,17 @@
+
+ # statically link against libraries in 3rdparty
+-unix:LIBS += ../3rdparty/muparser/lib/libmuparser.a
+-unix:LIBS += ../3rdparty/qwtplot3d/lib/libqwtplot3d.a
+-unix:LIBS += ../3rdparty/qwt/lib/libqwt.a
+-unix:LIBS += ../3rdparty/gsl/lib/libgsl.a
+-unix:LIBS += ../3rdparty/gsl/lib/libgslcblas.a
++#unix:LIBS += ../3rdparty/muparser/lib/libmuparser.a
++#unix:LIBS += ../3rdparty/qwtplot3d/lib/libqwtplot3d.a
++#unix:LIBS += ../3rdparty/qwt/lib/libqwt.a
++#unix:LIBS += ../3rdparty/gsl/lib/libgsl.a
++#unix:LIBS += ../3rdparty/gsl/lib/libgslcblas.a
+
+ # dynamically link against dependencies if they are installed system-wide
+-#unix:LIBS += -lmuparser
+-#unix:LIBS += -lqwtplot3d
+-#unix:LIBS += -lqwt
+-#unix:LIBS += -lgsl -lgslcblas
++unix:LIBS += -lmuparser
++unix:LIBS += -lqwtplot3d
++unix:LIBS += -lqwt
++unix:LIBS += $$system(pkg-config --libs gsl)
++unix:LIBS += -lorigin
++unix:LIBS += -lz
+
+ ##################### Windows ###############################################
+@@ -127,5 +128,5 @@
+
+ #system(lupdate -verbose qtiplot.pro)
+-#system(lrelease -verbose qtiplot.pro)
++system(lrelease -verbose qtiplot.pro)
+
+ translations.files += translations/qtiplot_de.qm \
+@@ -141,6 +142,5 @@
+ ../manual/qtiplot-manual-en.pdf
+
+-documentation.files += ../README.html \
+- ../gpl_licence.txt
++documentation.files += ../README.html
+
+ unix: man.files += ../qtiplot.1
+@@ -240,6 +240,6 @@
+ ###############################################################
+
+- HEADERS += ../3rdparty/liborigin/OPJFile.h
+- SOURCES += ../3rdparty/liborigin/OPJFile.cpp
++# HEADERS += ../3rdparty/liborigin/OPJFile.h
++# SOURCES += ../3rdparty/liborigin/OPJFile.cpp
+
+ ###############################################################
+@@ -474,5 +474,5 @@
+ qti_wordlist.txt \
+
+- unix: pythonconfig.path = /usr/local/qtiplot
++ unix: pythonconfig.path = /usr/share/qtiplot
+ win32: pythonconfig.path = $$INSTALLBASE
+ DEFINES += PYTHON_CONFIG_PATH="\\\"$$replace(pythonconfig.path," ","\ ")\\\"
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.6.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.6.ebuild
new file mode 100644
index 000000000000..36354f0040b9
--- /dev/null
+++ b/sci-visualization/qtiplot/qtiplot-0.9.6.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.6.ebuild,v 1.1 2008/05/18 16:26:49 grozin Exp $
+
+EAPI="1"
+inherit eutils multilib qt4
+
+DESCRIPTION="Qt based clone of the Origin plotting package"
+HOMEPAGE="http://soft.proindependent.com/qtiplot.html"
+SRC_URI="http://soft.proindependent.com/src/${P}.tar.bz2
+ doc? ( mirror://gentoo/${P}-manual-en.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="python doc bindist"
+
+LANGS="de es fr ja ru sv"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+CDEPEND=">=x11-libs/qwt-5.1
+ >=x11-libs/qwtplot3d-0.2.7
+ >=dev-cpp/muParser-1.28
+ !bindist? ( sci-libs/gsl )
+ bindist? ( <sci-libs/gsl-1.10 )"
+
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ python? ( >=dev-python/sip-4.5.2 )"
+
+RDEPEND="${CDEPEND}
+ python? ( >=dev-lang/python-2.5
+ dev-python/PyQt4
+ dev-python/pygsl
+ sci-libs/scipy )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-profile.patch
+ epatch "${FILESDIR}"/${P}-fitplugins.patch
+
+ sed -i \
+ -e '/manual/d'\
+ -e '/3rd/d' \
+ qtiplot.pro || die "sed qtiplot.pro failed"
+ sed -i \
+ -e '/manual/d' \
+ -e "s:doc/${PN}:doc/${PF}:" \
+ qtiplot/qtiplot.pro || die " sed for qtiplot/qtiplot.pro failed"
+
+ if ! use python; then
+ sed -i \
+ -e '/^SCRIPTING_LANGS += Python/d' \
+ -e '/sipcmd/d' \
+ qtiplot/qtiplot.pro || die "sed for python option failed"
+ fi
+
+ # the lib$$suff did not work in the fitRational*.pro files
+ sed -i \
+ -e "s|/usr/lib\$\${libsuff}|/usr/$(get_libdir)|g" \
+ fitPlugins/fit*/fitRational*.pro \
+ || die "sed fitRational* failed"
+
+ for l in ${LANGS}; do
+ if ! use linguas_${l}; then
+ sed -i \
+ -e "s:translations/qtiplot_${l}.ts::" \
+ -e "s:translations/qtiplot_${l}.qm::" \
+ qtiplot/qtiplot.pro || die
+ fi
+ done
+}
+
+src_compile() {
+ eqmake4 || die "eqmake4 failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die 'emake install failed'
+ rm -f "${D}"/usr/share/${PN}/translations/*.ts
+
+ newicon qtiplot_logo.png qtiplot.png
+ make_desktop_entry qtiplot QtiPlot qtiplot
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r "${WORKDIR}"/qtiplot-manual-en/* \
+ || die "install manual failed"
+ rm -rf "${D}"/usr/share/doc/${PF}/html/*/.svn
+ fi
+}
+
+pkg_postinst() {
+ if use doc; then
+ elog "On the first start, do Help -> Choose Help Folder"
+ elog "and select /usr/share/doc/${PF}/html"
+ elog "Also do View -> Preferences, in the tab File Locations"
+ elog "set Python Configuration Files to /usr/share/${PN}"
+ elog "and Translations to /usr/share/${PN}/translations"
+ fi
+}