summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/mixlib-authentication/ChangeLog10
-rw-r--r--dev-ruby/mixlib-authentication/mixlib-authentication-1.3.0.ebuild31
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-ruby/mixlib-authentication/ChangeLog b/dev-ruby/mixlib-authentication/ChangeLog
index a74d8312d1d2..eb8a457f2a05 100644
--- a/dev-ruby/mixlib-authentication/ChangeLog
+++ b/dev-ruby/mixlib-authentication/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/mixlib-authentication
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-authentication/ChangeLog,v 1.3 2010/10/09 08:45:42 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-authentication/ChangeLog,v 1.4 2012/08/11 08:11:19 hollow Exp $
+
+*mixlib-authentication-1.3.0 (11 Aug 2012)
+
+ 11 Aug 2012; Benedikt Böhm <hollow@gentoo.org>
+ +mixlib-authentication-1.3.0.ebuild:
+ version bump
09 Oct 2010; Hans de Graaff <graaff@gentoo.org>
-mixlib-authentication-1.1.2.ebuild:
diff --git a/dev-ruby/mixlib-authentication/mixlib-authentication-1.3.0.ebuild b/dev-ruby/mixlib-authentication/mixlib-authentication-1.3.0.ebuild
new file mode 100644
index 000000000000..68af4fdac372
--- /dev/null
+++ b/dev-ruby/mixlib-authentication/mixlib-authentication-1.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-authentication/mixlib-authentication-1.3.0.ebuild,v 1.1 2012/08/11 08:11:19 hollow Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_EXTRADOC="NOTICE README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mixes in simple per-request authentication"
+HOMEPAGE="http://github.com/opscode/mixlib-authentication"
+SRC_URI="https://github.com/opscode/${PN}/tarball/${PV} -> ${P}.tgz"
+RUBY_S="opscode-${PN}-*"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Tests fail. Not clear if this is a regression since the previous
+# ebuild did not run tests. No upstream bug tracker to report the
+# failure to.
+#RESTRICT="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec )"
+
+ruby_add_rdepend "dev-ruby/mixlib-log"