summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-embedded/u-boot-tools/ChangeLog8
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2012.10.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-embedded/u-boot-tools/ChangeLog b/dev-embedded/u-boot-tools/ChangeLog
index 561a84a10f2c..97a77cb2cf91 100644
--- a/dev-embedded/u-boot-tools/ChangeLog
+++ b/dev-embedded/u-boot-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-embedded/u-boot-tools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/u-boot-tools/ChangeLog,v 1.26 2012/09/05 04:51:29 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/u-boot-tools/ChangeLog,v 1.27 2012/11/09 21:53:32 hwoarang Exp $
+
+*u-boot-tools-2012.10 (09 Nov 2012)
+
+ 09 Nov 2012; Markos Chandras <hwoarang@gentoo.org>
+ +u-boot-tools-2012.10.ebuild:
+ Version bump. Bug #437576
05 Sep 2012; Tim Harder <radhermit@gentoo.org>
-files/2011.09/0001-Build-timestamp_autogenerated.h-without-config.patch,
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2012.10.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2012.10.ebuild
new file mode 100644
index 000000000000..7fa49aa362cf
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2012.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/u-boot-tools/u-boot-tools-2012.10.ebuild,v 1.1 2012/11/09 21:53:32 hwoarang Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e "s:-g ::" tools/Makefile || die
+ # We don't have a config.h as we are building
+ # for host and not for a board
+ sed -i -e "/config.h/d" tools/env/fw_env.c || die
+ # All this insanity is not required if there is no
+ # /usr/include/image.h installed
+ if [[ -e ${ROOT}/usr/include/image.h ]]; then
+ ewarn "A image.h header is installed in /usr/include/"
+ ewarn "Fixing u-boot files to use the local image.h header"
+ # FIXME: HACK. media-libs/lensfun installs image.h
+ # Copy local image.h to tools/ and common.h directory
+ cp include/image.h common/image.h || die
+ cp include/image.h tools/image.h || die
+ sed -i -e "s:<image.h>:\"image.h\":" common/image.c || die
+ # Fix headers so local copy is picked up first
+ grep -r "<image\.h>" tools/* | cut -d ":" -f 1 | \
+ xargs sed -i -e "s:<image.h>:\"image.h\":" || die
+ fi
+}
+
+src_compile() {
+ emake \
+ HOSTSTRIP=echo \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ tools-all
+}
+
+src_install() {
+ cd tools env
+ dobin bmp_logo gen_eth_addr img2srec mkimage
+ dobin easylogo/easylogo
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+}