summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/dbus/ChangeLog9
-rw-r--r--sys-apps/dbus/dbus-1.0.1-r1.ebuild5
-rw-r--r--sys-apps/dbus/dbus-1.0.1-r2.ebuild119
-rw-r--r--sys-apps/dbus/files/dbus-1.0.1-fixfilecreation.patch11
-rw-r--r--sys-apps/dbus/files/digest-dbus-1.0.1-r23
5 files changed, 145 insertions, 2 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index 647e373e12c5..8f9762b38a31 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/dbus
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.156 2006/12/02 20:21:29 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.157 2006/12/04 17:33:35 cardoe Exp $
+
+*dbus-1.0.1-r2 (04 Dec 2006)
+
+ 04 Dec 2006; Doug Goldstein <cardoe@gentoo.org>
+ +files/dbus-1.0.1-fixfilecreation.patch, dbus-1.0.1-r1.ebuild,
+ +dbus-1.0.1-r2.ebuild:
+ Fix dnotify on file creation
02 Dec 2006; Doug Goldstein <cardoe@gentoo.org> dbus-0.62-r1.ebuild:
Fix bug #156225. Masking -fstack-protector-all
diff --git a/sys-apps/dbus/dbus-1.0.1-r1.ebuild b/sys-apps/dbus/dbus-1.0.1-r1.ebuild
index 266fbe8549b4..7e33a2f71d0a 100644
--- a/sys-apps/dbus/dbus-1.0.1-r1.ebuild
+++ b/sys-apps/dbus/dbus-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.0.1-r1.ebuild,v 1.1 2006/11/19 17:32:33 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.0.1-r1.ebuild,v 1.2 2006/12/04 17:33:35 cardoe Exp $
WANT_AUTOCONF=2.5
inherit eutils multilib debug autotools
@@ -30,6 +30,9 @@ src_unpack() {
# fix assertion failure with pthreads
epatch "${FILESDIR}"/${PN}-1.0.1-pthread-holder-fix.diff
+
+ # fix dnotify issue with not detecting created files
+ epatch "${FILESDIR}"/${PN}-1.0.1-fixfilecreation.patch
}
src_compile() {
diff --git a/sys-apps/dbus/dbus-1.0.1-r2.ebuild b/sys-apps/dbus/dbus-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..90aec7660373
--- /dev/null
+++ b/sys-apps/dbus/dbus-1.0.1-r2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.0.1-r2.ebuild,v 1.1 2006/12/04 17:33:35 cardoe Exp $
+
+WANT_AUTOCONF=2.5
+inherit eutils multilib debug autotools
+
+DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/dbus/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc selinux X"
+
+RDEPEND="X? ( x11-libs/libXt x11-libs/libX11 )
+ selinux? ( sys-libs/libselinux )
+ >=dev-libs/expat-1.95.8
+ !<sys-apps/dbus-0.91"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen
+ app-text/xmlto )"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # fix assertion failure with pthreads
+ epatch "${FILESDIR}"/${PN}-1.0.1-pthread-holder-fix.diff
+
+ # fix dnotify issue with not detecting created files
+ epatch "${FILESDIR}"/${PN}-1.0.1-fixfilecreation.patch
+}
+
+src_compile() {
+ local myconf=""
+
+ hasq test ${FEATURES} && myconf="${myconf} --enable-tests=yes"
+
+ econf \
+ $(use_with X x) \
+ $(use_enable kernel_linux dnotify) \
+ $(use_enable kernel_FreeBSD kqueue) \
+ $(use_enable selinux) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable debug asserts) \
+ --with-xml=expat \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-socket=/var/run/dbus/system_bus_socket \
+ --with-session-socket-dir=/tmp \
+ --with-dbus-user=messagebus \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-docs) \
+ --disable-xml-docs \
+ ${myconf} \
+ || die "econf failed"
+
+ # after the compile, it uses a selinuxfs interface to
+ # check if the SELinux policy has the right support
+ use selinux && addwrite /selinux/access
+
+ emake || die "make failed"
+}
+
+src_test() {
+ DBUS_VERBOSE=1 make check || die "make check failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # initscript
+ newinitd "${FILESDIR}"/dbus.init-1.0 dbus
+
+ # dbus X session script (#77504)
+ # turns out to only work for GDM. has been merged into other desktop
+ # (kdm and such scripts)
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/30-dbus
+
+ # needs to exist for the system socket
+ keepdir /var/run/dbus
+ # needs to exist for machine id
+ keepdir /var/lib/dbus
+
+ keepdir /usr/lib/dbus-1.0/services
+ keepdir /usr/share/dbus-1/services
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO
+ if use doc; then
+ dohtml doc/*html
+ fi
+}
+
+pkg_preinst() {
+ enewgroup messagebus || die "Problem adding messagebus group"
+ enewuser messagebus -1 "-1" -1 messagebus || die "Problem adding messagebus user"
+}
+
+pkg_postinst() {
+ elog "To start the D-Bus system-wide messagebus by default"
+ elog "you should add it to the default runlevel :"
+ elog "\`rc-update add dbus default\`"
+ elog
+ elog "If dbus is already installed and running,"
+ elog "run etc-update and then run the following:"
+ elog "\`/etc/init.d/dbus reload\`"
+ elog "This will cause it to reload it's configs but"
+ elog "*not* run the newest version you just installed."
+ elog "You must tell it to restart for that to happen,"
+ elog "however not all apps can handle a D-Bus restart."
+ elog
+ ewarn
+ ewarn "You MUST run 'revdep-rebuild' after emerging this package"
+ ewarn
+}
diff --git a/sys-apps/dbus/files/dbus-1.0.1-fixfilecreation.patch b/sys-apps/dbus/files/dbus-1.0.1-fixfilecreation.patch
new file mode 100644
index 000000000000..0dabf2cc68cd
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-1.0.1-fixfilecreation.patch
@@ -0,0 +1,11 @@
+--- dbus-1.0.0/bus/dir-watch-dnotify.c.fixfilecreation 2006-11-22 14:24:01.000000000 +0100
++++ dbus-1.0.0/bus/dir-watch-dnotify.c 2006-11-22 14:26:06.000000000 +0100
+@@ -57,7 +57,7 @@
+ goto out;
+ }
+
+- if (fcntl (fd, F_NOTIFY, DN_DELETE|DN_RENAME|DN_MODIFY) == -1)
++ if (fcntl (fd, F_NOTIFY, DN_CREATE|DN_DELETE|DN_RENAME|DN_MODIFY) == -1)
+ {
+ _dbus_warn ("Cannot setup D_NOTIFY for '%s' error '%s'\n", dir, _dbus_strerror (errno));
+ close (fd);
diff --git a/sys-apps/dbus/files/digest-dbus-1.0.1-r2 b/sys-apps/dbus/files/digest-dbus-1.0.1-r2
new file mode 100644
index 000000000000..7660510d0186
--- /dev/null
+++ b/sys-apps/dbus/files/digest-dbus-1.0.1-r2
@@ -0,0 +1,3 @@
+MD5 52c70d18fe0b398f5de3b8a18a589960 dbus-1.0.1.tar.gz 1406595
+RMD160 2270f27d9314f0e7b99540f0aa1902b8d0d7343d dbus-1.0.1.tar.gz 1406595
+SHA256 6e0730a39485fb502d640841f0f328c1a0212743f17b3fa61c78e6e32925f061 dbus-1.0.1.tar.gz 1406595