summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmcalendar/ChangeLog6
-rw-r--r--x11-plugins/wmcalendar/files/wmcalendar-0.5.0.makefile.patch30
2 files changed, 35 insertions, 1 deletions
diff --git a/x11-plugins/wmcalendar/ChangeLog b/x11-plugins/wmcalendar/ChangeLog
index a330a352723f..a31648ecec07 100644
--- a/x11-plugins/wmcalendar/ChangeLog
+++ b/x11-plugins/wmcalendar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmcalendar
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcalendar/ChangeLog,v 1.1 2004/03/06 02:20:55 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcalendar/ChangeLog,v 1.2 2004/03/20 12:33:48 pyrania Exp $
+
+ 20 Mar 2004; Markus Nigbur <pyrania@gentoo.org>
+ files/wmcalendar-0.5.0.makefile.patch:
+ Added Makefile patch. Closing bug #28951.
*wmcalendar-0.5.0 (06 Mar 2004)
diff --git a/x11-plugins/wmcalendar/files/wmcalendar-0.5.0.makefile.patch b/x11-plugins/wmcalendar/files/wmcalendar-0.5.0.makefile.patch
new file mode 100644
index 000000000000..6c13f109a469
--- /dev/null
+++ b/x11-plugins/wmcalendar/files/wmcalendar-0.5.0.makefile.patch
@@ -0,0 +1,30 @@
+diff -ur wmcalendar-0.5.0/Src/Makefile /wmcalendar-0.5.0/Src/Makefile
+--- wmcalendar-0.5.0/Src/Makefile 2003-07-15 17:19:26.000000000 +0200
++++ /wmcalendar-0.5.0/Src/Makefile 2003-09-17 08:36:48.000000000 +0200
+@@ -1,4 +1,7 @@
+-CC = gcc
++ifndef CC
++ CC = gcc
++endif
++
+ INCLUDES = `pkg-config --cflags gtk+-2.0` -I.
+ LFLAGS = `pkg-config --libs gtk+-2.0`
+
+@@ -6,7 +9,7 @@
+ #INCLUDES = `gtk12-config --cflags` -I.
+ #LFLAGS = `gtk12-config --libs`
+ X11BASE = /usr/X11R6
+-CFLAGS = $(INCLUDES) -DICON_TYPE=$(ICON_TYPE)
++MY_CFLAGS = $(CFLAGS) $(INCLUDES) -DICON_TYPE=$(ICON_TYPE)
+ INCDIR = -I$(X11BASE)/include/X11 -I$(X11BASE)/include -I$/usr/include -I$/usr/local/include
+ DESTDIR= /usr/local
+ LIBDIR = -L/usr/lib -L${X11BASE}/lib -L/usr/local/lib
+@@ -24,7 +27,7 @@
+ calendar.o
+
+ .c.o:
+- $(CC) $(CFLAGS) -D`uname -s` -DHAVE_SYS_TIME_H -c $< -o $*.o $(INCDIR)
++ $(CC) $(MY_CFLAGS) -D`uname -s` -DHAVE_SYS_TIME_H -c $< -o $*.o $(INCDIR)
+
+
+ all: wmCalendar.o wmCalendar